Download it now!
Bug 134770 - Crash deleting content since 6.3 (tracking changes enabled)
Summary: Crash deleting content since 6.3 (tracking changes enabled)
Status: RESOLVED DUPLICATE of bug 133967
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard:
Keywords: bibisectRequest, haveBacktrace, regression
Depends on:
Blocks: redline-regressions
  Show dependency treegraph
 
Reported: 2020-07-13 08:01 UTC by Telesto
Modified: 2020-11-19 11:09 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["sw::GotoPrevLayoutTextFrame(SwNodeIndex &,SwRootFrame const *)"]


Attachments
backtrace from Linux (9.37 KB, text/plain)
2020-07-18 22:03 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-07-13 08:01:15 UTC
Description:
Crash deleting content since 7.0

Steps to Reproduce:
1. Open attachment 162927 [details]
2. Scroll to the bottom of the file
3. Select page 8 Serbest Cumhuriyet Fırkası(12 Ağustos 1930) until bottom
4. Press Backspace -> Crash

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: c48e4d795e37f23b71d647247590807ab9e52223
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-07-13 08:04:39 UTC
The table on page 10-11 is causing it
Comment 2 Telesto 2020-07-13 08:07:40 UTC
Shorter version
1. CTRL+A
2. CTRL+X
Comment 3 Telesto 2020-07-13 08:17:19 UTC
(In reply to Telesto from comment #2)
> Shorter version
> 1. CTRL+A
> 2. CTRL+X

This one already found in 6.3
Comment 4 Attila Baraksó (NISZ) 2020-07-13 17:33:00 UTC
Reproduced in:

Version: 7.1.0.0.alpha0+ (x64)
Build ID: ffe503b62f9a508285ed06ef977f91604130579a
CPU szálak: 4; OS: Windows 10.0 Build 17134; Felületmegjelenítés: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: CL
Comment 5 Attila Baraksó (NISZ) 2020-07-13 17:36:26 UTC
Bibisected using bibisect-win32-6-3. to:
URL: https://cgit.freedesktop.org/libreoffice/core/commit/?id=32902f66e7749b2d06d13f50416be5323a0c0ea9
author: Michael Stahl <Michael.Stahl@cib.de>
committer: Michael Stahl <Michael.Stahl@cib.de>
summary: sw_redlinehide: make layout based Show/Hide mode the default

Adding CC: Michael Stahl
Comment 6 Terrence Enger 2020-07-18 22:03:06 UTC
Created attachment 163248 [details]
backtrace from Linux

I collected the attached "backtrace" full from local build of commit 0d45380c, configured

    --with-vendor=Terrence Enger
    --with-jdk-home=/usr/lib/jvm/default-java
    --enable-split-debug
    --enable-gdb-index
    --enable-ld=gold
    --enable-option-checking=fatal
    #--enable-dbgutil
    --enable-debug
    --without-system-postgresql
    --without-myspell-dicts
    --with-extra-buildid
    --without-doxygen
    --with-external-tar=/home/terry/lo_hacking/git/src
    --without-package-format

built and running on debain-buster.
Comment 7 Telesto 2020-07-25 12:29:25 UTC
Needs a new bibisect

Bibisect with ExperimentalMode enabled & export SW_REDLINEHIDE=1
Comment 8 Terrence Enger 2020-07-26 14:55:07 UTC
I see the bug in bibisect-linux-64-6.3 version oldest.  The closest
preceding version that I have is bibisect-linux-64-6.2 master, and it
procedes through the given STR without obvious problem.  Those commits
are 6 months apart, so this determination is unhelpful.


However, after bibisect-linux-64-6.2 master procedes through the given
STR, <ctrl>+Z produces Application Error (Signal 6).  Work on
debian-buster in bibisect-linux-6.1 points the introduction of this
behavior to:

          commit    s-h       date
          --------  --------  -------------------
    good  43c2ce41  b524de95  2018-04-11 14:43:30
    bad   dfd95d65  7db137e8  2018-04-11 15:11:32

and the commit message is:

    commit 7db137e87177dbe381186491ca36e3e8fd62ddc2
    Author:     Michael Stahl <Michael.Stahl@cib.de>
    AuthorDate: Wed Apr 11 14:31:47 2018 +0200
    Commit:     Michael Stahl <Michael.Stahl@cib.de>
    CommitDate: Wed Apr 11 17:11:32 2018 +0200

        tdf#50057 sw: fix duplication of at-paragraph anchored flys
    
        The problem is that the flys that are anchored to the first paragraph of
        a SwRedline do get copied by SwRangeRedline::CopyToSection(), but they
        don't get deleted by DelCopyOfSection().
    
        Copying is enabled because the setting of the SetRedlineMove()
        was made conditional in commit 65de5382a389cc7edf1cdf506da4fb43a4d33a9f
        "#100619# fixed problem with hiding deleted graphics",
        which isn't justified in any way and which i can't imaginge a good reason
        for, given that the flys anchored in the first paragraph are all skipped
        in DelFlyInRange(), so why would you want to copy them; hence this
        reverts that commit.
    
        The interesting check for the redline_fly_duplication_at_para_end_inside
        case is actually the one that was added in commit
        23e52c207760c596cc2f841ef59f3100c110d591
    
        Change-Id: I96fb294a5456e7f1172a5f408ebcb21cf211c276
        Reviewed-on: https://gerrit.libreoffice.org/52729
        Tested-by: Jenkins <ci@libreoffice.org>
        Reviewed-by: Michael Stahl <Michael.Stahl@cib.de>


As what I have bibisected is not the reported bug, I am leaving
keyword bibisectRequest.
Comment 9 Michael Stahl (CIB) 2020-07-31 09:32:22 UTC
was fixed by 14e87a4b15d31a34e6053f6194688f3aa23af991

*** This bug has been marked as a duplicate of bug 133967 ***