Bug 133967 - Crash swlo!SwDoc::GotoOutline+0x59c
Summary: Crash swlo!SwDoc::GotoOutline+0x59c
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:7.1.0 target:7.0.1 target:6.4.7
Keywords: bibisected, bisected, haveBacktrace
: 134006 134770 134839 (view as bug list)
Depends on:
Blocks: Crash
  Show dependency treegraph
 
Reported: 2020-06-13 18:40 UTC by Telesto
Modified: 2020-08-05 10:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
bt with debug symbols (gen) (6.43 KB, text/plain)
2020-06-14 19:36 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-06-13 18:40:16 UTC
Description:
Crash swlo!SwDoc::GotoOutline+0x59c

Steps to Reproduce:
1. Open https://bz.apache.org/ooo/attachment.cgi?id=57837
2. Got to page 4 "Detailed Specification" select the text to bottom 
3. Press CTRL+X crash



Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: a201ab6f47c2d5a7ba4c5f998b0aa231cae82010
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-06-13 18:42:04 UTC
No crash in 4.4.7.2.. However not everything is cut (and crashes at undo)
Comment 2 Julien Nabet 2020-06-14 19:36:36 UTC
Created attachment 161997 [details]
bt with debug symbols (gen)

On pc Debian x86-64 with master sources updated today, I got an assertion.
Comment 3 Xisco Faulí 2020-06-15 10:16:04 UTC
Also crashes if the content from page 4 to the end is deleted
Comment 4 Aron Budea 2020-06-21 02:10:15 UTC
Not sure what "to bottom" in step 2 refers to in the description, but I could reproduce the crash based on Xisco's comment.

Bibisected to the 6.2 backport of the following commit using repo bibisect-linux-64-6.2. Adding CC: to Michael Stahl.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=32902f66e7749b2d06d13f50416be5323a0c0ea9
author		Michael Stahl <Michael.Stahl@cib.de>	2018-11-30 17:54:41 +0100
committer	Michael Stahl <Michael.Stahl@cib.de>	2018-12-18 17:55:30 +0100

sw_redlinehide: make layout based Show/Hide mode the default
Comment 6 Commit Notification 2020-07-27 09:17:36 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/14e87a4b15d31a34e6053f6194688f3aa23af991

tdf#133967 sw_redlinehide: fix redline deletion of table containing redlines

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-07-28 08:58:11 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c363568fcedb6b7b425b735614db0600a0362ead

tdf#133967 sw_redlinehide: delete existing MergedPara before

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-07-28 08:59:22 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b33034e7faee2cb8a602ed3342803bf731da8a8b

tdf#133967 sw_redlinehide: fix assert on undo-redo-undo

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Michael Stahl (CIB) 2020-07-28 13:55:54 UTC
fixed on master
Comment 10 Commit Notification 2020-07-28 20:10:03 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/49d1ef7907f5a7a0934fbfa03318ddc6d3ad69b8

tdf#133967 sw_redlinehide: fix redline deletion of table containing redlines

It will be available in 7.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-07-28 20:10:15 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/bf69a8761bf5595aa3db6dc18c34352f2d00412c

tdf#133967 sw_redlinehide: delete existing MergedPara before

It will be available in 7.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2020-07-28 20:11:25 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/3afb71ee89f450217cbe232d636f40f10d425198

tdf#133967 sw_redlinehide: fix assert on undo-redo-undo

It will be available in 7.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2020-07-30 08:35:35 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a6e02f6337f038a445b858bb91bf14d1a14768e4

tdf#133967: sw_uiwriter: Add unittest

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Xisco Faulí 2020-07-30 09:23:17 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: 231e1e416c039d1f9724962a89cf0573a3db48a2
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Michael, thanks for fixing this issue!!
Comment 15 Commit Notification 2020-07-30 09:31:15 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/84a97498abdf5590e36f2845f7ddd13a4335431e

tdf#133967 sw_redlinehide: fix redline deletion of table containing redlines

It will be available in 6.4.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2020-07-30 09:31:39 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/e7e268d0709df6dffa20fb254522f916069262b2

tdf#133967 sw_redlinehide: fix assert on undo-redo-undo

It will be available in 6.4.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2020-07-30 09:32:50 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/6910f03678b93e92bd7dfb43ee6b2356a550de2e

tdf#133967 sw_redlinehide: delete existing MergedPara before

It will be available in 6.4.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2020-07-30 11:31:43 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/a77ad868f12038a28634fb110fc5e77390d5584e

tdf#133967: sw_uiwriter: Add unittest

It will be available in 7.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Michael Stahl (CIB) 2020-07-31 09:32:22 UTC
*** Bug 134770 has been marked as a duplicate of this bug. ***
Comment 20 Commit Notification 2020-07-31 09:46:58 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/a6753768fe914fb110bc4e4def4699b8e54b7e49

tdf#133967: sw_uiwriter: Add unittest

It will be available in 6.4.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Xisco Faulí 2020-08-03 09:52:22 UTC
*** Bug 134839 has been marked as a duplicate of this bug. ***
Comment 22 Xisco Faulí 2020-08-05 10:48:51 UTC
*** Bug 134006 has been marked as a duplicate of this bug. ***