Bug 135878 - Highlighting of paragraph style gets overwritten by direct formatting no fill
Summary: Highlighting of paragraph style gets overwritten by direct formatting no fill
Status: RESOLVED DUPLICATE of bug 135871
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Formatting-Text-Diverse
  Show dependency treegraph
 
Reported: 2020-08-18 11:36 UTC by Telesto
Modified: 2020-09-26 11:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screencast (443.26 KB, video/mp4)
2020-09-15 21:42 UTC, Telesto
Details
Screencast2 (944.65 KB, video/mp4)
2020-09-15 21:47 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-18 11:36:51 UTC
Description:
Highlighting of paragraph style gets overwritten by direct formatting no fill

Steps to Reproduce:
1. Ope the attachment 164406 [details] (bug 135876)
2. Select the first sentence on the page
3. Notice the page style being hello
4. Open Sidebar -> Right click Hello -> Modify -> Font Effects tab -> Notice black is explicitly set 
5. Press cancel
6. Drag it after "Lightning" (red) -> See bug 135876
7. Now drag it back to the initial position -> Highlighting gone -> Overwritten by Highlighting no fill (bug 135871)
8. Drag the text between the purple formatted text -> nothing happens; it's is of course correct (as there is no DF)
9. Undo everything or file reload
10. Now select Highlighting (last word on the page; red) by double clicking
11. right Click -> Character -> Quotation style
12. Drag first sentence after "Highlighting"
13. Text will be red (Direct formatting) and cursive (Character formatting)
14. Drag the text back to original position
15. Clear direct formatting -> Issue still not solved; as we have a character style in it too

If bug 135871 gets solved this would be gone. If bug 135876 gets solved this should be gone. However solution of bug 135871 is technically only masking/hiding bug 135876

This report is only intended for demonstration purposes, as it can drive you nuts


Actual Results:
Highlighting removed

Expected Results:
Still present


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: <buildversion>
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-08-18 11:41:15 UTC
As I love bring this up once in a while; as there is some tendency to downplay this of present it as a kind of feature if IRCC
Comment 2 Heiko Tietze 2020-09-14 14:41:34 UTC
Please make shorter lists of steps. Assuming you think PS must not be overriden by DF, which is wrong. Direct formatting will always overrule other formatting. =>NAB

There are many other issues around this, discussing the same topic with slightly different facets is a bit tedious.
Comment 3 Thomas Lendo 2020-09-15 21:01:39 UTC
I've problems to reproduce these steps. At some steps (e.g 7 and 13) I get other results as Telesto.

As Heiko said, direct formatting beats style formatting. Maybe the cause for this report is misunderstanding of complex formatting behavior?

When I've 2 paragraphs and the first one is formatted with a style that has a highlight color and the second one is formatted with direct formatting highlight color (e.g. with character dialog (not character style dialog!) or highlight color button in toolbar), and if you move the first one to the position directly behind the second one, then the highlight color from direct formatting of the second one will "overwrite" the style highlight color.

When both paragraphs are formatted differently, then the pasted text will be formatted like the text before as a paragraph can't have more than 1 paragraph style.
Comment 4 Telesto 2020-09-15 21:42:38 UTC
Created attachment 165553 [details]
Screencast
Comment 5 Telesto 2020-09-15 21:47:21 UTC
Created attachment 165554 [details]
Screencast2
Comment 6 Telesto 2020-09-15 21:54:57 UTC
(In reply to Thomas Lendo from comment #3)
> I've problems to reproduce these steps. At some steps (e.g 7 and 13) I get
> other results as Telesto.
> 
> As Heiko said, direct formatting beats style formatting. Maybe the cause for
> this report is misunderstanding of complex formatting behavior?

Partly, I think
Comment 7 Thomas Lendo QA 2020-09-20 19:13:22 UTC
I tend to set it as duplicate of bug 135871
Comment 8 Thomas Lendo QA 2020-09-26 11:53:49 UTC

*** This bug has been marked as a duplicate of bug 135871 ***