Bug 141965 - character and numbering Style edit icon in the toolbar don't refer to good style category edit box
Summary: character and numbering Style edit icon in the toolbar don't refer to good st...
Status: RESOLVED DUPLICATE of bug 88512
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-29 07:26 UTC by bentusiii@yahoo.fr
Modified: 2021-05-15 04:56 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bentusiii@yahoo.fr 2021-04-29 07:26:09 UTC
Description:
The toolbar icons for "character style edit" ans "list style edit" in the "style format" toolbar (which need to be activated in "personnalise..." settings) are not referring to the corresponding styles catgories but to "paragraph styles" each time. thus there are three time the same "paragraph style edit" icon's target in the toolbar despite different icon names and (supposed) purpose.

Steps to Reproduce:
Steps to Reproduce:
* warning : all "denominations" are estmated from french locale from memory (can't go back to english locale).

1. go to "menu / display / toolbar/ personnalise".

2. select "toolbar" tab, then select the target "style format" toolbar as a destination for settings (right side). Activate all the unactivated "charcter style edit" and "list style edit" icons (the ones with the same icon as the "paragraph style edit" icon at the beginning of the same toolbar) -- OR search fort "style" in the left side "all icons available" list and apply them in any toolbar. Validate and go back to main window.

3. try to edit different "character style" (need to have created someones at first and, i guess, to place the cursor on one of them applied in the text) from the corresponding icon. Do the same for other "list style icon" icon. 



Actual Results:
Click on the icon open only paragraph styles in each of the thee icons, which is not the actual purpose.

Expected Results:
Click on the icon open corresponding "character style edit" or "list style edit" settings boxes.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
see aloso Bug 141958
Comment 1 bentusiii@yahoo.fr 2021-04-29 11:06:58 UTC
Same problem with the icon "create new style from selection" , same logic but different process : the "new style dialog box only present paragraph styles > user should be able to select which "style category" to create new style in.

-> need a separate new bug report ?
Comment 2 Dieter 2021-05-15 04:55:16 UTC
(In reply to bentusiii@yahoo.fr from comment #0)
> Description:
> The toolbar icons for "character style edit" ans "list style edit" in the
> "style format" toolbar (which need to be activated in "personnalise..."
> settings) are not referring to the corresponding styles catgories but to
> "paragraph styles" each time. thus there are three time the same "paragraph
> style edit" icon's target in the toolbar despite different icon names and
> (supposed) purpose.

Character style is bug 130260, which is a duplicate of bug 88512
List style is bug 130228, which is a duplicate of bug 107000

*** This bug has been marked as a duplicate of bug 88512 ***
Comment 3 Dieter 2021-05-15 04:56:42 UTC
(In reply to bentusiii@yahoo.fr from comment #1)
> Same problem with the icon "create new style from selection" , same logic
> but different process : the "new style dialog box only present paragraph
> styles > user should be able to select which "style category" to create new
> style in.
> 
> -> need a separate new bug report ?

Yes, but please search for duplicates before