Bug 145037 - UI: Animation list, show all entry's by default. Add search & drop down to filter
Summary: UI: Animation list, show all entry's by default. Add search & drop down to fi...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:7.3.0
Keywords:
: 149030 (view as bug list)
Depends on:
Blocks: Sidebar-Animation
  Show dependency treegraph
 
Reported: 2021-10-10 09:08 UTC by Telesto
Modified: 2022-05-23 23:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2021-10-10 09:08:50 UTC
Description:
UI: Animation list, show all entry's by default (and use the drop down to filter)

Steps to Reproduce:
1. Open Impress
2. Select textbox
3. Sidebar -> Animation tab
4. Click + button
5. You have to pick a topic an scroll

Actual Results:
All sorts of subsections. Nasty scrolling (except if you know what you want)

Expected Results:
Options -> Customize dialog -> Menu tab has search field & category's. Which looks simpler to me 

The category (basic/ special/exiting could be a column) instead of some kind of tree hierarchy with those being added to the list. 



Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 93115d2c54d645bcf2f80fde325e3ede39dee4d5
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2021-10-10 09:09:23 UTC
(except if you know what you want) should be 'especially if you know what you want'
Comment 2 Heiko Tietze 2021-10-11 07:38:29 UTC
Don't like the idea to make the workflow easier by adding complexity to the UI. Point is that you have less space after adding a search field. What works is a splitter, which could allow to resize the upper part (applied animations) to get more space on the lower. 

Ultimately I would limit the list to the last used n item (or even better animations including other attributes). See also bug 145038
Comment 3 Telesto 2021-10-11 07:43:51 UTC
(In reply to Heiko Tietze from comment #2)
> Don't like the idea to make the workflow easier by adding complexity to the
> UI. Point is that you have less space after adding a search field. What
> works is a splitter, which could allow to resize the upper part (applied
> animations) to get more space on the lower. 
> 
> Ultimately I would limit the list to the last used n item (or even better
> animations including other attributes). See also bug 145038

A splitter would be already an improvement. Limited list is also welcome. But where do you want to put the rest of the entry's?
Comment 4 Heiko Tietze 2021-10-11 07:46:35 UTC
(In reply to Telesto from comment #3)
> But where do you want to put the rest of the entry's?

In the requested dialog, see bug 145038.
Comment 5 Telesto 2021-10-11 09:55:00 UTC
(In reply to Heiko Tietze from comment #4)
> (In reply to Telesto from comment #3)
> > But where do you want to put the rest of the entry's?
> 
> In the requested dialog, see bug 145038.

Well OK, I didn't read your comment at bug 145038 that way :-). However UX uses a different language ;-). So I'm going lets wait and see mode
Comment 6 Heiko Tietze 2021-10-14 12:30:37 UTC
The topic was on the agenda of the design meeting but hasn't received further input. Resolving WF since search/filter adds control and clutter. Will do the splitter however as a related implementation.
Comment 7 Commit Notification 2021-10-20 05:12:50 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/279cc2aa9d8e5e53762352415c05c262fb1d906f

Related tdf#145037 and tdf#145028 - Animation sidebar usability

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Heiko Tietze 2022-05-11 09:49:27 UTC
*** Bug 149030 has been marked as a duplicate of this bug. ***
Comment 9 Heiko Tietze 2022-05-23 07:00:36 UTC
*** Bug 142821 has been marked as a duplicate of this bug. ***
Comment 10 Eyal Rozenberg 2022-05-23 07:21:37 UTC
I don't understand what this bug is about, nor the reproduction instructions.

> 1. Open Impress
> 2. Select [an empty] textbox
> 3. Sidebar -> Animation tab
> 4. Click + button

I performed this. A new animation effect was created

> 5. You have to pick a topic an[d] scroll

This is not an action. Also... huh? I have to "pick a topic"? I have to scroll? Why? What for?

> All sorts of subsections. Nasty scrolling (except if you know what you want)

Subsections? Of what? And what are "sections" here? What scrolling are we talking about, and why is it nasty? 


> UI: Animation list, show all entry's by default (and use the drop down to
> filter)

Do you mean that, the controls on the side-bar changing the current selected effect would  serve as filters on the list of animations, when there is no item selected?

> Expected Results:
> Options -> Customize dialog -> Menu tab has search field & category's. Which
> looks simpler to me 

Did not understand this either.
Comment 11 Telesto 2022-05-23 09:08:32 UTC
(In reply to Eyal Rozenberg from comment #10)
Well my description doesn't win awards (it's actually horrible). I'm actually having multiple annoyances at the same time, which makes it kind of toxic cocktail.. 
1. Open Impress
2. Insert say a Shape
3. Sidebar -> Animation Deck
4. Press add button
5. Pick a category (say Entrance, default)
6. Search for zoom effect
7. Insert a 3 shapes, which also should have the zoom-effect

Result: 
A) You have to scroll a lot in the Effects list (and you can see only that many items at once). There is always stuff hidden. Even increasing the effects area, still doesn't help.
B) The effect list lacking a type & find system (compare fontbox). This will be hug speed-up if you use effects more often
C) The effects lists isn't sorted alphabetically (not overall, which would mean Zoom at the end of the effect list. And not even within a topic. Really hard to find some specific effect
D) The (sub)category's naming is really arbitrary, why are some effects 'exiting' or 'special'. I'm really not seeing the value.
E) Position of the category labels (Centered) I'm used top top down reading.
F) The bold part of the category's. It attracts attention, but well words without any meaning.. A simple separator would do the same thing, without 'some labels' (but well that's repeat of D)
G).The large effect list sensible for insertion of effects (still arguing for drop down list), but really pointless if you pre-existing animation. The start/delay/and direction stuff is probably more relevant, but positioned big distance from the animation list (with effect list in between). 
H). I'm kind disliking the 'dual layer' entry in the animation panel. First the say the Shape name, and directly below it with indent the category and effect. I'm bit inclined to hide the effect category/name. But only show it if selected in the list (which makes it possible to have more effects in the animation panel, before it becomes a list). See also PowerPoint 2003 (no clue about never versions)

---

> > UI: Animation list, show all entry's by default (and use the drop down to
> > filter)
> 
> Do you mean that, the controls on the side-bar changing the current selected
> effect would  serve as filters on the list of animations, when there is no
> item selected?

Well this likely about - yes, my description is that bad - the Category drop down (for effects). Nearly all effects under category Entrance, are also found under Emphasis.

So kind of argued what advantage having category's for effects which actually are multi-purpose effects. So as Entrance, as Exit, Emphasis have (mostly) the same effects as content but suggesting exclusive usability, which isn't the case..

The opposite is also happening. If select the motion paths category, the effect list will show a sub category 'Special or Basic'. The content is different 'Basic' Subcategory in Entrance. So sometimes "Basic" subcategory being the 'same' when comparing Exit/Entrance category's. Sometimes it totally different.
Comment 12 Eyal Rozenberg 2022-05-23 17:43:31 UTC
(In reply to Telesto from comment #11)

Thank you for clarifying. The thing is, with a large number of annoyances/requests/suggestions, I believe there's no getting around opening five or six or however bugs you need; with each of them focused on a single suggestion, with a clear explanation and maybe a mockup. I have some comments about some of the suggestions but I don't think it makes sense to write that all up in here.
Comment 13 Telesto 2022-05-23 21:02:57 UTC
(In reply to Eyal Rozenberg from comment #12)
> (In reply to Telesto from comment #11)
> 
> Thank you for clarifying. The thing is, with a large number of
> annoyances/requests/suggestions, I believe there's no getting around opening
> five or six or however bugs you need; with each of them focused on a single
> suggestion, with a clear explanation and maybe a mockup. I have some
> comments about some of the suggestions but I don't think it makes sense to
> write that all up in here.

I'm somewhat in 'repeat mode' with comment 11. I brought few things up separately  see bug 145035 comment 1 and bug 145034. 

And well bug 145034 (alphabetically order of the list of effects) got some objections/ issues with my alphabetical proposal (which is fine), however got dropped pretty easy (IMHO)

There is also the bug tracker issue
1) If you propose a specific fix for alleged problem, shooting down the proposal means, shooting down the 'bug' (annoyance/ design issue).
2) If I put forward a genetic description of the perceived problem - to avoid people shooting on the solution - it will be soon to vague (lacking direction)

An certain reply's have lots of strategic ambiguity.  Sometimes people object the solution, but de facto don't see something which need to addressed. There no problem at all: like it isn't a bug, but a feature. Or seeing it as a trivial/unimportant drawback. 

--
In case someone acknowledge an issue, but dislike the proposed solution I prefer people to put forward different idea's (brainstorming) in attempt to work something out. People taking an interest. Which can result in an alternative, or ultimately sticking to the current situation because every other solution having more drawbacks.

However a single person having to come up with ideas, and others shooting on it isn't much fun.  

--
So I'm happy to open yet again some bug reports on the matter, but I really don't have some fully conceptualized integral mock-up ready with meeting all UI design standards. Or total overview what needs to be taken in consideration.

It's more that I wanted to share my opinion on the animation deck and maybe getting some idea's for improvement.
Comment 14 Eyal Rozenberg 2022-05-23 23:06:16 UTC
(In reply to Telesto from comment #13)
(In reply to Telesto from comment #13)
> There is also the bug tracker issue
> 1) If you propose a specific fix for alleged problem, shooting down the
> proposal means, shooting down the 'bug' (annoyance/ design issue).

Ah, but you often propose more than a fix - you propose a change which will be detrimental to other workflows. For example, in 145034 - you didn't say you wanted to be able to have the effect kinds sorted alphabetically, you wrote you wanted to change it for everyone. Those are two different requests.




> 2) If I put forward a genetic description of the perceived problem - to
> avoid people shooting on the solution - it will be soon to vague (lacking
> direction)

Well, you can:

1. Ask for help with making it concrete.
2. Write the mailing list (or soon the discourse forums).
3. Try to make the problem more concrete by describing your workflow, and be more exact about what's problematic/annoying to you. I also have this problem sometime, and am frustrated by, uhm, certain people repeatedly not understanding my bug reports.
4. Ask Heiko to put some subject on the design meeting agenda (if it's a UI/design issue).

> Sometimes people ... don't see something which need to
> addressed. There no problem at all: like it isn't a bug, but a feature. Or
> seeing it as a trivial/unimportant drawback. 

My courses of action above should be relevant in those cases too. Of course, it may be the case that they're mostly right and what you want is a niche use case (happens to me occasionally).


> However a single person having to come up with ideas, and others shooting on
> it isn't much fun.  

I feel your pain, my friend ! T_T