Download it now!
Bug 32475 - UI: Shortcuts missing in menu, Shortcuts not working as expected
Summary: UI: Shortcuts missing in menu, Shortcuts not working as expected
Status: RESOLVED DUPLICATE of bug 88027
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 RC1
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL: http://lists.freedesktop.org/archives...
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2010-12-17 09:08 UTC by Rainer Bielefeld Retired
Modified: 2018-07-29 16:52 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2010-12-17 09:08:48 UTC
AFAIK (Bug 30714, Bug 30715) its planned (or already done?) to have a shortcut to insert current date or current date into a cell.
We already have something listed in menu "Tools -> Customize": 
<Cntrl>         =  'Options -> Insert Current Date'
<Cntrl>+<Shift> =  'Options -> Insert Current Date'

It seems there is a problem to have shortcuts with punctuation marks in the list?

Currently these items are missing in WIKIHELP.
Comment 1 Daniel Espinosa 2011-01-19 16:05:39 UTC
In the other Writer like applications from other vendors, exists lot of shortcuts to help on EDITING making you more productive. A firts lists of them is:

Shift+F3           Change Uppercase/Lowercase (press once per option)
Ctrl+<             Decrease 1 point character size
Ctrl+>             Increase 1 point character size
Ctrl+=             Set character to be subindex
Ctrl++             Set character to be superindex
Ctrl+SPACE BAR     Set character to Default format
Ctrl+Shift+1       Set style Header 1
Ctrl+Shift+2       Set style Header 2
Ctrl+Shift+3       Set style Header 3
Ctrl+Shift+4       Set style Header 4
Comment 2 Daniel Espinosa 2011-01-19 16:08:38 UTC
Is very important for accessibility reasons, to add at the menu the shortcut to call each item it has. If one is missing please add it.

If the menu item opens a dialog, add a shurtcut to it and show to the user the combination of keys he/she need to press in order to call it.
Comment 3 Christophe Strobbe 2011-07-26 02:41:49 UTC
Some comments on the keyboard shortcuts described by esodan:
The following shortcuts are already in LibreOffice Writer:
Ctrl+M       Set default formatting (for current style)
Ctrl+0       Set style Text Body
Ctrl+1       Set style Header 1
Ctrl+2       Set style Header 2
Ctrl+3       Set style Header 3
Ctrl+4       Set style Header 4
Ctrl+5       Set style Header 5
(www.odfauthors.org - previously www.oooauthors.org - has/has a document with keyboard shortcuts, as an appendix to the Writer Guide.)

However, Rainer Bielefeld's comment is about Calc, not about Writer.
Comment 4 Rainer Bielefeld Retired 2011-08-02 06:33:08 UTC
I checked with Master "LibO-dev 3.4.5  – WIN7  Home Premium  (64bit) English UI 
[(Build ID:d337f79-a24c961-2865670-9752b71-7f8fd43
	2fdd60d-fd28b6a-fd7bf20-aa369cb-28da3fb
	6a9633a-931d089-ecd263f-c9b55e9-b31b807
	82ff335-599f7e9-bc6a545-1926fdf)]"

Shortcut  Insert Date
Customize shows that it should be ctrl+shift+;
That does nothing with a german key board
Keyboard layout problem?
Comment 5 Rainer Bielefeld Retired 2011-08-02 07:20:02 UTC
My mistake, of course 
Shortcut  "Insert current TIME" is 'ctrl+shift+;'
I doubt that such a keyboard layout dependent relation can be used without problems?!

Currently I don't have a complete overview concerning all related problems, but there can't be any doubt, we have a problem here, so CONFIRMED.

@David
At least 'ctrl+shift+;' is missing in Help, also some others from Comment 1 are missing

@Christoph:
You know, here is my question concerning general considerations?

@sophie:
Who can check localization issues?

@Kohei:
Please feel free to reassign if it’s not your area or if provided information is not sufficient.
Comment 6 wope 2011-08-02 08:19:36 UTC
not only the shortcut <Control> + ; are affected, there are also the Shortcuts <Control> + [ and <Control> + ]
Comment 7 Christoph 2011-08-06 07:36:56 UTC
(In reply to comment #5)
> @Christoph:
> You know, here is my question concerning general considerations?

Sorry, I lack knowledge on (existing) general considerations in this case. In the past, decisions on new keyboard shortcuts have often be made with regard to competitor products (if not interfering with existing shortcuts). Usually, it is hard to apply any _serious_ scheme (but e.g. the difference Ctrl+ or Ctrl+Shift+).

What may help here for time/date functions in comparison to the large competitor product (2007) - they also have different shortcuts in German vs. English. So it seems such items are localized.
* German: STRG+UMSCHALT+; Aktuelle Zeit einfügen
* English: CTRL+SHIFT+:	Enters the current time.
Comment 8 Björn Michaelsen 2011-12-23 13:26:53 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 9 QA Administrators 2014-10-23 17:32:19 UTC Comment hidden (obsolete)
Comment 10 QA Administrators 2015-12-20 16:13:10 UTC Comment hidden (obsolete)
Comment 11 QA Administrators 2017-01-03 19:48:28 UTC Comment hidden (obsolete)
Comment 12 Roman Kuznetsov 2018-07-29 16:52:34 UTC

*** This bug has been marked as a duplicate of bug 88027 ***