Bug 34420 - Replace graphite with graphite2
Summary: Replace graphite with graphite2
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on: 36510 36562 36703 36752 37184
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-17 19:10 UTC by martin_hosken
Modified: 2012-03-23 00:42 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description martin_hosken 2011-02-17 19:10:44 UTC
The current graphite engine that is integrated into LibreOffice is too slow. The engine has been rewritten to be some 10x faster and more robust. This bug is a merge request to integrate that new engine into LibreOffice to replace the graphite that is already there.

Graphite involves the following three repositories:

git://gitorious.org/~mhosken/libreoffice-graphite2/mhoskens-bootstrap.git
git://gitorious.org/~mhosken/libreoffice-graphite2/mhoskens-libs-extern-sys.git
git://gitorious.org/~mhosken/libreoffice-graphite2/mhoskens-libs-gui.git

The branch in each case is features/graphite2

The necessary file graphite2-0.9.2.tar.gz may be found here:

http://sourceforge.net/projects/silgraphite/files/graphite2/graphite2-0.9.2.tgz/download
http://projects.palaso.org/attachments/download/95/graphite2-0.9.2.tgz

I would like to dedicate this bug to Keith Stribley who did nearly all the work in integrating the graphite2 library into LibreOffice. He suddenly died this week and we have lost a good friend and colleague.
Comment 1 Thorsten Behrens (CIB) 2011-02-22 02:49:40 UTC
Martin, thanks for the pointers - any chance you could try & cook up a patch against LibO with the updated graphite - or is this a drop-in replacements?
Comment 2 Michael Meeks 2011-02-22 03:17:12 UTC
Woah; so - Keith died !? I'm really sorry about that, and sad to miss you on IRC to ask more (I'm back on-line now).

What I suggest is, that since you really are the expert here Martin - is that we just get you git commit access, and you commit this to a feature branch in our repositories, and then we can more easily give it a quick glance before you merge it.

Can you go through the process at:
    http://freedesktop.org/wiki/AccountRequests

and mail me the bug number ? and I'll get you setup ASAP.

Thanks !
Comment 3 Michael Meeks 2011-02-22 03:18:08 UTC
oh - and sorry for the delay; we try to encourage people to post their work / patches / discussion straight to the (high traffic) dev list - bugzilla is not watched as eagerly :-)
Comment 4 Thorsten Behrens (CIB) 2011-02-22 06:36:53 UTC
Uploaded graphite to our tarball download server (with the md5sum prepended) - http://download.go-oo.org/src/0625a7d661f899a8ce263fc8a9879108-graphite2-0.9.2.tgz
Comment 5 gleppert 2011-04-09 15:57:54 UTC
In what release will we see graphite2? Will it be in release 3.4? Thanks
Comment 6 gleppert 2011-05-01 14:32:51 UTC
I added three bugs that may block this enhancement (replacement of graphite with graphite2).

Bug 36462 and 36752 are likely related to each other and the latter causes a crash. However, both were not yet tested in Graphite2. Please have a look.

Bug 36703 describes regressions and a crash in Graphite2.


I express my sincerest condolences to Keith's family and friends.
Comment 7 gleppert 2011-06-05 06:05:03 UTC
Isn't graphite2 not already integrated in LibreOffice 3.4? 
Then, this bug should be closed, right?
Comment 8 gleppert 2011-08-03 02:50:52 UTC
Repeating my question: Isn't graphite2 not already integrated in LibreOffice 3.4? Then, this bug should be marked as Closed->Fixed, right?
Comment 9 Gellért Gyuris 2011-08-03 08:29:22 UTC
(In reply to comment #8)
> Repeating my question: Isn't graphite2 not already integrated in LibreOffice
> 3.4? Then, this bug should be marked as Closed->Fixed, right?

I am not competent to answer. Just note that Graphite2 has been formally released these days: 
- http://sourceforge.net/projects/silgraphite/files/graphite2-1.0.0.tgz/download
- http://projects.palaso.org/projects/graphitedev/activity
Comment 10 Björn Michaelsen 2011-12-23 11:51:26 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 11 Björn Michaelsen 2011-12-23 17:00:09 UTC
needinfo keyword redundant by needinfo status.
Comment 12 martin_hosken 2012-01-03 20:18:31 UTC
This bug should be closed. Graphite2 is now in with considerable speedup. If speed testing shows libo with gr to be still too slow that should raise another bug or reopen this one.