Bug 45996 - UI Kana display broken in UI widgets
Summary: UI Kana display broken in UI widgets
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 50207 53952 65151 74684 74817 (view as bug list)
Depends on:
Blocks: CJK-Japanese
  Show dependency treegraph
 
Reported: 2012-02-13 06:28 UTC by Urmas
Modified: 2019-11-13 08:55 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
example (953 bytes, image/png)
2012-02-17 13:57 UTC, Urmas
Details
Sheet name ⌘あ (123.59 KB, image/jpeg)
2019-11-13 06:30 UTC, Massimo
Details
broken character (7.43 KB, image/jpeg)
2019-11-13 08:52 UTC, Kamei
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2012-02-13 06:28:20 UTC
The kana characters in UI widgets are display wrongly: some are replaced with box, some are misplaced to the right. If the text contains roman characters or punctuation, they are displayed correctly and positioned correctly too.
Comment 1 Andras Timar 2012-02-17 07:18:00 UTC
Did you have correct fonts installed? Do you see kana characters properly in other applications? Can you please attach a screenshot?
Comment 2 Urmas 2012-02-17 13:57:42 UTC
Created attachment 57232 [details]
example

Example from 'Documents and Templates' dialog.
Note that characters after U+30FC are displayed, before are not.
Comment 3 Urmas 2012-05-24 12:18:08 UTC
*** Bug 50207 has been marked as a duplicate of this bug. ***
Comment 4 Urmas 2012-10-13 02:37:00 UTC
*** Bug 53952 has been marked as a duplicate of this bug. ***
Comment 5 Urmas 2014-02-09 07:22:28 UTC
*** Bug 65151 has been marked as a duplicate of this bug. ***
Comment 6 Urmas 2014-02-09 07:22:43 UTC
*** Bug 74684 has been marked as a duplicate of this bug. ***
Comment 7 Urmas 2014-03-20 16:28:12 UTC
*** Bug 74817 has been marked as a duplicate of this bug. ***
Comment 8 Joel Madero 2015-05-02 15:43:46 UTC Comment hidden (obsolete)
Comment 9 Massimo 2015-05-02 18:36:39 UTC
Switching to Japanese interface no longer shows boxes but the right Kanji and Kana, although the fonts could be better. Checked in LO 4.4.2 under Win7 64bit French with Japanese charset as standard for non-Unicode applications.
Hope it helps....
Comment 10 QA Administrators 2016-09-20 09:37:32 UTC Comment hidden (obsolete)
Comment 11 Julien Nabet 2018-11-14 20:55:23 UTC
Any better with recent LO version?
Last stable one is 6.1.3

Following Massimo's comment (more than 3 years ago!), it seems better.
Comment 12 Julien Nabet 2018-12-17 08:28:16 UTC
Shinji/Himjin100000: thought you might be interested in this one.
(If you don't want to be put in cc, don't hesitate to tell)
Comment 13 Julien Nabet 2019-11-11 10:13:38 UTC
Following Massimo's comment (4 years ago!), waiting for new feedback here.
Comment 14 Massimo 2019-11-11 10:51:48 UTC
I think the problem is solved, now. Using LO 6.3.3 under Windows 10.
Comment 15 Julien Nabet 2019-11-11 11:16:46 UTC
Thank you Massimo for your feedback.
Let's put this one to WFM then.

Urmas: don't hesitate to reopen this tracker if you still reproduce this with a recent LO version (6.2.8 or brand new 6.3.3).
Comment 16 Kamei 2019-11-13 04:44:41 UTC
I confirm this is still reproduced.

procedure
1. create new spreadsheet document. (File > New > SpreadSheet)
2. change the sheet name (double click the "Sheet1" at bottom of window)
3. put following text  ⌘あ

environment:
Version: 6.3.3.2
Build ID: a64200df03143b798afd1ec74a12ab50359878ed
CPU threads: 8; OS: Mac OS X 10.13.6; UI render: default; VCL: osx; 
Locale: ja-JP (ja_JP.UTF-8); UI-Language: en-US
Calc: threaded
Comment 17 Massimo 2019-11-13 06:29:07 UTC
(In reply to Kamei from comment #16)
> I confirm this is still reproduced.
> 
> procedure
> 1. create new spreadsheet document. (File > New > SpreadSheet)
> 2. change the sheet name (double click the "Sheet1" at bottom of window)
> 3. put following text  ⌘あ
> 
> environment:
> Version: 6.3.3.2
> Build ID: a64200df03143b798afd1ec74a12ab50359878ed
> CPU threads: 8; OS: Mac OS X 10.13.6; UI render: default; VCL: osx; 
> Locale: ja-JP (ja_JP.UTF-8); UI-Language: en-US
> Calc: threaded

It seems fine here - see attachment.
Comment 18 Massimo 2019-11-13 06:30:09 UTC
Created attachment 155767 [details]
Sheet name ⌘あ

Sheet name seems correct
Comment 19 Julien Nabet 2019-11-13 08:25:00 UTC
(In reply to Kamei from comment #16)
> I confirm this is still reproduced.
> ...
Could you give a try to https://wiki.documentfoundation.org/QA/FirstSteps ?

Also, did you install any specific fonts? If yes, could you disable them and give a new try for the test?
Finally, could you attach a screenshot if you still reproduce this?
Comment 20 Kamei 2019-11-13 08:52:48 UTC
Created attachment 155769 [details]
broken character

Thanks for your tests.
please see attached file.

> Also, did you install any specific fonts? If yes, could you disable them and
> give a new try for the test?

I disabled any additional font. But still reproduced.
Maybe, this issue is occurred on macOS only.
Comment 21 Julien Nabet 2019-11-13 08:55:50 UTC
Thank you Kamei for your quick feedback.

Alex: could you give a try just to know if it's not specific to one person?
https://bugs.documentfoundation.org/show_bug.cgi?id=45996#c16 indicates the quick step by step process to reproduce this.