Bug 46561 - EDITING: Undo history cut off when inserting page header or footer
Summary: EDITING: Undo history cut off when inserting page header or footer
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: high normal
Assignee: Dániel Arató (NISZ)
URL:
Whiteboard: BSA target:7.2.0
Keywords:
: 50432 59560 62181 84461 87931 112744 116111 116113 140624 (view as bug list)
Depends on:
Blocks: Writer-Header-Footer Undo-Redo
  Show dependency treegraph
 
Reported: 2012-02-24 02:34 UTC by Nino
Modified: 2021-05-05 19:27 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nino 2012-02-24 02:34:42 UTC
Problem description: If you insert a page header and later try to revert your text changes, the undo history stops at the header changes and text changes from before are not reversible.

Steps to reproduce:
1. create new text document
2. insert some words of text 
3. create page header by clicking the "+" on hovering the sensible area and entering some words
4. continue writing text in page body area
5. repeatedly press undo button or CTRL+Z

Current behavior:
Undo steps end at header level, text changed or entered before are not revertable.

Expected behavior:
Undo steps continue until all changes of the session are reverted (or maybe change history length maximum is reached)

Not tested if it's a regression as no older versions available ATM

Platform:
Linux i686/RPM
Comment 2 Jorendc 2013-02-18 10:03:31 UTC
*** Bug 50432 has been marked as a duplicate of this bug. ***
Comment 3 Brenda Granados 2013-03-08 18:54:39 UTC
*** Bug 59560 has been marked as a duplicate of this bug. ***
Comment 4 Brenda Granados 2013-03-14 15:00:43 UTC
*** Bug 62181 has been marked as a duplicate of this bug. ***
Comment 5 Matthew Francis 2014-09-29 16:48:45 UTC
*** Bug 84461 has been marked as a duplicate of this bug. ***
Comment 6 Jean-Baptiste Faure 2014-09-29 17:45:18 UTC
It is not a bug because you are warned that the header deletion can't be undone.

Changed from Normal to enhancement, because it would be great if such style changes could be undone.

Best regards. JBF
Comment 7 Buovjaga 2015-01-16 17:02:37 UTC
*** Bug 87931 has been marked as a duplicate of this bug. ***
Comment 8 Xisco Faulí 2017-09-29 08:37:49 UTC
*** Bug 112744 has been marked as a duplicate of this bug. ***
Comment 9 Yousuf Philips (jay) (retired) 2017-09-29 21:45:14 UTC
(In reply to Jean-Baptiste Faure from comment #6)
> It is not a bug because you are warned that the header deletion can't be
> undone.

The issue is that after inserting the header, you cant undo, so its a bug.
Comment 10 Xisco Faulí 2018-03-01 14:16:59 UTC
*** Bug 116113 has been marked as a duplicate of this bug. ***
Comment 11 Xisco Faulí 2018-03-01 14:17:08 UTC
*** Bug 116111 has been marked as a duplicate of this bug. ***
Comment 12 NISZ LibreOffice Team 2021-02-24 12:12:05 UTC
*** Bug 140624 has been marked as a duplicate of this bug. ***
Comment 13 Aron Budea 2021-03-05 15:34:12 UTC
Already in 3.3.0.
Comment 14 Commit Notification 2021-03-17 12:11:16 UTC
Daniel Arato (NISZ) committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8d8486f43c1a8a51157bfc3e0b87090b05a9229e

tdf#46561 sw: fix lost undo stack setting header/footer

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Dániel Arató (NISZ) 2021-04-07 10:38:04 UTC
A crash has been discovered in testing:

1. create a new document
2. enter some text in the body
3. enter some text in the header
4. undo all changes
5. the application crashes

We are currently in the process of locating this crash.
Comment 16 NISZ LibreOffice Team 2021-05-05 07:35:58 UTC
Verified in: 

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: ef78c7d93e4f170ac7a7f0307a8305052524eb53
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: default; VCL: win
Locale: ug-CN (hu_HU); UI: hu-HU
Calc: threaded
Comment 17 Jean-Baptiste Faure 2021-05-05 16:43:30 UTC
(In reply to NISZ LibreOffice Team from comment #16)
> Verified in: 
> 
> Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
> Build ID: ef78c7d93e4f170ac7a7f0307a8305052524eb53
> CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: default; VCL: win
> Locale: ug-CN (hu_HU); UI: hu-HU
> Calc: threaded

No commit that fixes the crash ?

Best regards. JBF
Comment 18 Aron Budea 2021-05-05 19:27:06 UTC
(In reply to Jean-Baptiste Faure from comment #17)
> No commit that fixes the crash ?
I haven't tested, but it looks like bug 141613's fix does that.