Bug 48534 - EDITING: No footnotes possible in frames
Summary: EDITING: No footnotes possible in frames
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 50711 54190 66705 (view as bug list)
Depends on:
Blocks: Footnote-Endnote
  Show dependency treegraph
 
Reported: 2012-04-10 18:55 UTC by illumilore
Modified: 2018-01-19 14:25 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document (193.61 KB, application/3dr)
2012-04-10 21:27 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description illumilore 2012-04-10 18:55:11 UTC
Problem description: 
After I've added an endnote, I then cut the endnote, click in the caption frame for a picture, and hit paste, but the endnote never pastes to the caption for the picture. Insert>footnotes/endnotes are also grey while in caption.


Current behavior:it does not paste

Expected behavior:for it to paste

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 1 Rainer Bielefeld Retired 2012-04-10 21:26:36 UTC
[Reproducible] with "LibreOffice 3.3.3  German UI/Locale [OOO330m19 (Build:301) tag libreoffice-3.3.3.1] on German WIN7 Home Premium (64bit), within a frame it's impossible to add a footnote.

It's a very old bug inherited from OOo, see a.m. AOOo bug!

Simply create a writer document with a .png, add a caption with caption text "This is some Text". Or do your tests with attached sample.odt
Comment 2 Rainer Bielefeld Retired 2012-04-10 21:27:10 UTC
Created attachment 59787 [details]
Sample Document

See Comment 1
Comment 3 illumilore 2012-04-12 12:18:39 UTC
That sample document lets you add footnotes, but not endnotes to any of the frames. Is there a way to get the reference into the picture citation frame that links to the final endnotes on the last page?
Comment 4 Owen Genat (retired) 2013-05-13 07:14:28 UTC
*** Bug 50711 has been marked as a duplicate of this bug. ***
Comment 5 Jorendc 2013-10-07 21:28:32 UTC
*** Bug 54190 has been marked as a duplicate of this bug. ***
Comment 6 Jorendc 2013-10-07 21:29:28 UTC
*** Bug 66705 has been marked as a duplicate of this bug. ***
Comment 7 QA Administrators 2015-04-01 14:42:19 UTC Comment hidden (obsolete)
Comment 8 Jens Reimann 2015-04-02 10:28:09 UTC
This issue is still present in LibreOffice 4.4.1.

Tested on Windows:

* Installed fresh LibreOffice 4.4.1
* Create new text document
* Fill with lorem
* Create a new Frame
* Enter text into the frame
* Position cursor inside text in frame
* Open "Insert" Menu

* BANG: Footnote is disabled
Comment 9 Filipy 2016-03-08 14:19:57 UTC
The same issue still present in LibreOffice 5.0.5.2.

Tested on Arch Linux when tried to insert a footnote from an image caption.

Regards.
Comment 10 QA Administrators 2017-12-06 09:46:40 UTC Comment hidden (obsolete)
Comment 11 David 2018-01-19 14:25:04 UTC
Footnote and endnote menu items are still greyed out in version 6.1.