Download it now!
Bug 50827 - Extra, unwanted, Slovenian dictionary (share/wordbook/sl.dic)
Summary: Extra, unwanted, Slovenian dictionary (share/wordbook/sl.dic)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:4.1.0
Keywords:
: 52321 60424 63113 66729 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-06-07 05:52 UTC by Olivier Hallot
Modified: 2013-07-09 11:27 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
printscreen of unwanted user slovenian dictionary (61.99 KB, image/png)
2012-06-07 05:52 UTC, Olivier Hallot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2012-06-07 05:52:59 UTC
Created attachment 62711 [details]
printscreen of unwanted user slovenian dictionary

Hi

I am carrying an extra Slovenian user dictionary entry in my installation.

This entry should not be there, I have no use of it.

See image attached
Comment 1 Andras Timar 2012-06-08 13:16:51 UTC
It is a so called user dictionary, which belong to extras. It is not trivial to remove it, I mean it would not be a single line patch. Packaging of extras/wordbook should be changed.
Comment 2 manj_k 2012-07-21 12:48:30 UTC
*** Bug 52321 has been marked as a duplicate of this bug. ***
Comment 3 Jan Jurkus 2012-07-23 20:04:07 UTC
I can confirm it also occurs on a Windows installation.

Creating a msi transform file with this file removed from the extras_wordbook-thing-a-muh-jig is a workaround. I would not suggest making a msi tranform file for just this, of course.

Didn't this also happen with OpenOffice? I vaguely remember something about a slovenian wordlist popping up. Been a while.
Comment 4 Kim Bastin 2012-08-10 05:23:19 UTC
The Slovenian dictionary shows up unaccountably in my Windows XP SP3 installation of LibreOffice 3.6.0. I do not how long it has been there. If I delete the extensions folder it just comes back, and there appears to be no way of getting rid of it.
Comment 5 paour 2012-12-10 09:28:54 UTC
Hello,
Version 3.6.4.3 (Build ID: 2ef5aff), Win 7, french version.
I confirm unattended installation with option
REMOVE=gm_r_ex_Dictionary_Sl has no effect on this dictionnary.
After setup, if we remove C:\Program Files\LibreOffice 3.6\share\wordbook\sl.dic
the dictionary is deleted (it's not a solution, just a workaround)
Nicolas
Comment 6 Martin Srebotnjak 2012-12-28 23:27:13 UTC
OK, OK, just please do not remove it from the Slovenian langpack :)
Comment 7 Andras Timar 2013-02-08 21:28:01 UTC
I can move these wordlists to the appropriate hunspell package. 
sl to Slovenian, en-US and en-GB to English. Language independent technical.dic will stay in main package (core01 on Linux). Is this acceptable?
Comment 8 Not Assigned 2013-02-08 21:35:24 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a4547696d272588374fd391233626df986275870

fdo#50827 move language dependent wordlists to the appropriate dict pack



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Andras Timar 2013-02-14 19:08:17 UTC
*** Bug 60424 has been marked as a duplicate of this bug. ***
Comment 10 Don't use this account, use tml@iki.fi 2013-02-15 07:12:13 UTC
Olivier, what other files in the installation do you have that never get used by you? They might take up SEVERAL MEGABYTES of valuable disk space!!!
Comment 11 Olivier Hallot 2013-02-15 10:27:24 UTC
(In reply to comment #10)
> Olivier, what other files in the installation do you have that never get
> used by you? They might take up SEVERAL MEGABYTES of valuable disk space!!!

I dream not to have to handle all the foreign autocorrections in my locale... Although it takes only 360K, it perhaps could speed up a bit our LO starting time...

Still in 4.0, all autocorrections are packed irrespective of the locale:

olivier@olivier-Vostro-3500:/opt/libreoffice4.0/share/autocorr$ l
acor_af-ZA.dat  acor_en-GB.dat  acor_fi-FI.dat  acor_ja-JP.dat  acor_nl-NL.dat  acor_sh-RS.dat  acor_sr-YU.dat
acor_bg-BG.dat  acor_en-US.dat  acor_fr-FR.dat  acor_ko-KR.dat  acor_pl-PL.dat  acor_sh-YU.dat  acor_sv-SE.dat
acor_cs-CZ.dat  acor_en-ZA.dat  acor_ga-IE.dat  acor_lb-LU.dat  acor_pt-BR.dat  acor_sk-SK.dat  acor_tr-TR.dat
acor_da-DK.dat  acor_es-ES.dat  acor_hr-HR.dat  acor_lt-LT.dat  acor_pt-PT.dat  acor_sl-SI.dat  acor_vi-VN.dat
acor_de-DE.dat  acor_eu.dat     acor_hu-HU.dat  acor_mn-MN.dat  acor_ru-RU.dat  acor_sr-ME.dat  acor_zh-CN.dat
acor_en-AU.dat  acor_fa-IR.dat  acor_it-IT.dat  acor_nl-BE.dat  acor_sh-ME.dat  acor_sr-RS.dat  acor_zh-TW.dat

Autocorrections should be tied to the locales installed, IMHO.
Comment 12 Claude 2013-03-30 15:47:19 UTC
Hi
The problema still remains in version 4.0.2.2.  The dictionaries SL and GB are still part of the Language independent package, in the directory (Windows) C:\Program Files\LibreOffice 4.0\share\wordbook.
I have been tracking every new version since the bug was reported and they were all the same.  If you want to get rid off these dictionaries you have to remove them manually from the above address.

Thanks
Claude
Comment 13 Urmas 2013-04-04 21:18:36 UTC
*** Bug 63113 has been marked as a duplicate of this bug. ***
Comment 14 Harald Koester 2013-04-23 10:25:28 UTC
(In reply to comment #7)
> I can move these wordlists to the appropriate hunspell package. 
> sl to Slovenian, en-US and en-GB to English. Language independent
> technical.dic will stay in main package (core01 on Linux). Is this
> acceptable?

I'm afraid not completedly. 

Leaving technical.dic inside the main package still may lead to confusion. This dictionary is listed as a user-defined dictionary. But a user is not able to modify or remove this dictionary. I also had a look inside this dictionary. My impression is that it is more a mingle-mangle than a real technical dictionary. Hence my proposal: Remove this dictionary from the main package. 

Furthermore the dictionary IgnoreAllList exists as a user-defined dictionary. In my case this dictionary contents only the words I used in my user data. The user is not able to remove this dictionary, too. Furthermore the name "IgnoreAllList" is not localized. So a user which native language is not English may not understand the sense of this dictionary. In order to avoid confusion with this dictionary my proposal: 
(1) The user dictionary IgnoreAllList should not be created during installation of LO. 
(2) If a user enters data in the user data section, a dictionary named "Standard" should be created or modified if it allready exists. The words of the user data should be inserted into this dictionary.
(3) The corresponding file of the dictionary "Standard" should be created in the user profile in folder "wordbook".
(4) The user should have full control (insert words, delete words, remove dictionary) about the dictionary "Standard".
(5) If necessary the name of this dictionary ("Standard") should be localized.
Comment 15 David Tardon 2013-05-10 05:56:35 UTC
(In reply to comment #12)
> The problema still remains in version 4.0.2.2.

Because the fix was only applied on master. That means it will be in 4.1.
Comment 16 Urmas 2013-07-09 11:27:32 UTC
*** Bug 66729 has been marked as a duplicate of this bug. ***