Download it now!
Bug 53240 - : EDITING CRASH Insert custom field "x-y" with content "x-y"
Summary: : EDITING CRASH Insert custom field "x-y" with content "x-y"
Status: RESOLVED DUPLICATE of bug 47368
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: x86 (IA32) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-08 12:02 UTC by Petri Aukia
Modified: 2012-09-13 15:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The stack trace post-crash (151.98 KB, text/rtf)
2012-08-08 12:02 UTC, Petri Aukia
Details
Screenshot: The Fields dialog, entering variable called "x-y" is not possible (47.49 KB, image/png)
2012-08-22 16:10 UTC, Roman Eisele
Details
Screenshot of the Fields dialog, DocInformation setting, showing the triangular control (47.49 KB, image/png)
2012-09-12 16:04 UTC, Roman Eisele
Details
Screenshot of the "Fields" dialog ("Insert > Fields > Others..."), "DocInformation" setting, showing the triangular control (122.78 KB, image/png)
2012-09-13 14:59 UTC, Roman Eisele
Details
Screenshot of Properties dialog (File > Properties...) with custom properties (40.56 KB, image/png)
2012-09-13 15:16 UTC, Roman Eisele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petri Aukia 2012-08-08 12:02:37 UTC
Created attachment 65278 [details]
The stack trace post-crash

Problem description: 

Libreoffice crashes deterministically, if following steps are taken

Steps to reproduce:
1. crate property with the label x, type text, value x
2. Insert this property to an open document by clicking on insert > fields > other > custom > x
3. Create property with the label x-y, type text, value x-y
4. Insert this property to an open document by clicking on insert > fields > other > custom > x-y

Current behavior:

Libreoffice crashes

Expected behavior:

Contents of the custom field are inserted

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_0) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.151 Safari/535.19
Comment 1 billhook 2012-08-10 00:23:24 UTC
I could not reproduce this on WinVista SP1 32bit LO 3.6.0.4
Comment 2 Petri Aukia 2012-08-10 04:25:37 UTC
(In reply to comment #1)
> I could not reproduce this on WinVista SP1 32bit LO 3.6.0.4

Someone with a Mac should try this. Happens every time.
Comment 3 Roman Eisele 2012-08-22 16:10:39 UTC
Created attachment 65968 [details]
Screenshot: The Fields dialog, entering variable called "x-y" is not possible



I tried "with a Mac" ;-), i.e. with LibreOffice 3.6.1.1 on MacOS X 10.6.8 (Intel).

Interesting enought, I can’t reproduce this issue, but only because I can’t even define a variable with name "x-y".

What I did:
1) Start LibreOffice
2) Create a new Writer document
3) Select "Insert > Fields > Other..." from the menu bar
   -> Dialog window "Fields" appears
4) In the dialog window, select tab "Variables";
5) Select Type: "Set variable" and Format: "Text";
6) now I try to type "x-y" into field "Name",
   but this is impossible: the '-' gets lost, the name is "xy" now,
   probably because '-' is not allowed in variable names.

Needless to say that I can’t reproduce the crash either; defining and inserting "x" (value: "x") and "xy" (value: "x-y") works as expected.


@Petri Aukia:

Please take a look at my steps listed above. Is this the same thing you did? Or did you something else, I mean, did you define the variable in another way, and therefore you could define a variable with name "x-y" (including the '-')? The '-' may well be the reason for the crash ...

Thank you very much in advance for your answer!


(Or was this bug fixes somewhere in the 3.6.1.1 development process, so that I can’t reproduce it because I use 3.6.1.1 instead of 3.6.0.4? You can try this yourself: please download 3.6.1.1 -- or, coming soon, 3.6.1.2 -- from
  http://www.libreoffice.org/download/pre-releases/
and try if it fixes the crash ...)
Comment 4 Roman Eisele 2012-08-22 16:20:17 UTC
Oh, wait a minute: two additional questions, very important!

Looking at your "stack trace post-crash", I see that it contains many many references to accessibility stuff. This may be the reason for this crash, because we have heavy problems in LibreOffice when MacOS accessibility features are enabled.

Therefore, two very important questions:

1) Do you have any accesibility features enabled? Apple’s accessibility
features like "VoiceOver" or "Enable access for assistive devices", which get
enabled in "System Preferences > Universal Access" (in German: "Bedienungshilfen"; dont’t know about other languages), are known to cause many crashes in LibreOffice (see bug 47368). So please try to disable any accesibility features, i.e. uncheck "VoiceOver", "Enable access for assistive devices", etc.

2) Do you have installed any window management/user interface utilities/apps
for MacOS X like 
* Moom      (see bug 42014)
* Cinch     (see bug 51791)
* RightZoom (see bug 51686)
* ShiftIt   (see bug 52147)?
All these and many similar utilities rely heavily on accessibility issues and
therefore cause LibreOffice to crash. So please check if you have installed any
utility of this kind and try to disable it (or to add LibreOffice to the list
of excluded applications for the utility, if there is such a thing).

Disabling both Apple’s accessibility features and all accessibility-related/window management utilities, and then re-starting your Mac could fix the LibreOffice crash. Please try this.

Thank you very much for trying this out (and please report the results here,
too)!
Comment 5 Petri Aukia 2012-08-22 16:23:58 UTC
That must be it. In my case I run something called BetterSnapTool, which could explain this. I'll report after the reboot.

(And already … thank you for the excellent debug information and the effort you have put into this.)
Comment 6 Roman Eisele 2012-08-23 12:29:41 UTC
(In reply to comment #5)
> That must be it. In my case I run something called BetterSnapTool, which could
> explain this. I'll report after the reboot.

Any results yet? I just need to know if this really solves the problem, or if we need to investigate further ...


> (And already … thank you for the excellent debug information and the effort you
> have put into this.)

Oh, thank you, not worth mentioning! Just telling me the results of your tests is enough ...
Comment 7 Roman Eisele 2012-09-01 11:47:32 UTC
Because of the traces of Mac Accessibility-related problems in the stack trace (cf. comment #4) and of the first answer of the original reporter (comment  #5), I mark this report as a duplicate of the main report for accessibility-related crashes, bug 47368.

Feel free to re-open this bug report if you can reproduce *exactly* the same issue (see comment #0) without any accesibility features enabled and without any special accessibility-related extensions/utilities (cf. comment #4). But even then it may be even better to file a new bug report, because the crash desribed in the present bug report was clearly related to accesibility.

*** This bug has been marked as a duplicate of bug 47368 ***
Comment 8 Roman Eisele 2012-09-12 16:01:02 UTC
Mac Accessibility Related Bugs Survey Results
---------------------------------------------

All tests done on Mac OS X 10.6.8 (Intel), with RightZoom running to provoke the accessibility-related bugs.

Using the steps given in comment #0, the crash is REPRODUCIBLE with
* LibreOffice 3.6 daily (3.6.2.0+), Build ID: cfbfa26,
  Pull time: 2012-09-07 10:35:10, German langpack installed
* LOdev 3.7.0.0.alpha0+, Build ID: 5ca197c,
  Pull time: 2012-09-06 07:07:33, US English langpack installed

But the crash is NO longer reproducible with
* LibreOffice 3.6 daily (3.6.2.0+), Build ID: c303961,
  Pull time: 2012-09-11 08:49:57, German langpack installed
* LOdev 3.7.0.0.alpha0+, Build ID: 2df0884,
  Pull time: 2012-09-11 01:28:39, US English langpack installed

This indicates that this bug was fixed by Michael Meek’s patch for bug 47368:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=3234b715b5a6d13ee673b41066eb565706be5ec9

Additionaly, this is also indicated by the stack trace attached to the present
bug: it shows much (endless?) recursion of hitTestRunner(); Michael’s patch is
exactly a fix for this endless hitTestRunner() recursion.

This means in turn that this bug is correctly marked as a duplicate of bug
47368, which was fixed by the commit cited above.

This fix will appear in LibreOffice 3.6.2 and 3.7.0.
Comment 9 Roman Eisele 2012-09-12 16:04:45 UTC
Created attachment 67056 [details]
Screenshot of the Fields dialog, DocInformation setting, showing the triangular control

It turns out that this crash is related to the hierachical display of the properties including the small triangular control which is used to show and hide the sub-entries. All bugs which are related to the hitTestRunner() recursion include some hierarchical list box: the pane selection in the LibO Preferences/Options window (bug 52147, bug 54282, and others), or the list of styles with hierarchical view in bug 53221, or, like here, the properties list ...
Comment 10 Roman Eisele 2012-09-13 14:59:14 UTC
Created attachment 67110 [details]
Screenshot of the "Fields" dialog ("Insert > Fields > Others..."), "DocInformation" setting, showing the triangular control


(Sorry: that was the wrong screenshot, here is the right one.)
Comment 11 Roman Eisele 2012-09-13 15:16:43 UTC
Created attachment 67111 [details]
Screenshot of Properties dialog (File > Properties...) with custom properties


For the record:

I have to confess it was not easy to understand how to reproduce this issue, sorry. So here some additional notes, just in case someone else wants to reproduce/test the issue again.

First you need to select “File > Properties...” from the menu to show the file properties dialog; switch to the “Custom Properties” tab; and here add the two properties “x” and “x-y” as described in comment #0. See the last screenshot (attached with this comment) for that.

Secondly, to insert these custom properties into the main text of the document, select “Insert > Fields > Others...” from the menu to show the “Fields” dialog; switch to the “DocInformation” tab; in the list at the left labelled “Type”, select the entry “Custom”; and as sub-entries of that entry you will find again the two properties “x” and “x-y”, and you can insert them via selection one of them and clicking the button “Insert”. See the screenshot (attachment 67110 [details]) for that.