Bug 56960 - FILEOPEN particular .xlsx shows cell border lines with wrong FORMATTING (too thick)
Summary: FILEOPEN particular .xlsx shows cell border lines with wrong FORMATTING (too ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.6.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.1.0.0.beta2 target:4.2.0
Keywords:
: 53287 58356 60599 65071 67008 (view as bug list)
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-11-10 18:01 UTC by Ibrahim Hammad
Modified: 2014-01-02 08:45 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments
This is a 4 sheet excel document (364.40 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2012-11-10 18:40 UTC, Ibrahim Hammad
Details
Same Workbook opened again (738.27 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2012-11-10 18:43 UTC, Ibrahim Hammad
Details
Screenshot Showing views in various ofice suites (405.54 KB, image/png)
2013-02-01 17:00 UTC, Rainer Bielefeld Retired
Details
patch to make imported .xlsx .xlsb borders look like they do in Excel (1.11 KB, patch)
2013-06-01 08:15 UTC, Tim Richardson
Details
dot border excel print incorrectly (183.04 KB, image/png)
2014-01-02 08:38 UTC, Lewi S. Kristianto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ibrahim Hammad 2012-11-10 18:01:37 UTC
When using Linux to open a previously made excel file in windows the following inconveniences occur:
1- Font type is different
2- cell borders are shown as very thick
3- Art shapes are misplaced
4- All comments in cells are shown by default
5- some files with more than one sheet will only load one sheet
6- Hidden rows and columns are not depicted nor accessible 

This is happening every time same sheet is opened even when corrected and saved while using under Linux. Worth saying that all files are saved on windows partition and accessed through Linux.

The Following describes my system:

Ubuntu 12.04 LTS
Memory 5.8 GiB
Processor: Intel® Core™ i7-2630QM CPU @ 2.00GHz × 8 
Graphics: GeForce GT 540M/PCIe/SSE2 
OS type: 64 bit
Comment 1 Urmas 2012-11-10 18:33:13 UTC
You forgot to attach the document.
Comment 2 Ibrahim Hammad 2012-11-10 18:40:39 UTC
Created attachment 69876 [details]
This is a 4 sheet excel document

Originally, this workbook contains 4 inter related sheets. Only one sheet appeared.
Comment 3 Ibrahim Hammad 2012-11-10 18:43:07 UTC
Created attachment 69877 [details]
Same Workbook opened again

This is the same workbook used as an example in the first attachment. Check out sheet 2 it should contain hidden columns and should have filters!
Comment 4 Ibrahim Hammad 2012-11-10 18:49:00 UTC
I already submitted two attachments for same workbook open twice and both
are not satisfactory.

If this is not enough please let me know.

Regards,
Ibrahim Hammad

On Sat, Nov 10, 2012 at 9:33 PM, <bugzilla-daemon@freedesktop.org> wrote:

>  Urmas <davian818@gmail.com> changed bug 56960<https://bugs.freedesktop.org/show_bug.cgi?id=56960>
>  What Removed Added  Status UNCONFIRMED NEEDINFO  Ever confirmed   1
>
>  *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=56960#c1> on bug
> 56960 <https://bugs.freedesktop.org/show_bug.cgi?id=56960> from Urmas<davian818@gmail.com>
> *
>
> You forgot to attach the document.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 5 Rainer Bielefeld Retired 2013-01-25 07:00:44 UTC
@Ibrahim Hammad:
Thank you for your report! Please consider
<http://wiki.documentfoundation.org/BugReport#General_information> item 4!

Please submit a new bug concerning font type problem with reference to Attachment here  due to <https://wiki.documentfoundation.org/QA-FAQ#How_to_use_attached_sample_documents_for_multiple_Bug_Reports> and add me to CC! Please add this Bug ID Number there to "Blocks" field!

Please read and consider hints on <http://wiki.documentfoundation.org/BugReport>, your info here is much too rare!

Please do not forget to select Wauto mime tyed detection" for attachments in future
Comment 6 Rainer Bielefeld Retired 2013-02-01 16:59:03 UTC
My MS EXCEL Viewer does not open "Sales Management _Water.xlsx", so I can't compare.

No feedback, so reduced to 1 single problem

@Ibrahim Hammad:
We have lots of Bug Reports with a clear description concerning the reported problem. So unfortunately we can't invest time to find out what the problems might be with your documents. "Objects are at the wrong place" is a very bad description, we need something like "'Picture.png' in sheet1 anchored to cell B17 in EXCEL exactly covers B17:C18. LibO shows the picture half a cell width too far to the right and 3/4 cell hight too far to the bottom." Or you contribute a screen shot wiht comments comparing the view.

Please feel free to proceed as I suggested in Comment 5 and to open additional Bug reports referring to your samples here and a clear description of the problems.


@Markus:
Indeed, Attachment 69877 [details] "Same Workbook opened again" shows sheet "4      Action" with visible thicker cell borders than AOOo, Sympony and MS Excel viewer
May be you can use the sample document for some more fine tuning concerning Fileopen /  Cell border width? You will see my results in a screenshot comparing views with same zoom in several office suites.

Please close this Bug after your examinations, I will not try to fine more problems
Comment 7 Rainer Bielefeld Retired 2013-02-01 17:00:10 UTC
Created attachment 74055 [details]
Screenshot Showing views in various ofice suites

as promised in comment before.
Comment 8 Rainer Bielefeld Retired 2013-02-01 17:07:30 UTC
Forgot FreeOffice Planmaker in the screenshots: They show cell border width very similar to LibO.
Comment 9 Jorendc 2013-05-27 20:16:13 UTC
*** Bug 58356 has been marked as a duplicate of this bug. ***
Comment 10 Jorendc 2013-05-27 20:27:46 UTC
*** Bug 58356 has been marked as a duplicate of this bug. ***
Comment 11 Jorendc 2013-05-27 22:13:28 UTC
*** Bug 58356 has been marked as a duplicate of this bug. ***
Comment 12 ign_christian 2013-05-28 15:10:42 UTC
*** Bug 65071 has been marked as a duplicate of this bug. ***
Comment 13 Tim Richardson 2013-06-01 08:15:03 UTC
Created attachment 80110 [details]
patch to make imported .xlsx .xlsb borders look like they do in Excel
Comment 14 Ibrahim Hammad 2013-06-01 09:00:48 UTC
Comment on attachment 80110 [details]
patch to make imported .xlsx .xlsb borders look like they do in Excel

Thank you for the brilliant professional work.
Please excuse my ignorance, but how can one activate this batch to apply the new configuration changes please?

Regards,
Ibrahim Hammad
Comment 15 Tim Richardson 2013-06-01 11:18:35 UTC
You need to build libreoffice, ie compile it from source. hours of work if
you haven't done it before. Hopefully the patch will be reviewed soon, it's
my first patch for LO so I haven't experienced the process.
On 1 Jun 2013 19:00, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 14 <https://bugs.freedesktop.org/show_bug.cgi?id=56960#c14>on bug
> 56960 <https://bugs.freedesktop.org/show_bug.cgi?id=56960> from Ibrahim
> Hammad <ibrahim.hammad@gmail.com> *
>
> Comment on attachment 80110 [details] <https://bugs.freedesktop.org/attachment.cgi?id=80110> [details] <https://bugs.freedesktop.org/attachment.cgi?id=80110&action=edit> [review] <https://bugs.freedesktop.org/page.cgi?id=splinter.html&bug=56960&attachment=80110>
> patch to make imported .xlsx .xlsb borders look like they do in Excel
>
> Thank you for the brilliant professional work.
> Please excuse my ignorance, but how can one activate this batch to apply the
> new configuration changes please?
>
> Regards,
> Ibrahim Hammad
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You are on the CC list for the bug.
>
>
Comment 16 Markus Mohrhard 2013-06-02 02:10:30 UTC
(In reply to comment #15)
> You need to build libreoffice, ie compile it from source. hours of work if
> you haven't done it before. Hopefully the patch will be reviewed soon, it's
> my first patch for LO so I haven't experienced the process.
> On 1 Jun 2013 19:00, <bugzilla-daemon@freedesktop.org> wrote:
> 

Just for the future, please send patches either to the mailing list or to gerrit. Patches in bugzilla are lost as long as there is no core developer subscribed to the bug report. In this case I'll take care of the bug report but it will need some more work to get it in line with XLS import and XLS/XLSX export.

I'll look into your patch and all the other necessary changes to get it integrated.
Comment 17 Tim Richardson 2013-06-02 05:40:29 UTC
On Sunday 02 June 2013 02:10:30 you wrote:


*Comment # 16[1] on bug 56960[2] from Markus Mohrhard[3] *
(In reply to comment #15[4])
> You need to build libreoffice, ie compile it from source. hours of work if
> you haven't done it before. Hopefully the patch will be reviewed soon, it's
> my first patch for LO so I haven't experienced the process.
> On 1 Jun 2013 19:00, <bugzilla-daemon@freedesktop.org[5]> wrote:
> 

Just for the future, please send patches either to the mailing list or to
gerrit. Patches in bugzilla are lost as long as there is no core developer
subscribed to the bug report. In this case I'll take care of the bug report but
it will need some more work to get it in line with XLS import and XLS/XLSX
export.

I'll look into your patch and all the other necessary changes to get it
integrated. 
--------------------
     *  You are on the CC list for the bug. 



--------
[1] https://bugs.freedesktop.org/show_bug.cgi?id=56960#c16
[2] https://bugs.freedesktop.org/show_bug.cgi?id=56960
[3] mailto:markus.mohrhard@googlemail.com
[4] show_bug.cgi?id=56960#c15
[5] mailto:bugzilla-daemon@freedesktop.org
Comment 18 Markus Mohrhard 2013-06-03 21:56:12 UTC
> I'll look into your patch and all the other necessary changes to get it
> integrated.

Your patch looks ok and the remaining parts are on my Todo list. Could you please send a license statement to the developer mailing list similar to the one at https://wiki.documentfoundation.org/Development/Developers?
Comment 19 Commit Notification 2013-06-04 03:21:16 UTC
Tim Richardson committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c30a8f1738f8ef3ff842b27c54ef28891ce85d91&h=libreoffice-4-1

use better values for OOXML border width, fdo#56960


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2013-06-04 03:21:37 UTC
Tim Richardson committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a6833704bcfe6b5b5b6eb020eb79aebf0dc6cd4f

use better values for OOXML border width, fdo#56960



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 21 Kevin Suo 2013-06-07 02:08:54 UTC
*** Bug 62513 has been marked as a duplicate of this bug. ***
Comment 22 Kevin Suo 2013-06-07 02:13:15 UTC
*** Bug 60607 has been marked as a duplicate of this bug. ***
Comment 23 Kevin Suo 2013-06-19 02:17:21 UTC
(In reply to comment #20)
> Tim Richardson committed a patch related to this issue.
> It has been pushed to "master":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=a6833704bcfe6b5b5b6eb020eb79aebf0dc6cd4f
> 
> use better values for OOXML border width, fdo#56960
> 
> 
> 
> The patch should be included in the daily builds available at
> http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> http://wiki.documentfoundation.org/Testing_Daily_Builds
> Affected users are encouraged to test the fix and report feedback.

Thanks for the patch, and I can see the patch is taking effect in the newly released Libreoffice 4.1 Beta2.

However, when testing LO.4.1 Beta2I found another bug:
create a new file with calc, apply some border styles, save as ms office 2010 xlsx format, reopen it, you will see the right and left borders are missing, while the top and bottom borders are perfect.

Maybe I should file a new bug re Libreoffice 4.1 beta2 ?
Comment 24 Mikeyy - L10n HR 2013-06-19 07:48:32 UTC
@suokunlong
Can you please test bug 60607 which was marked as duplicate of this bug with 4.1 beta? https://bugs.freedesktop.org/show_bug.cgi?id=60607
I cannot install experimental releases on work comp.
Comment 25 Kevin Suo 2013-06-19 09:34:16 UTC
06/19/2013 03:48 PM, bugzilla-daemon@freedesktop.org wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=56960
>
> --- Comment #24 from Mikeyy <mikeyy.vip@gmail.com> ---
> @suokunlong
> Can you please test bug 60607 which was marked as duplicate of this bug with
> 4.1 beta? https://bugs.freedesktop.org/show_bug.cgi?id=60607
> I cannot install experimental releases on work comp.
>
I tested it and reopened that bug report, see:
https://bugs.freedesktop.org/show_bug.cgi?id=60607
Comment 26 Kevin Suo 2013-06-24 09:00:53 UTC
The border seems ok now in Libreoffice 4.1 RC 1, 

but,When:
* create a new spreadsheet, 
* apply some borders with the default "border" icon in the toolbar (which is 0.05pt border width),
* save as xlsx,
* reopen with libreoffice 4.1 RC1, border is OK (thin line),
* open with MS Office or other office suites like Kingsoft Office, Yozo Office etc., the border is dashed (rather than the thin line).
Comment 27 Mikeyy - L10n HR 2013-06-24 11:21:08 UTC
Reported that bug 48282 some time ago.
Comment 28 Noel Power 2013-06-24 18:59:04 UTC
(In reply to comment #26)
> The border seems ok now in Libreoffice 4.1 RC 1, 
> 
> but,When:
> * create a new spreadsheet, 
> * apply some borders with the default "border" icon in the toolbar (which is
> 0.05pt border width),
> * save as xlsx,
> * reopen with libreoffice 4.1 RC1, border is OK (thin line),
> * open with MS Office or other office suites like Kingsoft Office, Yozo
> Office etc., the border is dashed (rather than the thin line).

isn't this a new issue ? export related. This bug already seems rather a mess of sub-issues, adding yet another in here really doesn't help I don't think. I suppose it is possible that this issue is related to the patch from comment #19 maybe this is what you are trying to point out, did exporting a new spreadsheet with 'default' border produce the correct (non dashed) before that patch ?
Comment 29 Markus Mohrhard 2013-06-24 19:22:40 UTC
(In reply to comment #28)
> (In reply to comment #26)
> > The border seems ok now in Libreoffice 4.1 RC 1, 
> > 
> > but,When:
> > * create a new spreadsheet, 
> > * apply some borders with the default "border" icon in the toolbar (which is
> > 0.05pt border width),
> > * save as xlsx,
> > * reopen with libreoffice 4.1 RC1, border is OK (thin line),
> > * open with MS Office or other office suites like Kingsoft Office, Yozo
> > Office etc., the border is dashed (rather than the thin line).
> 
> isn't this a new issue ? export related. This bug already seems rather a
> mess of sub-issues, adding yet another in here really doesn't help I don't
> think. I suppose it is possible that this issue is related to the patch from
> comment #19 maybe this is what you are trying to point out, did exporting a
> new spreadsheet with 'default' border produce the correct (non dashed)
> before that patch ?

The bug fix for this issue and the export issue are unrelated and are old issues. The border export is a nasty beast and on my list as I mentioned in Comment 16 and Comment 18.

I just don't have enough time right now to look at all the issues on my list.
Comment 30 Commit Notification 2013-06-24 20:16:19 UTC
Noel Power committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1680a8cd4f4393ec15c4f85cb63b6654117d56d1

fix hair & fine cell border export ( followon fix fdo#56960 )



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 31 Commit Notification 2013-06-25 09:49:43 UTC
Noel Power committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=69dcacedaccd1d698a54eed615ee8739747bc975

unit test for commit:1680a8cd4f4393ec15c4f85cb63b6654117d56d1 (fdo#56960)



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 32 Commit Notification 2013-06-28 08:16:20 UTC
Noel Power committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f9b7fe9140ccec30167eba861d9979b03379c121&h=libreoffice-4-1

fix hair & fine cell border export ( followon fix fdo#56960 )


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 33 Commit Notification 2013-06-28 08:16:41 UTC
Noel Power committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=74e313801cf5e30c5dcbaa607904d7441b6dff4b&h=libreoffice-4-1

unit test for commit:1680a8cd4f4393ec15c4f85cb63b6654117d56d1 (fdo#56960)


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 34 Kevin Suo 2013-07-01 08:01:40 UTC
I remind you all that, this bug exists in LibreOffice 3.6.6,

So, is the patch mentioned here also applied to LibreOffice 3.6.6? If not, maybe the version field should be changed to an older version?
Comment 35 Kevin Suo 2013-07-01 08:55:13 UTC
*** Bug 60599 has been marked as a duplicate of this bug. ***
Comment 36 tommy27 2013-07-01 08:58:44 UTC
changing version to 3.6.6 according to previous comment.

regarding backporting to 3.6.x branch I suppose it's too late...

3.6.7 is already in RC1 status and will be the last of 3.6.x series.
https://wiki.documentfoundation.org/ReleasePlan/3.6#3.6.7_release

maybe the devs should consider backporting to LibO 4.0.5
Comment 37 Kevin Suo 2013-07-01 09:08:58 UTC
(In reply to comment #36)
> changing version to 3.6.6 according to previous comment.
> 
> regarding backporting to 3.6.x branch I suppose it's too late...
> 
> 3.6.7 is already in RC1 status and will be the last of 3.6.x series.
> https://wiki.documentfoundation.org/ReleasePlan/3.6#3.6.7_release
> 
> maybe the devs should consider backporting to LibO 4.0.5

Should the developers do sth to backport this to 3.6.X because this border issue is really annoying. For me it's the only reason not to open and edit xlsx with libreoffice.

I really expect this issue be fixed in 3.6.X because 3.6.X seems to be the most stable release for productivity usage.
Comment 38 tommy27 2013-07-01 09:28:12 UTC
the 4.0.x branch is already considered stable at the 4.0.4 release and has hundreds of fixes in respect to the 3.6.x branch that will be soon abandoned.

as I said before, I'm afraid the fix will not be integrated in 3.6.7 but maybe there are good chance for 4.0.5... I think that a 3.6.6 --> 4.0.5 upgrade would be a good option for you
Comment 39 ign_christian 2013-07-18 03:40:46 UTC
*** Bug 67008 has been marked as a duplicate of this bug. ***
Comment 40 Kevin Suo 2013-07-26 01:39:31 UTC
*** Bug 53287 has been marked as a duplicate of this bug. ***
Comment 41 tommy27 2013-07-26 02:49:57 UTC
@suokunlong@gmail.com

LibO 4.1 is out.
please verify if the fix solved the reported bug.
Comment 42 stragu 2013-09-11 23:18:15 UTC
I can confirm that this was fixed in LO 4.1.

Can we expect to see this fix getting into 4.0.6 ?

Cheers
Comment 43 Lewi S. Kristianto 2014-01-02 08:38:11 UTC
Created attachment 91406 [details]
dot border excel print incorrectly
Comment 44 Lewi S. Kristianto 2014-01-02 08:43:37 UTC
I have submit screenshot for dot table created in .xlsx doesn't print correctly in LibreOffice 4.1.4 (https://bugs.freedesktop.org/attachment.cgi?id=91406)

step to produce:
1. create with dot border in excel
2. open in libreoffice, print preview doesn't show correctly

machine:
Mac OS X 10.7.5 in LibreOffice Version: 4.1.4.2
Comment 45 Markus Mohrhard 2014-01-02 08:45:31 UTC
Please open a new bug report. This one is about a different problem.