Bug 60316 - PPTX FILEOPEN: chart background is white instead of Automatic/No fill plot area
Summary: PPTX FILEOPEN: chart background is white instead of Automatic/No fill plot area
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: All All
: medium normal
Assignee: nd101
URL:
Whiteboard: target:7.1.0
Keywords:
: 104750 134217 (view as bug list)
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2013-02-05 10:30 UTC by Kirill
Modified: 2020-10-10 07:25 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
pptx file (159.84 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2013-02-05 10:30 UTC, Kirill
Details
screen ms office 2010 (577.98 KB, image/png)
2013-02-05 10:36 UTC, Kirill
Details
screen libre office 3.6.5.2 (529.08 KB, image/png)
2013-02-05 10:36 UTC, Kirill
Details
PDF export using 4.4.0.0 alpha from Oct 6 (147.78 KB, application/pdf)
2014-10-07 10:35 UTC, Buovjaga
Details
MSO options - there's Automatic and No Fill for plot area (chart background) (490.81 KB, image/png)
2017-05-03 16:17 UTC, Timur
Details
LO options - there's no Automatic and No Fill for chart background (in Edit mode) (282.29 KB, image/png)
2017-05-03 16:19 UTC, Timur
Details
LO options with patch (154.74 KB, image/png)
2020-07-17 17:18 UTC, Timur
Details
Example file in current Impress (303.60 KB, image/png)
2020-08-10 10:20 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kirill 2013-02-05 10:30:55 UTC
Created attachment 74230 [details]
pptx file

PPTX file, created in MSOffice, opens by LibreOffice with wrong styles (black&white instead coloured)
Comment 1 Kirill 2013-02-05 10:36:08 UTC
Created attachment 74231 [details]
screen ms office 2010
Comment 2 Kirill 2013-02-05 10:36:51 UTC
Created attachment 74232 [details]
screen libre office 3.6.5.2
Comment 3 Jorendc 2013-02-06 13:58:01 UTC Comment hidden (obsolete)
Comment 4 Jorendc 2013-03-04 19:15:59 UTC
(In reply to comment #3)
> Thanks for reporting,
> I can reproduce this behavior.

Reproduced using Linux Mint 14 x64 LibreOffice 4.0.1.2 rc.
Comment 5 Xisco Faulí 2014-02-28 13:38:49 UTC
In
   - Libreoffice 4.2.1.1 Build  ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b
   - Libreoffice 4.3.0.0.alpha0 ID: f839b5dd16c05c0eda21345ec36ec0cb024eb732

styles are already imported with colors. However, the color is not the same as in Powerpoint 2010.
Besides, in Libreoffice the chart on the second slide has a white background. In PP 2010 there's no background.
Comment 6 Buovjaga 2014-10-07 10:35:07 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2015-10-14 19:58:02 UTC Comment hidden (obsolete)
Comment 8 Buovjaga 2016-01-30 14:54:51 UTC
(In reply to Beluga from comment #6)
> Created attachment 107475 [details]
> PDF export using 4.4.0.0 alpha from Oct 6
> 
> Color in 4.4.0.0 and 4.3.2.2 looks the same to me as in the Word screenshot.
> The problem with the white background on page 2 persists.
> The reflection effect with the text on page 1 is not there in LO.

Same.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 9784ff3d878eaa21491fbd779e57d7d4710f5449
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-01-30_01:31:57
Locale: fi-FI (fi_FI)
Comment 9 Xisco Faulí 2016-12-18 16:58:51 UTC
*** Bug 104750 has been marked as a duplicate of this bug. ***
Comment 10 Timur 2017-05-03 16:17:57 UTC
Created attachment 133044 [details]
MSO options - there's Automatic and No Fill for plot area (chart background)
Comment 11 Timur 2017-05-03 16:19:20 UTC
Created attachment 133045 [details]
LO options - there's no Automatic and No Fill for chart background (in Edit mode)

In LO options - there's no Automatic and No Fill for chart background (in Edit mode) or I can't see it. So I guess it just gives "white" color.
Comment 12 Xisco Faulí 2017-10-19 15:10:44 UTC
Still reproducible in

Version: 6.0.0.0.alpha0+
Build ID: cfbb8b5090537e79ba70e250ddee86d53facbe15
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 13 QA Administrators 2019-08-19 06:56:13 UTC Comment hidden (obsolete)
Comment 14 Timur 2019-08-27 07:34:26 UTC
Repro 6.4+
Comment 15 Xisco Faulí 2019-10-15 22:47:57 UTC
The problem is that MSO doesn't set the automatic value explicitly, as it does with other options, like no fill:

<c:spPr>
 <a:noFill/>
</c:spPr>
Comment 16 Xisco Faulí 2019-10-15 22:56:31 UTC
Another finding, it seems Word sets the automatic background to white, powerpoint to no fill...
Comment 17 NISZ LibreOffice Team 2020-06-22 07:25:00 UTC
*** Bug 134217 has been marked as a duplicate of this bug. ***
Comment 18 nd101 2020-06-24 02:29:13 UTC
Patch fixed this BUG, and it is under code review

https://gerrit.libreoffice.org/c/core/+/96955
Comment 19 Buovjaga 2020-06-24 18:43:10 UTC
(In reply to nd101 from comment #18)
> Patch fixed this BUG, and it is under code review
> 
> https://gerrit.libreoffice.org/c/core/+/96955

I confirm the chart wall has no fill with the patch!

Arch Linux 64-bit
Version: 7.1.0.0.alpha0+
Build ID: 090477feb304dd293c8dbf9bf729a3b3a41ae4df
CPU threads: 8; OS: Linux 5.7; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 24 June 2020
Comment 20 Commit Notification 2020-07-14 20:07:10 UTC
nd101 committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d851a02df57ab378ed0cc6d9362516de09c3279c

tdf#60316 Chart plotarea background issue

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2020-07-15 21:49:19 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/cb6a7b988a00500fbc4116c38bc1a959ca16d065

tdf#60316: chart2_export: Add unittest

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Timur 2020-07-17 17:18:50 UTC
Created attachment 163196 [details]
LO options with patch

Background is fine on fileopen.
Properties for Area are somewhat strange.
Comment 23 NISZ LibreOffice Team 2020-08-10 10:20:30 UTC
Created attachment 164097 [details]
Example file in current Impress

Now it looks good (in non-edit mode at least) and Area properties side bar correctly displays None fill type.