Bug 62938 - FORMATTING: Print ranges: when more rows (including row $1) are set to repeat, that first will be removed from the rows to repeat, after saving&opening of file
Summary: FORMATTING: Print ranges: when more rows (including row $1) are set to repeat...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha1
Hardware: Other All
: medium normal
Assignee: Markus Mohrhard
URL:
Whiteboard: BSA target:4.1.0.0.beta2 target:4.2.0...
Keywords: regression
: 61056 61436 Luchito 64373 64535 64564 64642 64644 64785 65392 66697 67262 (view as bug list)
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2013-03-30 16:14 UTC by me
Modified: 2013-11-26 09:28 UTC (History)
28 users (show)

See Also:
Crash report or crash signature:


Attachments
spreadsheet with various print ranges on various sheets (12.44 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-06-02 08:00 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description me 2013-03-30 16:14:42 UTC
Problem description: 
I use spreadsheets where I need to repeat $1:$2 on each page for printing. I can set via edit print ranges and print but it won't save this reverting to just $2 on reopening

Steps to reproduce:
1. Format > Print ranges > Edit...
2. Rows to repeat - User defined - set to $1:$2
3. Save, close & reopen.
4. 1. & 2. above showing just $2 requiring re-setting

Current behavior:
Won't save print range: rows to repeat format.

Expected behavior:
To save user defined print range: rows to repeat format

Columns seems to be ok

              
Operating System: Windows 7
Version: 4.0.1.2 release
Comment 1 me 2013-03-30 16:20:03 UTC
This may be of importance, in the top two rows to repeat some of the columns are merged cells, others aren't.
Comment 2 retired 2013-04-04 21:39:32 UTC
Reproducibe on OS X 10.8.2 LO 4.0.2.2.

Proceeding as described by bug-reporter leads to the described behavior.

-> NEW
Comment 3 me 2013-04-05 08:49:05 UTC
(In reply to comment #1)
> This may be of importance, in the top two rows to repeat some of the columns
> are merged cells, others aren't.

I tested using un merged cells but 2 repeated and the same happens
Comment 4 Thomas Thym 2013-04-08 09:49:25 UTC
I can confirm this bug in LO 4.0.1.2 and 4.0.2.2 on Windows XP and in LO 4.0.2.1 on Linux (openSUSE). => Platform: All

Some more information:
- The "print range - repeat row"-information is saved correctly. Opened with LO 3.5.? or AOO 3.4.1 the setting is ok. It might not be a "save" bug, but on "open" bug.
- It seems that only row 1 is affected. Any other row I tried worked.
Comment 5 Thomas Thym 2013-04-08 09:54:59 UTC
*** Bug 61436 has been marked as a duplicate of this bug. ***
Comment 6 me 2013-04-08 18:30:42 UTC
A work around in the meantime should you need it:

Insert row above so blank row 1. Set row height to 0. Set print range to repeat as $2:$3
Comment 7 Mike 2013-05-06 08:22:34 UTC
I can confirm this bug in
LO 4.0.3.3
Win 7
Comment 8 Thomas van der Meulen 2013-05-09 08:09:22 UTC
*** Bug 64373 has been marked as a duplicate of this bug. ***
Comment 9 Jacques Guilleron 2013-05-13 14:04:44 UTC
*** Bug 64535 has been marked as a duplicate of this bug. ***
Comment 10 Jacques Guilleron 2013-05-13 14:25:45 UTC
*** Bug 63342 has been marked as a duplicate of this bug. ***
Comment 11 m.a.riosv 2013-05-15 22:07:52 UTC
*** Bug 64644 has been marked as a duplicate of this bug. ***
Comment 12 ign_christian 2013-05-18 03:45:23 UTC
*** Bug 64642 has been marked as a duplicate of this bug. ***
Comment 13 ign_christian 2013-05-20 09:32:45 UTC
*** Bug 64785 has been marked as a duplicate of this bug. ***
Comment 14 ign_christian 2013-05-20 09:46:44 UTC
*** Bug 64564 has been marked as a duplicate of this bug. ***
Comment 15 Cor Nouws 2013-06-02 07:55:03 UTC
already existing in 400alpha1
Comment 16 Cor Nouws 2013-06-02 08:00:27 UTC
Created attachment 80146 [details]
spreadsheet with various print ranges on various sheets

Attached a test document.

1- opened in 400alpha1: to repeat headers in sheet 1 and 5 are changed 

2- correct to repeat headers

3- save

4- open in 366: to repeat headers in sheet 1 and 5 are OK

 > error is on opening the file
 > regression from 3.6
Comment 17 Markus Mohrhard 2013-06-02 22:46:10 UTC
I suppose I should look into it as Joren pointed out it might have been a commit that went through my review which introduced the regression.
Comment 18 Commit Notification 2013-06-03 02:40:55 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3c332c935e3531ca58fafebe79f7f99cf9d16a72&h=libreoffice-4-1

the print range can start in row 0, fdo#62938


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2013-06-03 02:41:16 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e1c70f2f046ab6c5bb808666b4f5466902b9fcf8

the print range can start in row 0, fdo#62938



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2013-06-03 02:41:36 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a719841d02fb93ddfc80956c5e6e417f551e8a9f

add test case for fdo#62938



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2013-06-03 03:15:09 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4e8d0a9efe4d549789995344c637bac5bede1893&h=libreoffice-4-1

Revert "the print range may start in row 0, fdo#62938"


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2013-06-03 03:15:29 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=07e24af2801ae28a5552c4afc9ea3730aa00914c&h=libreoffice-4-1

correct fix for fdo#62938


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2013-06-03 03:15:50 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=59519242dd11ac91720a9646197b803f5ed812b7

Revert "the print range may start in row 0, fdo#62938"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2013-06-03 03:16:10 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7dfb72e69c629e5897ee515f8c42b7e45610ab8e

correct fix for fdo#62938



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 25 Markus Mohrhard 2013-06-04 20:46:43 UTC
Pending review for 4-0.
Comment 26 Cor Nouws 2013-06-05 07:17:33 UTC
*** Bug 65392 has been marked as a duplicate of this bug. ***
Comment 27 Commit Notification 2013-06-06 13:34:55 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2e5b6fd2d1c1b23eef3c32222bfb0efd7a27d21d&h=libreoffice-4-0

correct fix for fdo#62938


It will be available in LibreOffice 4.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 28 Thomas Thym 2013-07-15 14:02:33 UTC
Thanks, Markus, for the fix! It helps us a lot!
Comment 29 ign_christian 2013-07-24 15:52:21 UTC
*** Bug 67262 has been marked as a duplicate of this bug. ***
Comment 30 ign_christian 2013-10-04 10:16:57 UTC
*** Bug 61056 has been marked as a duplicate of this bug. ***
Comment 31 Jacques Guilleron 2013-11-26 09:28:38 UTC
*** Bug 66697 has been marked as a duplicate of this bug. ***