Download it now!
Bug 65980 - Wrong message shown when opening large file using XSLT filter
Summary: Wrong message shown when opening large file using XSLT filter
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 61546 70537 82264 95334 97472 (view as bug list)
Depends on:
Blocks: Dialog-Msgbox
  Show dependency treegraph
 
Reported: 2013-06-20 18:50 UTC by Dmitry Yakimov
Modified: 2018-11-26 16:28 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
The test file (1.21 MB, application/xml)
2013-06-20 18:50 UTC, Dmitry Yakimov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Yakimov 2013-06-20 18:50:34 UTC
Created attachment 81128 [details]
The test file

The file attached is viewed fine in Microsoft word viewer but when open in libre office I get a message "general input/output" error.
Comment 1 p_kongstad 2013-06-20 19:20:31 UTC
Hi,

I have been testing this file and confirm that I get the message 'General input/output".

The processor is running at 100% and opening the file take more than 2 minutes to reach the error message.

However, when pressing retry the file is opening.
Comment 2 Dmitry Yakimov 2013-06-20 20:11:15 UTC
On low speed processor (netbook) it can took 2 times to press to retry to get result. Note that formatting of the table looks strange
Comment 3 Mike Kaganski 2013-09-23 05:01:21 UTC

*** This bug has been marked as a duplicate of bug 67699 ***
Comment 4 Maxim Monastirsky 2013-09-23 11:08:47 UTC
It's not a duplicate of bug 67699, as the latter is a regression of 4.1, while this bug was reported against 4.0. Also bug 67699 is fixed as of 4.1.2.2, while this bug still reproducible. Tested with Fedora 19 (64-bit) in VirtualBox + lowered Execution Cap (to emulate slow processor). However it opens fine on my host machine (LO 4.1.1.2 under Ubuntu 13.04 64-bit).
Comment 5 Mike Kaganski 2013-09-23 11:34:27 UTC
(In reply to comment #4)
You are absolutely right. Still reproducible under Ubuntu. I should have been more careful.
Comment 6 Maxim Monastirsky 2013-10-18 09:10:32 UTC
*** Bug 70537 has been marked as a duplicate of this bug. ***
Comment 7 Maxim Monastirsky 2013-10-19 18:27:05 UTC
Caused by http://cgit.freedesktop.org/libreoffice/filters/commit/?id=2e9f9d82110342601d28408ae77d63b673993ebe. There is always 60 seconds timeout before the error message is displayed. So if the document is not so large and the processor is not so slow, then it opens without any error. For more information, see Bug 35543.
Comment 8 Maxim Monastirsky 2013-11-12 15:41:22 UTC
*** Bug 61546 has been marked as a duplicate of this bug. ***
Comment 9 Kevin Suo 2014-07-17 03:43:06 UTC
Reproduce with Version: 4.3.1.0.0+
Build ID: 5536b127a105123de6f64dcf8f53dfa277faef3c
TinderBox: Win-x86@42, Branch:libreoffice-4-3, Time: 2014-07-16_10:15:31
Windows XP SP3.

Set platform to all.
Comment 10 Kevin Suo 2014-07-17 03:50:09 UTC
I first noticed this bug behaviour when I was trying to open a 100M MS 2003 XML spreadsheet. MSO 2013 opens that file within 5 seconds, but LibreOffice takes forever to load it while using 100% CPU, then finally gives I/O error message.

I was thinking LO failed to load it because of its file size. But after I made the file size much smaller (50M->10M-5M...), LibreOffice still fails to open it (high CPU, error message).

Files with only a few KB size can open with no problem
Comment 11 Maxim Monastirsky 2014-08-06 20:52:08 UTC
*** Bug 82264 has been marked as a duplicate of this bug. ***
Comment 12 Jan Kratochvíl 2014-08-14 21:59:57 UTC
Hi all, I have the exact problem.

LO Calc 4.3.0.4

I thouught, the problem is the XML format, but it's the size.

Strange thing is, that this bug says, it!s been fixed long time ago...

http://www.libreoffice.org/bugzilla/show_bug.cgi?id=44969
Comment 13 Jan Kratochvíl 2014-08-14 22:07:02 UTC
Another strange thing is, that Calc can save such file just fine.

I have just tried to create large 10Mb spread sheet, save it as XML file, which works fine. Then when you try to open it, it crashes....
Comment 14 Maxim Monastirsky 2014-08-16 19:16:07 UTC
Just to clarify: This "General I/O error" message is not a bug but a feature - see bug 35543 comment 20. It will appear every 60 seconds *anyway*, a user just need to click "Retry" to continue the import process. The real bug here is the wrong text of that message.
Comment 15 Jan Kratochvíl 2014-08-17 20:48:17 UTC
OK, I get the point, but in that case, why it takes 5 minutes to open 10Mb file? (5x times click retry)

Should I write bug on that?
Comment 16 Maxim Monastirsky 2014-08-18 07:47:38 UTC
(In reply to comment #15)
> OK, I get the point, but in that case, why it takes 5 minutes to open 10Mb
> file? (5x times click retry)
XSLT processing is slow, it's not related to LO. Try it yourself from the terminal:

$ xsltproc --output output.fods /opt/libreoffice4.3/share/xslt/import/spreadsheetml/spreadsheetml2ooo.xsl input.xml

> Should I write bug on that?
No.
Comment 17 Jan Kratochvíl 2014-08-18 09:31:50 UTC
OK, I get the point again. So the solution is not to use XML, but other format.

Thanks for clearing that out.
Comment 18 Michael Wood 2014-08-18 12:28:42 UTC
(In reply to Comment # 16
<https://bugs.freedesktop.org/show_bug.cgi?id=65980#c16>)

> XSLT processing is slow, it's not related to LO. Try it yourself from the
> terminal:


Yes, XSLT processing might be slow.  I'm not sure that is a sufficient
answer.

Excel manages to open such files in a fraction of a second where
LibreOffice takes minutes.  You might argue that these files are not very
common and therefore it's not worth fixing this, but from a user's point of
view, it just seems excessively slow.

I agree that fixing the message will be an improvement, because at the
moment there's no indication that clicking on retry is something that is
likely to help.
Comment 19 Maxim Monastirsky 2014-08-18 14:14:28 UTC
(In reply to comment #18)
> Yes, XSLT processing might be slow.  I'm not sure that is a sufficient
> answer.
This is a sufficient answer, because we don't have a real filter for those types, just this horrible XSLT stuff. There is nothing better currently.

> You might argue that these files are not very common and therefore it's not
> worth fixing this
I didn't say that (and BTW such files are more common than you might think). The point here is that there is no way to "fix" this like any other bug, instead someone needs to create a whole new filter for those types (which is not a trivial task). And just like any other feature request we have, someone needs to be interested enough to work on this.

Anyway this discussion is out of scope for this particular bug, because the error message in question is not specific to one particular format.
Comment 20 Peter Jentsch 2015-02-08 22:28:18 UTC
I can open the attach WordML 2003 file fine with LibreOffice 4.3.3.2 (on a quad-core machine though). 

The XSLT filter has a built-in timeout that should prevent libreoffice from handing indefinitely in case the filter takes to long. With large files on slower machines that timeout might prevent loading the file even though the filter would eventually finish importing. 

The import and export filters for Office 2003 XML are suboptimal an would need a rewrite in order to support a larger feature set or larger files. 

If at all possible, save your files to OOXML and import those files to LibreOffice. 

I will take the time to look at the problem, but it's very likely I will not be able to fix it.
Comment 21 Maxim Monastirsky 2015-10-26 19:16:31 UTC
*** Bug 95334 has been marked as a duplicate of this bug. ***
Comment 22 Maxim Monastirsky 2016-02-01 19:00:49 UTC
*** Bug 97472 has been marked as a duplicate of this bug. ***
Comment 23 QA Administrators 2018-10-27 02:55:24 UTC Comment hidden (obsolete)
Comment 24 Roman Kuznetsov 2018-11-26 11:54:49 UTC
in

Version: 6.2.0.0.beta1
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

Opening of attached file takes 15 sec on Core i3-3120 (2,5GHz) and I didn't see any error message

Xisco, I'm not sure, WFM or not?
Comment 25 Mike Kaganski 2018-11-26 13:10:43 UTC Comment hidden (obsolete)
Comment 26 Mike Kaganski 2018-11-26 14:23:50 UTC
(In reply to Mike Kaganski from comment #25)

Sorry - the file in question is not the Excel 2003 XML. Sorry for the noise.
Comment 27 Jan Kratochvíl 2018-11-26 15:47:38 UTC
I can confirm, that opening large XLS XML files works. The speed is comparable to MS Excel. I thing this bug can be closed.