Bug Hunting Session
Bug 72668 - Allow user to remove all the recent items from StartCenter in one action
Summary: Allow user to remove all the recent items from StartCenter in one action
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.0.beta1
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Start-Center
  Show dependency treegraph
 
Reported: 2013-12-13 08:07 UTC by narayanaras
Modified: 2014-07-24 18:45 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description narayanaras 2013-12-13 08:07:28 UTC
The launch screen of LibreOffice shows thumbnails of recent items. 

However, there is not facility to remove selected items (to remove clutter, or to hide a sensitive document).

Also, there is no facility to clear all items from this screen. A user may need this to start building the list afresh.

Please provide a feature to remove selected or all items from the list.
Comment 1 Joel Madero 2013-12-22 16:31:44 UTC
Thank you for reporting this enhancement request! I can confirm that this is a valid enhancement request on:
Version: 4.3.0.0.alpha0+Build ID: daa57a101a20e0b37db7090796ad002b8d192b9b
Date:   Sun Dec 15 23:07:57 2013 +0100 
Platform: Ubuntu Linux 13.10 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm the enhancement request I am marking as:

New (confirmed)
Enhancement
High - another one that seems useful given the fact that our recent documents list can get so large now. Also maybe in some cases people don't want other people to know that particular documents are accessed routinely and want to "always hide" from the list.

Kendy - another one, again apologies if you're the wrong person to ping about this

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 pierre-yves samyn 2013-12-29 12:05:48 UTC
Hello

1. Remove

"File> Recent Documents> Clear list" is not enough ?
Really too far ?

2. Hide (one or a selection)

For this to be possible we should be able to select, but a single click or right-click directly open the document.

Also depends on bug 71957

Regards
Pierre-Yves
Comment 3 pierre-yves samyn 2013-12-29 12:08:38 UTC
Sorry, please read:
 
> For this to be possible we should be able to select (simple click or
> right-click), but a single click  directly open the document.
> 
Regards
Pierre-Yves
Comment 4 narayanaras 2013-12-29 12:32:47 UTC
Actually we should have the following features:

1. Let user select one or more continuous/non-contiguous items (by using SHFT/CTRL and clicking)

2. Provide a context menu with at least two options: (a) Clear and (b) pin.

All pinned items should go to the top of list, above a line. All cleared items should disappear from screen (and also from the "Recent items" list).
Comment 5 Jean-Baptiste Faure 2014-01-11 16:43:07 UTC
As a workaround, you can manage the recent file list with the HistoryMaster extension. You can find it on the OpenOffice repository : http://extensions.openoffice.org/fr/project/history-master

Best regards. JBF
Comment 6 ign_christian 2014-07-03 03:13:04 UTC
*** Bug 80833 has been marked as a duplicate of this bug. ***
Comment 7 Cor Nouws 2014-07-03 04:24:22 UTC
has been implementend in 4.3.0 since one can click on a cross on each picture. No?
IMO WorksForMe ?
Comment 8 narayanaras 2014-07-03 05:34:57 UTC
Hi

Well, the "clear selected" portion has the connotation of RAPIDLY selecting multiple items with mouse (lasso) with CTRL/SHFT. That's not done.

Secondly, this issue recommends the "clear all" option also, which is not implemented at all. 

Therefore this issue should be left open.

@Worksforme:
When I made the request, the need DID exist. The remove (X) button was added much later, so a WorksForMe resolution would be like pretending that the feature always existed, and the reporter missed it. This is disrespectful to the reporter.
Comment 9 Joel Madero 2014-07-03 05:44:35 UTC
WORKSFORME is just our workflow - if something is fixed after the report is made then we close it as WORKSFORME unless we know the exact commit that fixed it, in which case it is FIXED.

So it is not meant to be disrespectful - simply our internal workflow
Comment 10 V Stuart Foote 2014-07-04 17:05:58 UTC
(In reply to comment #8)
> Well, the "clear selected" portion has the connotation of RAPIDLY selecting
> multiple items with mouse (lasso) with CTRL/SHFT. That's not done.

Rework of GUI to providing a StartCenter thumbnail view display of the recent documents list was the initial scope of StartCenter.

Since evolving the StartCenter (bug 61914, bug 64088, and UX Design channels) several requested enhancements have been made to the GUI to allow selective removal of recent documents--but this is all done manipulating the GTK+ UI Widgets implementation, it is not a full VCL implementation.

At 4.3 Kendy has added function to remove selected document (one by one) from StartCenter with:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=60cd850d672bc1dcc3eb24adfffa7a6ab98a44bd

http://cgit.freedesktop.org/libreoffice/core/commit/?id=978ba69d33cf31cd334f18af5215166dd3926402

Bug 61174 is a more comprehensive rework of handling the Recent Document list, which then is reflected graphically on the Start Center.

Bug 71957 and similar "wrangling" to refine our implementation of UI widgets is still required to allow OS specific GUI "selection" and manipulation on the StartCenter and the Template Manager.


> 
> Secondly, this issue recommends the "clear all" option also, which is not
> implemented at all. 

The clear all recent IS correctly implemented from File -> Recent Documents -> Clear list (bug 62028). Placing a button action on the start center to do the same was discussed and rejected.

Yes it is clunky, but the level of OS GUI primitive manipulation needed to graphically manipulate is simply not available with this cross platform project.

No disrespect, but closing as Resolved Fixed.