Bug Hunting Session
Bug 85966 - No ability to copy / duplicate master slides
Summary: No ability to copy / duplicate master slides
Status: RESOLVED DUPLICATE of bug 45617
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Context-Menu Matters-to-Caolan Master-Slide-View
  Show dependency treegraph
 
Reported: 2014-11-06 13:47 UTC by Máirín Duffy
Modified: 2017-10-26 22:51 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Máirín Duffy 2014-11-06 13:47:38 UTC
Problem description: 

Description from end user I've been trying to assist on this:

"If I have a master page I'm happy with, but then want to make a new variant with some minor modifications (a slightly different layout, say), I can't seem to find any way to copy the original one. The only way I've succeeded is by creating a new master page (which adopts the default layout/style), and then painstakingly copying every change I made to the original to the second page. This is frustratingly time-consuming and inefficient."

I was able to find a (rather convoluted) work-around:

- Save your preso with the master slide you want to copy, say as foo.odp
- Save it again, this time as bar.odp
- Open up foo.odp so you have two impress windows open
- Open up the master view in each impress window
- Drag the master you want to make a copy of to the slide canvas in the center of the impress window (not the slide pane on the left)
- You'll have a copy of the slide master you dragged over added to the bottom of the slide pane list

Would it be possible to add a 'duplicate' function to the right click context menu of slides in the master slide pane?
Comment 1 Máirín Duffy 2014-11-06 14:22:10 UTC
A note: this bug is the same problem with a diff suggested solution:
https://bugs.freedesktop.org/show_bug.cgi?id=45617
Comment 2 Cor Nouws 2014-11-06 14:46:07 UTC
Hi Máirín,

Thanks for filing the issue.
Would be a very useful addition indeed.
Currently the workaround is: copy the presentation, in that one rename the masterpage, copy&paste a slide with that masterpage to the original presentation :)

Regards,
Cor
Comment 3 Cor Nouws 2014-12-24 10:41:43 UTC
*** Bug 87669 has been marked as a duplicate of this bug. ***
Comment 4 jan d 2016-11-22 13:12:54 UTC
A long time need of myself, too.

Is there any reason why this is not a duplicate of 45617 (Make Impress masterpages copyable)?
Comment 5 Yousuf Philips (jay) (retired) 2016-11-22 13:40:29 UTC

*** This bug has been marked as a duplicate of bug 45617 ***
Comment 6 Xisco Faulí 2017-10-26 22:51:12 UTC
*** Bug 113407 has been marked as a duplicate of this bug. ***