Bug 86872 - Word completion: Add ability to save word completion (aka "auto complete") lists and re-use them
Summary: Word completion: Add ability to save word completion (aka "auto complete") li...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 128903 (view as bug list)
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2014-11-30 11:04 UTC by Shantanu
Modified: 2020-02-29 07:12 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shantanu 2014-11-30 11:04:29 UTC
There is no way to save auto-complete list.
Another limitation is that there is max limit of 10,000 words that auto-complete can handle.
This limit should be increased and please provide an option to save auto complete list that can be reused in the next session.
Comment 1 Robinson Tryon (qubit) 2014-12-09 20:09:24 UTC
(In reply to shantanu from comment #0)
> There is no way to save auto-complete list.

When I add words to my Auto-complete list, they are saved in the following file inside my User Profile:
  user/autocorr/acor_en-US.dat

If I copy that file from my LibreOffice 4.4 beta2 install to my LibreOffice 4.3.5.1 install, the Auto-complete words appear for me in Writer.

I'm going to mark this as RESOLVED WORKSFORME. If you'd like something more detailed (e.g. a GUI for saving the auto-complete list), please describe that in a comment and change the status back to UNCONFIRMED.

> Another limitation is that there is max limit of 10,000 words that
> auto-complete can handle.
> This limit should be increased 

This sounds like a separate issue. Please file a separate enhancement request (bug) for this change.
Comment 2 Shantanu 2014-12-10 01:54:00 UTC
The file acor_en-US.dat contain the "auto correct" word list. Auto Complete word list does not get saved anywhere. I will like to see this option added in the future version of Libre office.
Comment 3 Robinson Tryon (qubit) 2014-12-10 02:33:48 UTC
(In reply to shantanu from comment #2)
> The file acor_en-US.dat contain the "auto correct" word list. Auto Complete
> word list does not get saved anywhere. 

Ah, okay, I see. Yes -- Word completion lists appear to persist across Writer documents during a single session of LibreOffice, but disappear when the program is restarted.

> I will like to see this option added
> in the future version of Libre office.

Sounds reasonable.

Status -> NEW

(In reply to shantanu from comment #0)
> Another limitation is that there is max limit of 10,000 words that
> auto-complete can handle.
> This limit should be increased

Please file that as a separate bug report (and change the Severity to 'enhancement').
Comment 4 Robinson Tryon (qubit) 2014-12-10 04:49:02 UTC
> (In reply to shantanu from comment #2)
> > The file acor_en-US.dat contain the "auto correct" word list. Auto Complete
> > word list does not get saved anywhere. 

Here's a workaround:
https://help.libreoffice.org/Writer/Fine-Tuning_the_Word_Completion_for_Text_Documents#To_Use_the_Word_List_for_Further_Sessions

You can Copy/Paste the list of Word Completion entries into a separate document and save it for later use. It's a little more cumbersome than a built-in mechanism, but I figure it might be of use to you.
Comment 5 Shantanu 2015-06-24 17:12:34 UTC
Thanks for that "workaround" link. But a real solution will be appreciated.
Comment 6 LostLombard 2016-11-27 02:03:01 UTC
It would be good to have the word list saved during version upgrades as well.

https://bugs.documentfoundation.org/show_bug.cgi?id=104193
Comment 7 Sophie Freud 2018-06-22 00:10:49 UTC
Writer now has an option called "When closing a document, remove the words collected from it from the list". Disabling this is supposed to preserve the Word Completion list throughout sessions, but it doesn't seem to work, the word list is still lost after exiting Writer.

See details here: https://bugs.documentfoundation.org/show_bug.cgi?id=118309
Comment 8 Sophie Freud 2018-06-22 00:15:49 UTC
> > (In reply to shantanu from comment #2)
> > > The file acor_en-US.dat contain the "auto correct" word list. Auto Complete
> > > word list does not get saved anywhere. 
> 
> Here's a workaround:
> https://help.libreoffice.org/Writer/Fine-
> Tuning_the_Word_Completion_for_Text_Documents#To_Use_the_Word_List_for_Furthe
> r_Sessions
> 
> You can Copy/Paste the list of Word Completion entries into a separate
> document and save it for later use. It's a little more cumbersome than a
> built-in mechanism, but I figure it might be of use to you.

@Robinson Tryon: this workaround is very, very cumbersome. Word Completion makes much more sense if the collection and the preservation of words works automatically.
Comment 9 Dieter 2019-11-20 20:38:29 UTC
*** Bug 128903 has been marked as a duplicate of this bug. ***
Comment 10 david.c.littman 2019-11-20 21:27:56 UTC
This enhancement request has not had a comment for a long time so I'd like to raise/vote for it again because I believe it would be a very significant addition to the user experience with LO and, therefore, to its prospects for wider adoption especially by people using Word now that W10 apparently has some global autocomplete features.

It would be a tremendous help if new words were added to a global autocomplete list rather than added only to per-document lists.

I just finished writing a book (Democratic Party Renaissance - Rank and File Action Manifesto) and at some point will probably do a 2nd ed and perhaps a follow up volume that addresses some of the topics in depth.

In producing the text I typed hundreds of "new" words (people, places, parties, laws, etc.) and if I do the 2nd ed or a follow up volume I would obviously like those words in my autocomplete list.

I have worked at a professional level as an experimental psychologist, a computer scientist, and other fields in which there are hundreds if not thousands of lexical items one uses every day. Not to be able to, for example, write a second paper on the same topic as 6 months ago and use the same autocomplete list is, to put it mildly, frustrating as all get out.

There are a few hacks. The one I created was: Make and prepopulate a word list document with just all your words, open it whenever you're writing a new document, create the new document, save the new document and the word list document frequently, and it kind of works ok. But that's a pretty circuitous route to achieve what I am sure many many people working in lexically rich disciplines would love to have and when I describe the hack to people who would like to have global autocomplete their eyes start to roll back after the first sentence. 

At the UX level, perhaps along with the "collect words" and "discard when closing document" check boxes in the Tools/Autocorrect/Autocorrect Options panel, add a "add words to global autocomplete list" checkbox.

Then, in options/settings, a choice to "always load global autocomplete list" or just do it by default and, ideally, put a button on the toolbar "Turn On/Off Global Autocomplete" scoped to the current document.

By the way I have 8K words in my prepopulated document and have no performance issues on an old single core 4GB W7 machine so I don't see why the limit couldn't be bumped up to 20K.

I really like autocomplete, have used e.g., LightKey which is a really nice piece of commercial software, and as noted, evidently W10 has some global autocomplete functionality. 

But to provide a robust global autocomplete with an open source product as good as LibreOffice would really advance the cause.

Thanks.
Comment 11 christ.stark 2020-02-29 07:12:46 UTC
I agree. Please improve word completion!
And please include a function that memorizes hyphens manually put into long words.