Bug 90921 - Implement ODF footnotes-position 'text' (19.804) -- to place footnotes at the bottom of the text
Summary: Implement ODF footnotes-position 'text' (19.804) -- to place footnotes at the...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL: http://docs.oasis-open.org/office/v1....
Whiteboard:
Keywords:
: 114600 (view as bug list)
Depends on:
Blocks: Footnote-Endnote
  Show dependency treegraph
 
Reported: 2015-04-29 09:10 UTC by J. F. Manullang
Modified: 2019-11-11 10:51 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Demonstration (16.15 KB, application/vnd.oasis.opendocument.text)
2018-08-31 10:25 UTC, Gellért Gyuris
Details
Before adding sections (19.68 KB, application/vnd.oasis.opendocument.text)
2019-10-10 19:21 UTC, adaw2
Details
After adding sections (19.97 KB, application/vnd.oasis.opendocument.text)
2019-10-10 19:24 UTC, adaw2
Details
After editing a document with sections (21.22 KB, application/vnd.oasis.opendocument.text)
2019-10-10 19:27 UTC, adaw2
Details
The no section sample document, reworked into a single section with footnotes collected at end (16.79 KB, application/vnd.oasis.opendocument.text)
2019-10-10 21:02 UTC, V Stuart Foote
Details
original footnote 9 restored (18.00 KB, application/vnd.oasis.opendocument.text)
2019-10-15 02:20 UTC, V Stuart Foote
Details
Pasted into a new doc, new section (19.93 KB, application/vnd.oasis.opendocument.text)
2019-10-18 21:02 UTC, adaw2
Details
text (double spaced) and reflinked footnotes into a single section (14.91 KB, application/vnd.oasis.opendocument.text)
2019-10-30 22:13 UTC, V Stuart Foote
Details
6 - mocked-up solution (27.37 KB, application/pdf)
2019-11-07 20:59 UTC, adaw2
Details
style guide 1 (171.08 KB, image/jpeg)
2019-11-08 17:47 UTC, adaw2
Details

Note You need to log in before you can comment on or make changes to this bug.
Description J. F. Manullang 2015-04-29 09:10:00 UTC
To whom it may concern:

Please consider my suggestion for the footnote placement option. 
It will be much better if the footnote can be place not only at the bottom of the page but also at the bottom of the text like in Microsoft Word and WordPerfect.

I really appreciate your hard work and good job.

Thank you very much

J. F. Manullang, 
Jakarta, Indonesia
Comment 1 Buovjaga 2015-04-29 16:39:22 UTC
Ok, I'll set to NEW, but please give us some link to documentation of MS Word or WordPerfect or a screenshot that shows the feature.
Comment 2 Buovjaga 2015-04-29 16:39:34 UTC
Corrected priority.
Comment 3 Dieter 2018-01-18 17:43:33 UTC
*** Bug 114600 has been marked as a duplicate of this bug. ***
Comment 4 Gellért Gyuris 2018-08-31 10:25:43 UTC
Created attachment 144579 [details]
Demonstration

I think this feature is already done.

Please, try this:
1. Add some text.
2. Add a footnote.
3. Select the text with footnote and: Insert > Section... Footnotes/Endnotes tab and check Collect at and of the text

See attached document.

I used this feature in LO 6.0 and 6.1
Comment 5 Buovjaga 2018-08-31 12:14:51 UTC
(In reply to Gellért Gyuris from comment #4)
> Created attachment 144579 [details]
> Demonstration
> 
> I think this feature is already done.
> 
> Please, try this:
> 1. Add some text.
> 2. Add a footnote.
> 3. Select the text with footnote and: Insert > Section... Footnotes/Endnotes
> tab and check Collect at and of the text
> 
> See attached document.
> 
> I used this feature in LO 6.0 and 6.1

I think the people requesting this do not want to use sections.

Well, we should ask UX if they think the section method is enough and this should be closed as wontfix or worksforme.
Comment 6 V Stuart Foote 2018-08-31 18:08:54 UTC
Much as with using columns for page layout, sections (and frames) provide structure to the document. For those requiring that layout-- the Format -> Sections -> Options panel for each section provides for footnotes using "collect at end of text" or endnotes "collect at end of section".

It is quite functional if a little obscure--but then this page layout is somewhat specialized.

IMHO the dev effort needed to make the same page layout functions available via normal running paragraph formatting is not justified.

Beleive converting paragraphs into 1 column sections and applying footnote/endnote formatting against the section is sufficient for this style of reference handling.  The only wart is the dependence on the additional formatting controls from the Page style dialog's Footnote tab.

Otherwise, some dev work *is* needed to allow restructuring of documents with movement of sections.

IMHO => WF
Comment 7 Dieter 2018-09-02 08:34:08 UTC
(In reply to V Stuart Foote from comment #6)

> IMHO => WF

In this case I propose to add some additionals informations in the documentation and LO-Help so that people know about the section alternative.
Comment 8 V Stuart Foote 2018-09-02 12:45:51 UTC
(In reply to Dieter Praas from comment #7)
> (In reply to V Stuart Foote from comment #6)
> 
> > IMHO => WF
> 
> In this case I propose to add some additionals informations in the
> documentation and LO-Help so that people know about the section alternative.

The help for the panel seems complete [1], while the Writer Guide 6, pg 137 [2] provides a bit better usage context. What more is needed to be documented?

[1] https://help.libreoffice.org/6.2/en-US/text/swriter/01/05040700.html?System=WIN&DbPAR=WRITER#bm_id3154572

[2] https://documentation.libreoffice.org/assets/Uploads/Documentation/en/WG6.0/WG60-WriterGuideLO.pdf
Comment 9 Buovjaga 2018-09-02 12:51:17 UTC
(In reply to Dieter Praas from comment #7)
> (In reply to V Stuart Foote from comment #6)
> 
> > IMHO => WF
> 
> In this case I propose to add some additionals informations in the
> documentation and LO-Help so that people know about the section alternative.

Do you mean there should be a reference to the section alternative here https://help.libreoffice.org/6.2/en-US/text/swriter/01/04030000.html?&DbPAR=WRITER&System=UNIX or here https://help.libreoffice.org/6.2/en-US/text/swriter/guide/footnote_usage.html?DbPAR=WRITER#bm_id3145819 ?
Comment 10 Dieter 2018-09-02 13:55:33 UTC
(In reply to Buovjaga from comment #9)
> Do you mean there should be a reference to the section alternative here
> https://help.libreoffice.org/6.2/en-US/text/swriter/01/04030000.
> html?&DbPAR=WRITER&System=UNIX or here
> https://help.libreoffice.org/6.2/en-US/text/swriter/guide/footnote_usage.
> html?DbPAR=WRITER#bm_id3145819 ?

Yes, I think that would be very helpful, because if you want to know something about footnotes, you normally won't look within the section help.
Comment 11 Buovjaga 2018-09-02 14:04:57 UTC
Ok, I created bug 119647 for the help enhancement.

I will go ahead and close this. I agree with Stuart that the development effort for this would be too much, when we consider this is already working with sections.
Comment 12 adaw2 2019-10-09 22:14:40 UTC
Team,

The proposed solution is very clever. However, (as far as I can tell,) the section method does not work for a 2-(or more-)paged document--particularly where a paragraph on an earlier page rolls over onto the next page.

(One might object that the option is not necessary in such cases, since on each earlier page the text will reach the bottom of the page before rolling over. However, this is not the case, because paragraphs with multiple footnotes of substantial length will frequently leave a gap of several lines between the bottom of the text on the first page and the top of the footnotes on the first page.)

The only way to use the section method in such cases is to manually split the paragraph (and manually adjust the formatting of the second half of the paragraph to make it look like a continuation of the first half). This solution quickly becomes unwieldy in larger documents--especially given that edits in the earlier pages will change the paragraph locations.

Incidentally, the only work-around I have found so far is to manually enter hard returns after the last footnote on each page in order to move the footnotes up below the text. However, again, this is not a good solution since an edit in the early pages of the document frequently requires you to manually re-position all footnotes in the document.

The energy required to add the option might be great, but the energy required on the part of users to work around the missing option is also great.

Thank you for your reconsideration.
Comment 13 Buovjaga 2019-10-10 06:27:11 UTC
adaw2: please attach an example document that demonstrates the problematic scenario you describe
Comment 14 adaw2 2019-10-10 19:21:44 UTC
Created attachment 154909 [details]
Before adding sections
Comment 15 adaw2 2019-10-10 19:24:31 UTC
Created attachment 154910 [details]
After adding sections

Notice that sections had to be manually created on each page. Notice the extra space at the beginning of page 2 and the extra tab at the beginning of page 3, which would have to be manually corrected. (Note also that when the sections were originally applied, a bug prevented footnote 12 from displaying and a red triangle appeared at the right side. When I reopened the document the footnote appeared.)
Comment 16 adaw2 2019-10-10 19:27:45 UTC
Created attachment 154911 [details]
After editing a document with sections

When text is added in an early page. Notice that the gap has reappeared (between text and footnotes) on page 1. Notice the location of footnote 9 in the middle of the text at the top of p. 2. Notice the bug with footnote 16. (Additional bugs were present prior to saving, closing, and reopening.)
Comment 17 V Stuart Foote 2019-10-10 21:02:14 UTC
Created attachment 154913 [details]
The no section sample document, reworked into a single section with footnotes collected at end

(In reply to adaw2 from comment #15)
> Notice that sections had to be manually created on each page.

That is your problem--it needs to be in a single section, until you are ready to restart footnote numbering, e.g. at a chapter break.

Meaning to reformat, select your _entire_ text (it will include your footnotes) and paste into a new section. But it is better to work into a new document for clean formatting.

In either case the new section should be formatted prior to the insertion: Footnotes -> Collect at End of Section.

Attached your text & footnotes from attachment 154909 [details] "Before adding sections" where I have selected all and then pasted into a correctly formatted section. Section expands to multiple pages to hold the content--footnotes are correctly placed on each page where they occur.

Footnote 9 is modified to shift the text of footnote 10 completely to the next page--otherwise the footnote does start on page one where initially located, and finishes to start footnotes on following page.
Comment 18 adaw2 2019-10-15 01:29:46 UTC
Thank you for your suggestion. However, (1) I was not able to follow the suggestion and get the desired results, (2) the file containing the alleged solution was apparently manually modified (something about footnote 9, also not double-spaced anymore), and (3) the file containing the alleged solution did not actually solve the problem (see footnote 18 on the final page). I suspect the file only *appeared* correct on pages 1 and 2 by coincidence (due to the location of the footnotes, line breaks, etc.) Thank you for your continued assistance.
Comment 19 V Stuart Foote 2019-10-15 02:20:33 UTC
Created attachment 155008 [details]
original footnote 9 restored

Attached is the your sample text correctly copied and pasted into a single section with correct footnote handling.

Here, I have restored footnote 9 so that footnote 10 will start on page 1 (but footnote 10 can not be completed in the footnote section because there is insufficient room--so it then continues on the opposing page). I'd only modified the footnote to show the behavior of the page text shrinking as the footnote entries increas--the logic is that a footnote will start on the page that holds its anchor.

Inserting into a single section will extend with correct footnoting for as many pages as you have text.
Comment 20 adaw2 2019-10-18 21:02:47 UTC
Created attachment 155130 [details]
Pasted into a new doc, new section

Again, the proposed solution only *appears* (at first glance) to work. (1) When I create a new document, create a new section, collect the footnotes at the end, and paste the text into that new section, the result is large gaps between the text and the footnotes (see attached). (2) The second file containing the alleged solution did not have the exact same text and was not double spaced. As I noted before, I suspect the file only *appeared* to fix the problem by coincidence, due to the spacing, location of the footnotes, line breaks, etc. (3) The second file containing the alleged solution did not actually solve the problem (note the different gap sizes between the text and footnotes on both pages). The issue would become clearer if the text were allowed to roll over to the third page, as in my example and in the large gap in the first proposed solution. (4) The first file containing the alleged solution did not solve the problem (see footnote 18), and the procedure used in the second file was no different, meaning the problem still is not resolved--just masked.

Unless I am missing something, the section method is not an actual solution to the problem, except where footnote lengths and line breaks happen to coincidentally line up in such a way as to make the footnotes *appear* to be collected at the bottom of the text.
Comment 21 V Stuart Foote 2019-10-30 22:13:02 UTC
Created attachment 155413 [details]
text (double spaced) and reflinked footnotes into a single section

You are missing something... and, the attachment here has your latest text and referenced footnotes copied to a new document into a single section 'Collect footnotes at end of text', and paragraphs formatted with double line space.

Within a section with appropriate formatting it works as requested. The footnotes are collected on the page their reflink occurs in text, and can run over to the next page if not enough room to hold the footnote.

Back => WFM
Comment 22 adaw2 2019-11-01 16:56:05 UTC
The latest alleged solution is still a failure:
(1) The attachment did not resolve the problem. Note the gap between text and footnotes on the first page, compared to the lack of gap between text and footnotes on the second page. (The problem only appears to be *somewhat* addressed, by coincidence, due to the position and spacing of the footnotes; see #2.) 
(2) The attachment was formatted differently; notice the blank line between footnotes in my document which is not present in the alleged solution. Once you correct the footnote formatting in the alleged solution, the problem is exacerbated and the document looks like mine.

Again, the section method is not a real solution--it only appears to be in certain situations.
Comment 23 adaw2 2019-11-01 17:12:17 UTC
I thought of another way of making my point (from a different angle): Try to create a multiple-paged document using the section method in which the footnotes on the first page actually *need* to be moved up (due to a large gap between text and footnotes) and therefore *are* moved up.

All of the proposed solutions so far did not *need* to have the footnotes on the first page moved up (due to formatting errors). Thus, even if the section method had not been used, the footnotes in such cases would have *seemed* to be immediately below the text anyway due to the position of footnote links, etc. (The last page is a different story, obviously.)

If you are successful, your document will have multiple pages, and the bottom of the footnotes on the first page will be higher than the bottom margin of the page, due to the footnotes actually being moved *up*. I suspect you will not be able to create such a document, because the section method only moves the footnotes up on the last page.
Comment 24 V Stuart Foote 2019-11-01 17:27:44 UTC
In reply to adaw2 from comment #22)
> The latest alleged solution is still a failure:
> (1) The attachment did not resolve the problem. Note the gap between text
> and footnotes on the first page, compared to the lack of gap between text
> and footnotes on the second page.

That is exactly the correct formatting--the reflink for each footnote _must_ appear on the page where the footnote is added to the bottom of the page. The blank space _will_ expand or contract page to page depending on the size of the footnote for the reflink appearing on the page! Subsequent Paragraph content holding reflink(s) is free to move to the following page to allow the preceding footnote to grow.

 (The problem only appears to be *somewhat*
> addressed, by coincidence, due to the position and spacing of the footnotes;
> see #2.) 

No coincidence.

> (2) The attachment was formatted differently; notice the blank line between
> footnotes in my document which is not present in the alleged solution. Once
> you correct the footnote formatting in the alleged solution, the problem is
> exacerbated and the document looks like mine.
> 

No, attachment 155413 [details] was prepared is with 'Default' page and paragraph style formatting with just paragraph line spacing set to double, as that seemed to be the requested format.

> Again, the section method is not a real solution--it only appears to be in
> certain situations.

It is not an appearance of solution--it is the only solution that is viable (i.e. does not require major refactoring) page layout.

@adaw2 (not even the OP) has been unable to prepare legitimate, reproducible example(s) screenshot(s) showing what formatting they seek, and what exactly is perceived as lacking by using an appropriately formatted section to hold paragraph and reflink'd footnotes.

My UX input remains as in comment 6 as this WFM, and should otherwise be a WF.

=> Unconfirmed and back for UX-advise.
Comment 25 adaw2 2019-11-07 20:59:06 UTC
Created attachment 155618 [details]
6 - mocked-up solution

(In reply to V Stuart Foote from comment #24)
> That is exactly the correct formatting

It sounds like you are not understanding the request. Let me try to explain. In MS Word (and other WP's) you have the option of having the footnotes move *up*, *directly*--*immediately* below the text on each page--no matter how much of a gap would normally be present between text and footnotes. In other words, on pages where there would normally be a 3" gap between the bottom of the text and the top of the footnotes, this option would result in no gap. Instead, that same 3" gap would appear between the bottom of the footnotes and the top of the bottom margin, such that the footnotes section is simply moved *up* by 3".

> No, attachment 155413 [details] was prepared is with 'Default' page and
> paragraph style formatting with just paragraph line spacing set to double,
> as that seemed to be the requested format.

No, the requested format is found in attachment 154909 [details], except that the footnotes should be moved *up*. (None of the text on a given page--nor any of the footnotes--should be moved to a different page--just the location of the footnotes on each page should be higher vertically than they are.)

> @adaw2 . . . has been unable to prepare legitimate, reproducible example(s) screenshot(s) showing what formatting they seek

See attached. (Of course, this is just a mock-up, created by crudely hitting the enter key a whole bunch of times at the bottom of the footnotes on each page, and then using a section for the last page, since the feature does not currently exist in LibreOffice, but it should be close enough for you to get the idea.)

Thank you for your help.
Comment 26 adaw2 2019-11-07 21:33:44 UTC
(Anecdotally, to give you an idea of the importance of this feature, this morning I was talking to a PhD student who just purchased Word Perfect, and plans to also purchase a separate laptop to run WP on, just so he can have this feature available for his doctoral writing. The "below the text" footnote formatting is required by his Doctoral program.)
Comment 27 Heiko Tietze 2019-11-08 09:23:56 UTC
(In reply to adaw2 from comment #26)
> The "below the text" footnote formatting is required by his Doctoral program.

References to those standards would be very helpful for us.


Regina, what do you think about footnotes aligned to the bottom of the text?
Comment 28 Regina Henschel 2019-11-08 13:56:30 UTC
If you start the footnote area directly after the last line of text, you get the large gap after the footnotes. From a typographical point of view, it would be against the principle of a "footnote".

The gap is caused by the rule, that every footnote has to start at the same page as the footnote anchor. If -as in the example document- Orphan/Widow control is enabled, it can happen, that the footnote text together with (here 2) lines, does not fit on the page and therefore 2 lines and its footnotes go to the next page. Another reason is the amount of footnotes per line.

From a typographical point of view, I would use endnotes per chapter, technically done by making each chapter a section.
From content it is very questionable, to use a footnote that is longer as one line. If the content is so large, that it needs several lines, then it belongs to the text.

For the example document disable Widow control to get a more compact text. That is not nice typography, but double line spacing is neither.

I would not follow the idea to put footnotes directly after the text.

> The "below the text" footnote formatting is required by his Doctoral program.

I too would like to see such requirement. I guess, that the requirement only means to use footnotes and not endnotes.
Comment 29 adaw2 2019-11-08 17:33:36 UTC
> From a typographical point of view, I would use endnotes

This is not an option given our school style guides

> From content it is very questionable, to use a footnote that is longer as one line.
> If the content is so large, that it needs several lines, then it belongs to the text.

Not in doctoral writing. Some content footnotes in dissertations can run for over a page in length!

> disable Widow control

Widow control is required by the school style guides

> I would not follow the idea to put footnotes directly after the text.

Our school style guides require footnotes directly after the text--this is not an option, idea, or suggestion for us, but a requirement.

> I guess, that the requirement only means to use footnotes and not endnotes.

I assure you the requirement is as I have described, and we are interpreting our school style guides correctly, as (1) we have been penalized on our prior submissions for failing to conform to this requirement (and merely using footnotes at the bottom of the page with a gap between text and footnotes), (2) we have spoken with the people who wrote the style guides and confirmed the requirement, and (3) the option is available in MS Word, WordPerfect, etc. which shows that such a requirement is not unique to our school style guides.
Comment 30 adaw2 2019-11-08 17:47:23 UTC
Created attachment 155641 [details]
style guide 1

Here is a picture of the relevant excerpts from one of the school style guides, for those who would like visual confirmation. (Note, however, that the best interpreters of a document are its authors and the authors of this document have clearly explained the requirement to me.)
Comment 31 Heiko Tietze 2019-11-08 19:22:46 UTC
Fact is that MSO provides the option to place footnotes below the text and we have a roundtrip issue. Footnotes with this formatting are placed at the page bottom when saved as ODF.
Comment 32 Regina Henschel 2019-11-08 21:56:07 UTC
For ODF it is no problem, see link. It has for the position already the value "text". Only LibreOffice has not implemented it. So only a developer is needed who actually does the work.
Comment 33 Heiko Tietze 2019-11-11 10:51:56 UTC
Footnote position can be chosen in the F/E settings dialog with End of page and End of document. Either we add another radio button or make this a dropdown.