Download it now!
Bug 92223 - FILESAVE: Style based Shapes Line Color Changed on Roundtrip
Summary: FILESAVE: Style based Shapes Line Color Changed on Roundtrip
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pptx
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2015-06-21 08:11 UTC by Luke
Modified: 2018-10-22 16:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2015-06-21 08:11:12 UTC
Steps to reproduce:
1. Draw a shape in PowerPoint
2. Set the shape style to a outlined style (not filled, not manual color) 
3. Save ( ex: attachment 116696 [details] )
4. Open in Impress
5. Save ( ex:  attachment 116697 [details])
6. Close and reopen in Impress

Note the line color will change on the round tripped file. In step 2, you must not manually set a line color.

This maybe to related to the fact the file is corrupted, Bug 92221.
Comment 1 Buovjaga 2015-06-21 15:59:33 UTC
Reproduced.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)
Comment 2 Luke 2015-06-21 18:09:46 UTC
Andras,
In Bug 90877, moggi fixed very similar issues with OOXML chart color changing on roundtrip. Might be some clues there.
Comment 3 QA Administrators 2017-01-03 19:39:22 UTC Comment hidden (obsolete)
Comment 4 Luke 2017-01-04 02:15:01 UTC
line color still changing in Version: 5.4.0.0.alpha0+ (x64)
Build ID: bf80bbb7b75febc2769d6b64e6981224982f8fe2
Comment 5 QA Administrators 2018-10-22 02:48:06 UTC Comment hidden (obsolete)
Comment 6 Luke 2018-10-22 16:51:16 UTC
Works for me in Version: 6.2.0.0.alpha0+ (x64)
Build ID: 5e8cd8683d345b75297994b3f7aab851835eb124

Possibility some of the improvements from Bug 84205 helped with this one too.
Comment 7 Luke 2018-10-22 16:53:23 UTC
https://cgit.freedesktop.org/libreoffice/core/commit/?id=c344d74a6961ec39685d718fbb7c29dd186ca0a4

Preserved the color attribute in themes.