Bug 94561 - EDITING: Comments double when copying Sheets
Summary: EDITING: Comments double when copying Sheets
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Dennis Francis
URL:
Whiteboard: target:5.2.0 target:5.1.2 target:6.2....
Keywords:
: 57954 70479 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-09-28 07:14 UTC by Marvin Bender
Modified: 2018-06-27 08:02 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
doubled comments (13.58 KB, image/png)
2015-09-28 07:14 UTC, Marvin Bender
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marvin Bender 2015-09-28 07:14:44 UTC
Created attachment 119082 [details]
doubled comments

- creating new table
- fill Cell "A1" with i.e. "Text1"
- autofill 10 lines down (Text1, Text2, Text3 ...)
- insert comment to one cell, i.e. A5 ("Text5")
- show comment
- insert comment to another cell, i.e. A7, and also show comment
- hide line 7 (comment remains visible)
- copy whole table with context menu
- now hide line 5 in new created table
- all comments double (see atachement)

This happens under windows, too, in various forms (one time all comments pointed to the upper left corner of the table).

Sorry for possibly not correct english - I only have the german version of the software.
Comment 1 raal 2015-09-29 10:13:08 UTC
I can confirm with 5.0.1.2, win7 and Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)
Comment 2 Dennis Francis 2016-02-12 15:10:21 UTC
The issue is still present in master. But I think this a ui/view issue as the problem seems to go away when the document is saved and reopened. The copied sheet will now not have any duplicates.

I will try to fix this. Thanks.
Comment 3 Dennis Francis 2016-02-12 21:17:29 UTC
Submitted a patch for review at https://gerrit.libreoffice.org/#/c/22331/
Comment 4 Commit Notification 2016-03-08 18:08:13 UTC
Dennis Francis committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7c0f6b9d0fb8d7d9e54865ccf1047bb8f8148101

tdf#94561 : Create notes drawing objects only once on sheet copy

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2016-03-14 18:33:41 UTC
Dennis Francis committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4c9b861e43ea6efc193107a25def6a748994ad5b&h=libreoffice-5-1

tdf#94561 : Create notes drawing objects only once on sheet copy

It will be available in 5.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Eike Rathke 2016-03-14 18:40:09 UTC
@Dennis:
Side note: set bugs to resolved fixed once the change is in master, independent of whether we'll cherry-pick a change to other branches or not.
Comment 7 Timur 2016-03-14 18:41:26 UTC
Related or duplicate to Bug 57954?
Comment 8 Kevin Suo 2016-03-23 00:00:35 UTC
*** Bug 57954 has been marked as a duplicate of this bug. ***
Comment 9 Kevin Suo 2016-03-23 00:05:17 UTC
*** Bug 70479 has been marked as a duplicate of this bug. ***
Comment 10 Timur 2016-04-18 11:37:35 UTC
Please submit a patch for 5.0.6.2.
Comment 11 Commit Notification 2018-06-26 13:08:11 UTC
Dennis Francis committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eebd2c72ce2d6003975de6b5bfe14b204b382a6e

tdf#112452 : Refine the fix for tdf#94561

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2018-06-27 08:02:46 UTC
Dennis Francis committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b491bb4b1e2eb6745ced3e958550ea8526cd2f2a&h=libreoffice-6-1

tdf#112452 : Refine the fix for tdf#94561

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.