Bug 96942 - Dialog’s buttons localized to operating system language and do not match LibreOffice’s UI language
Summary: Dialog’s buttons localized to operating system language and do not match Libr...
Status: RESOLVED DUPLICATE of bug 94090
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.6.3 release
Hardware: x86 (IA32) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 109038 113094 (view as bug list)
Depends on:
Blocks: Dialog User-Locale
  Show dependency treegraph
 
Reported: 2016-01-07 10:15 UTC by erik
Modified: 2018-10-24 15:13 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Examples of unwanted language mismatches in dialog boxes (66.67 KB, image/jpeg)
2016-01-07 10:15 UTC, erik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description erik 2016-01-07 10:15:49 UTC
Created attachment 121771 [details]
Examples of unwanted language mismatches in dialog boxes

I live in Finland, speak Swedish, but install an use ALL software in English.
I have NOTHING installed in Finnish!

Still some dialog boxes in Libre Office show buttons with Finnish text - WHY?? This language mismatch is very annoying. 
Apparently as Libre Office upon installation asks where I am, it assumes I use Finnish in my computer.

My location has nothing to do with language preferences.
Please remove all associations between location and language in Your installation script.
Comment 1 Buovjaga 2016-01-10 19:28:35 UTC
If you uninstall 4.4 and then install 5.0.x, do you get the same problem?

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 2 erik 2016-01-11 09:59:06 UTC
Hello,

Installed the version 5 over version 4.4 (without uninstalling 4.4 - why would that be necessary?).
Downloaded the v.5 (english version) and started the update.
The whole installation procedure was still in finnish for some peculiar reason (I downloaded the english version), but once v.5 was installed I didn't get mixed-language dialogs any longer.

The annoying ongoing feature with mixed-language dialogs is fixed in v. 5 - Thank You.

However, the language in the installation procedure is still dictated by localisation rather than the language of the downloaded update.
That final fix of the installation script would be greatly appreciated.
Comment 3 Aron Budea 2016-05-07 21:30:04 UTC
Erik, there's only one download package containing all the languages. The installer then uses the language based on this setting: Control Panel -> Region and Language -> Formats -> Format. There's no straightforward setting for getting the preferred UI language across the system. There's a Display Language in tab Keyboards and Languages, but it's for Windows itself, and I don't know if there's an easy way to use that setting in the installer.

I hope this at least gives you a better understanding of the situation. For now that's all I can offer, don't get your hopes up, there are tons of higher priority bug reports out there.
Comment 4 Adolfo Jayme 2016-06-03 21:45:48 UTC
*** Bug 100208 has been marked as a duplicate of this bug. ***
Comment 5 erik 2016-06-04 07:08:22 UTC
Comment on attachment 121771 [details]
Examples of unwanted language mismatches in dialog boxes

My computer and myself are in Finland, my own mother tongue i swedish, everything on my computer (OS and all programs) are installed in english. I do use finnish as my locale, to get the correct keyboard, metric system and currency, but the location has NOTHING to do with language preference.
If some of the software tries to guess the language from somewhere - use the language of the OS as a language reference, NOT the location of the computer.

Seems illogic to select England as my locale to get the correct díalog boxes, if that is how You intended for the software to work.
Comment 6 Timur 2016-06-06 09:24:17 UTC
My Bug 100208 was resolved as a duplicate of this one, but I think those are both duplicates of Bug 94090. Please check.
Comment 7 Adolfo Jayme 2017-07-10 08:32:06 UTC
*** Bug 109038 has been marked as a duplicate of this bug. ***
Comment 8 Adolfo Jayme 2017-10-14 22:48:40 UTC
*** Bug 113094 has been marked as a duplicate of this bug. ***
Comment 9 QA Administrators 2018-10-23 02:49:23 UTC Comment hidden (obsolete)
Comment 10 Timur 2018-10-24 15:13:37 UTC
I suggested this bug be a duplicate of Bug 94090 but there was no comment after. 
I'll mark so. 
If anyone objects or has an explanation why these two are different, please write.

*** This bug has been marked as a duplicate of bug 94090 ***