Bug Hunting Session
Bug 115254 - [NEWHELP] Some branch bookmarks are not working
Summary: [NEWHELP] Some branch bookmarks are not working
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0.2 target:6.2.0 target:6.1.1
Keywords:
: UnspecificHelp 118587 118590 118968 (view as bug list)
Depends on:
Blocks: New-Help
  Show dependency treegraph
 
Reported: 2018-01-27 12:20 UTC by Olivier Hallot
Modified: 2018-10-02 09:50 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2018-01-27 12:20:15 UTC
Description:
On opening some new help pages from LibreOffice dialogs, the default page opens even if a bookmark "branch" is sent by the software.

Steps to Reproduce:
1. Open a dialog
2. select a widget
3. hit F1

Actual Results:  
Sometimes, the help page is the default page (writer entry page) and sometimes the help page is correct.

Expected Results:
Always open the right help page


Reproducible: Always


User Profile Reset: No



Additional Info:
The issue is in a small piece of Javascript, inside index2.html at 

https://opengrok.libreoffice.org/xref/help/help3xsl/index2.html
+++++++++++++++++++++++++
 var bookmark = rest.slice(rest.indexOf('/')+1, rest.indexOf('?'));
    var file = map[bookmark];
    // rebuild URL
    if (file === undefined){
    file = defaultFile;
    }
+++++++++++++++++++++++++

map[bookmark] is a map that transform the URL sent by LibreOffice to the right HTML page. It is a simple map generated by get_url.xsl

https://opengrok.libreoffice.org/xref/help/help3xsl/get_url.xsl

If the bookmark "branch" does not exist in the map, a default page in open.

Th issue occurs because some dialogs have only one bookmark branch for the main help page and lack the branch for the dialog widgets. For example, 

<bookmark xml-lang="en-US" branch="hid/modules/swriter/ui/watermarkdialog/WatermarkDialog" id="bm_id3155897" localize="false"/>

will open the page /text/swriter/01/watermark.html (source is /text/scalc/01/watermark.xhp)

but 

<bookmark xml-lang="en-US" branch="hid/modules/swriter/ui/watermarkdialog/TextInput" id="bm_id3155897" localize="false"/>

will open the default page because there is no entry for the TextInput widget of the dialog in the map.

To fix that, the hard solution is to insert the bookmark branch for every dialog widget in every help page associated with a dialog. It's the right thing to do, but can be quite hard.

The second solution is to improve the map or javascript and analyse the bookmark to see if there is another bookmark for the same help page. In the example above, the missing bookmark for TextInput should open the page for WatermarkDialog.

So, when the map return undefined", check again with pieces of the URL. 



User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 2 Olivier Hallot 2018-03-14 17:55:23 UTC
Fix in comment #2 is not related to this bug. Reopen
Comment 3 Olivier Hallot 2018-07-06 17:25:56 UTC
*** Bug 118590 has been marked as a duplicate of this bug. ***
Comment 4 Xisco Faulí 2018-07-06 17:35:07 UTC
*** Bug 118587 has been marked as a duplicate of this bug. ***
Comment 5 Xisco Faulí 2018-07-12 14:54:01 UTC
@Olivier, I think this issue should get fixed before the final release of 6.1. Increasing severity...
If you disagree, please change it accordingly...
Comment 6 Commit Notification 2018-07-15 20:22:08 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=a9a4b8c89a11d6c2955c52b9bda096b943df0476&h=libreoffice-6-1

tdf#115254 Some branch bookmarks are not working 3
Comment 7 Commit Notification 2018-07-15 20:22:17 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=d3b6ce0424e1aa359b297c63bbd16217a2e5b747

tdf#115254 Some branch bookmarks are not working 3
Comment 8 Commit Notification 2018-07-15 22:39:42 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=6cd28b0578beb4771c00b38f265870381045454e

tdf#115254 Some branch bookmarks are not working 4
Comment 9 Commit Notification 2018-07-18 14:41:08 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=d1e2ccbf4ee1d0a1ae047c4fa52bd579e783b3d9&h=libreoffice-6-1

tdf#115254 Some branch bookmarks are not working 4
Comment 10 Commit Notification 2018-07-20 11:22:25 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=9cd1d2832cad78410c85b9fb7b6ccba9473f3106

tdf#115254 Some branch bookmarks are not working 5
Comment 11 Commit Notification 2018-07-20 11:23:48 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=faeb714c09f7420d6ed0c55097de2467e211a13d

tdf#115254 Some branch bookmarks are not working 6
Comment 12 Commit Notification 2018-07-26 12:41:10 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=3fb1fda6051fafe343fde842a344192dbc5abe99

tdf#115254 Some branch bookmarks are not working 7
Comment 13 Commit Notification 2018-07-26 12:42:38 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=96108c1112300ab09d5e0632fe66cdf996d4443f

tdf#115254 Some branch bookmarks are not working 8
Comment 14 Commit Notification 2018-07-26 18:27:38 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=e055db0a26c7fab3d624fef7e726e61cb1e8f032

tdf#115254 Some branch bookmarks are not working 9
Comment 15 Commit Notification 2018-07-26 19:29:15 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=8426408b9647babdcc53ca4eef9762e50b3cd407

tdf#115254 Some branch bookmarks are'nt working 10
Comment 16 Commit Notification 2018-07-26 20:19:25 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=5b63a42edbba2999ccb50f5f58268050e25e22a9

tdf#115254 Some branch bookmarks are'nt working 11
Comment 17 Olivier Hallot 2018-07-27 12:38:01 UTC
*** Bug 118968 has been marked as a duplicate of this bug. ***
Comment 18 Olivier Hallot 2018-07-28 11:49:35 UTC
*** Bug 58168 has been marked as a duplicate of this bug. ***
Comment 19 Commit Notification 2018-07-31 11:00:28 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=83fdeadc83d3bfee7ef90bdace7cf0db8487190d

tdf#115254 Some branch bookmarks are'nt working 12
Comment 20 Commit Notification 2018-08-01 09:41:08 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=6eec4dae4a5e3a7edc426e01a86b755123e03f4c

tdf#115254 Some branch bookmarks are'nt working 13
Comment 21 Commit Notification 2018-08-01 09:41:15 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=a20196a08afd082a74e89e217cc5ca18a8dbe0be

tdf#115254 Some branch bookmarks are'nt working 14
Comment 22 Commit Notification 2018-08-01 11:53:42 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=814d9dc38a99f64b05d32e402295a3db8f91eb6b

tdf#115254 Some branch bookmarks are'nt working 15
Comment 23 Commit Notification 2018-08-14 11:53:09 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=6ae21238c8b086e464d84cfb32c40cc3c3069acb&h=libreoffice-6-1

tdf#115254 Some branch bookmarks are'nt working 13
Comment 24 Commit Notification 2018-08-14 11:53:17 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=a806592d4f2d4d56bb8e700c36f02a26a19f4fec&h=libreoffice-6-1

tdf#115254 Some branch bookmarks are not working 5
Comment 25 Commit Notification 2018-08-14 11:53:24 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=826b575dac648932b7c9c684a59c811d9e32362a&h=libreoffice-6-1

tdf#115254 Some branch bookmarks are not working 6
Comment 26 Commit Notification 2018-08-14 11:53:31 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=ef755086c52950deb9bb3551bbe2847f45c3d4aa&h=libreoffice-6-1

tdf#115254 Some branch bookmarks are not working 7
Comment 27 Commit Notification 2018-08-14 11:53:39 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=5c4e10b45521e96f46764839d9e9644bc48026ac&h=libreoffice-6-1

tdf#115254 Some branch bookmarks are not working 8
Comment 28 Commit Notification 2018-08-14 11:53:46 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=8fd523672739359ff08eddd330de5a62841a1532&h=libreoffice-6-1

tdf#115254 Some branch bookmarks are not working 9
Comment 29 Commit Notification 2018-08-14 11:53:53 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=f8b2927dfed4e72e547a0fae0f6026ba1e0aa8b7&h=libreoffice-6-1

tdf#115254 Some branch bookmarks are'nt working 11
Comment 30 Commit Notification 2018-08-14 11:54:00 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=52c1c523ac7988454a97dee5f05ad5a5aeba484e&h=libreoffice-6-1

tdf#115254 Some branch bookmarks are'nt working 12
Comment 31 Commit Notification 2018-08-14 11:54:07 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=31ee97c484ecddd8c41cab9833821d9cdca4e4b8&h=libreoffice-6-1

tdf#115254 Some branch bookmarks are'nt working 14
Comment 32 Commit Notification 2018-08-14 11:54:14 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=cb310d984ec6bebb2ace8f8646d263d2691810ad&h=libreoffice-6-1

tdf#115254 Some branch bookmarks are'nt working 15
Comment 33 Commit Notification 2018-08-14 12:11:27 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=9979cc60ca9b38dff35bcc1bd8a2bf5dd4a2c121&h=libreoffice-6-1

tdf#115254 Some branch bookmarks are'nt working 10
Comment 34 Commit Notification 2018-08-17 19:34:56 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=adff949d41483b1db4aec6eda371bd68e6f77dce

tdf#115254 Some branch bookmarks are'nt working 16
Comment 35 Commit Notification 2018-08-22 07:36:45 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=8ea8e50ef73b44f014c271b20fd583a688974919&h=libreoffice-6-1

tdf#115254 Some branch bookmarks are'nt working 16
Comment 36 Commit Notification 2018-08-22 07:36:52 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=f29c7f0ff6d4aae2a89b9e80ae1def07401ecd1d&h=libreoffice-6-1

tdf#115254 Some branch bookmarks are'nt working 17
Comment 37 Commit Notification 2018-08-22 07:36:59 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=0a77fc09a8060c18d52eaaf6d8233117fbdb3414&h=libreoffice-6-1

tdf#115254 Some branch bookmarks are'nt working 18
Comment 38 Commit Notification 2018-08-23 19:13:09 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=89e50da59f9f1de76f7de4d22ac22b2772894a74

tdf#115254 Some branch bookmarks are'nt working 17
Comment 39 Commit Notification 2018-08-23 19:15:38 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=e8d88bfcedec033cf53f7c7a6a870b52112a7745

tdf#115254 Some branch bookmarks are'nt working 18
Comment 40 Commit Notification 2018-08-23 22:14:47 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=87b5b6d3532c532d297f1e9f67b018c34aa89c82

tdf#115254 Some branch bookmarks are'nt working 19
Comment 41 Commit Notification 2018-09-12 02:47:07 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=11d6a45b5a8d269d451988c40a9a16dd3728f57c

tdf#115254 Some branch bookmarks are'nt working 20
Comment 42 Commit Notification 2018-09-12 02:47:16 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=8c40a3958542dca1ded6df309a2ededa31ed9194

tdf#115254 Some branch bookmarks are'nt working 21
Comment 43 Commit Notification 2018-09-12 02:47:24 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=abdb4b9745c43da805b11e19981b1c00c181d82b

tdf#115254 Some branch bookmarks are'nt working 22
Comment 44 Commit Notification 2018-09-12 02:48:49 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=0cfa25cb0494fee382aaa33f8dd0354f8a35b881

tdf#115254 Some branch bookmarks are'nt working 23
Comment 45 Commit Notification 2018-09-14 23:21:51 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=af87b7e316a3db00c565fa31b95f19f36697b6be

tdf#115254 Some branch bookmarks are'nt working 24
Comment 46 Commit Notification 2018-09-14 23:23:22 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=cc03a8f712b575625ac85da3fa84f3d3d54d1035

tdf#115254 Some branch bookmarks are'nt working 25
Comment 47 Commit Notification 2018-09-14 23:23:30 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=1500827537cb6050b9a08473710e8574f30cfe14

tdf#115254 Some branch bookmarks are'nt working 26
Comment 48 Commit Notification 2018-09-14 23:23:37 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=4ad451d2993357935fab7bc04cbcf123e7f0c0ec

tdf#115254 Some branch bookmarks are'nt working 27
Comment 49 Commit Notification 2018-09-14 23:23:44 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=4890637bf3ce3cebead1b1bb5395ada90cb2673a

tdf#115254 Some branch bookmarks are'nt working 28
Comment 50 Commit Notification 2018-09-14 23:25:20 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=847b17c70c53740bba9980fa8d72b71554d5925d

tdf#115254 Some branch bookmarks are'nt working 29
Comment 51 Commit Notification 2018-09-14 23:25:29 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=fff3c5664e650c9c7aef1ab60da86874cab9428a

tdf#115254 Some branch bookmarks are'nt working 30
Comment 52 Commit Notification 2018-09-17 20:49:48 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=b51008a35b852dab0ba0d50903b174824891b420

tdf#115254 Some branch bookmarks are'nt working 31
Comment 53 Commit Notification 2018-10-02 09:50:12 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=84a86433f6be3d6fab810891382d62599d82bdf8

tdf#115254 Some branch bookmarks are'nt working 32