Download it now!
Bug 124391 - Doubled global menu in 6.2.2 with GTK VCL
Summary: Doubled global menu in 6.2.2 with GTK VCL
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard: target:6.4.0 target:6.3.3 target:6.2.8
Keywords: bibisected, regression
: 122287 123484 124192 128142 (view as bug list)
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2019-03-28 11:17 UTC by Konstantin
Modified: 2020-01-10 17:15 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Double menus in GTK3 VCL (92.95 KB, image/png)
2019-03-28 11:19 UTC, Konstantin
Details
Double menus in GTK3 in English (we see, than all menu entries are doubled) (113.72 KB, image/png)
2019-03-28 11:21 UTC, Konstantin
Details
Screenshot showing duplicate menu (61.10 KB, image/png)
2019-05-03 22:53 UTC, Tor Slettnes
Details
doubled menus in Ubuntu 18.04 (Unity) (34.44 KB, image/png)
2019-09-18 10:59 UTC, john
Details
Double menus in LO ver. 6.3.3.2 (17.52 KB, image/png)
2019-11-11 15:26 UTC, the_cleaner
Details
Screenshot ot Help screen (110.12 KB, application/x-7z-compressed)
2019-11-11 19:24 UTC, the_cleaner
Details
Multiple instances of the menubar (49.68 KB, image/png)
2019-11-19 18:42 UTC, Bernard Decock
Details
Screenshots - 6.4.0.0-alpha - Ubuntu 19.10 - Unity DE (2.24 MB, application/zip)
2019-11-20 16:50 UTC, Marcus Tomlinson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin 2019-03-28 11:17:28 UTC
Description:
We have double menus in GTK3 VCL, if it is used with Unity-style globalmenu - vala-panel-appmenu, or with GTK3 Backend on KDE (via https://github.com/KDE/plasma-workspace/tree/master/gmenu-dbusmenu-proxy)

Package version: 6.2.2-2
Distribution: ArchLinux.

Steps to Reproduce:
1. Install and configure vala-panel-appmenu (https://gitlab.com/vala-panel-project/vala-panel-appmenu)
2. Open any LibreOffice app
3. Bug happens))))

Actual Results:
We see double menus, as in screenshots in bug on vala-panel-appmenu GitLab (https://gitlab.com/vala-panel-project/vala-panel-appmenu/issues/286)

Expected Results:
We should see only single menu, no double menus.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Related to:

1. https://bugs.documentfoundation.org/show_bug.cgi?id=123416 - similar (now seems fixed) bug for KDE on 6.2.0 and Qt VCL

2. https://bugs.documentfoundation.org/show_bug.cgi?id=122619 - this bug calls to remove menu export in GTK3 at all, because it is rarely needed. I am strongly against this decision.

3. https://gitlab.com/vala-panel-project/vala-panel-appmenu/issues/286 - Issue on vala-panel-appmenu end, confirmed by me and by some of my users.
Comment 1 Konstantin 2019-03-28 11:19:02 UTC
Created attachment 150350 [details]
Double menus in GTK3 VCL
Comment 2 Konstantin 2019-03-28 11:20:23 UTC
About attachment - there is just no place for double menu in panel, vala-panel-appmenu made next menu entries scrollable.
Comment 3 Konstantin 2019-03-28 11:21:42 UTC
Created attachment 150351 [details]
Double menus in GTK3 in English (we see, than all menu entries are doubled)
Comment 4 Xisco Faulí 2019-03-29 00:13:29 UTC
@Caolán, I thought you might be interested in this issue...
Comment 5 Tor Slettnes 2019-05-03 22:53:10 UTC
Created attachment 151169 [details]
Screenshot showing duplicate menu

I see the same in Debian "sid", starting with LibreOffice 6.1.  It only appears when using the global "appmenu" plugin in my Window manager (either XFCE4 or MATE), not with Gnome 3 (since the latter does not have a "global app menu" feature anymore).
Comment 6 Xisco Faulí 2019-06-10 15:41:16 UTC
(In reply to Tor Slettnes from comment #5)
> Created attachment 151169 [details]
> Screenshot showing duplicate menu
> 
> I see the same in Debian "sid", starting with LibreOffice 6.1.  It only
> appears when using the global "appmenu" plugin in my Window manager (either
> XFCE4 or MATE), not with Gnome 3 (since the latter does not have a "global
> app menu" feature anymore).

Confirmed by Tor.
Moving to NEW
Comment 7 OfficeUser 2019-07-27 09:29:57 UTC
*** Bug 124192 has been marked as a duplicate of this bug. ***
Comment 8 OfficeUser 2019-07-27 09:31:56 UTC
Same problem for me with 6.2.5.2.

Screenshot:
https://bug-attachments.documentfoundation.org/attachment.cgi?id=152974
Comment 9 OfficeUser 2019-07-27 09:34:36 UTC
Set keyword regression because according to the following screenshot from Bug 124192 the bug did not exist in build 6.1.2.
https://bug-attachments.documentfoundation.org/attachment.cgi?id=150089
Comment 10 fergusong2 2019-08-13 11:11:43 UTC
Same issue with me. Global menu duplicated across top for Writer, Calc, Impress.  Running Ubuntu 18.04.03, Libreoffice 6.3.0.4, build ID:Libreoffice-6.3.0.4-snap1   
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Comment 11 Caolán McNamara 2019-08-13 12:14:55 UTC
I imagine the GMenuModel is getting picked up twice, once from the native gtk menubar and once from the explicit dbus export.
Comment 12 OfficeUser 2019-08-15 21:44:48 UTC
Works for me with:

Version: 6.2.6.2
Build-ID: 684e730861356e74889dfe6dbddd3562aae2e6ad
CPU-Threads: 8; BS: Linux 4.4; UI-Render: Standard; VCL: gtk2; 
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded


I don't know if there has been a fix applied to build 6.2.6.2 or if it works for me now because I have installed this build along with ALL integration packages.

Status set to: RESOLVED WORKSFORME
Comment 13 OfficeUser 2019-08-20 09:29:18 UTC
REOPENED because issue appears again. I don't know why.
Comment 14 Konstantin 2019-08-20 09:38:28 UTC
Maybe because Gtk2 VCL does not do menu exporting?
Comment 15 qmc 2019-08-23 15:10:57 UTC
I solved the problem by removing libreoffice-gtk and installing libreoffice-kde. I'm using LibreOffice 6.3 and KDE Neon 5.16.4.
Comment 16 Jan 2019-08-23 15:46:01 UTC
Setting the environment variable SAL_USE_VCLPLUGIN=gen also disables the GTK menu and fixed the issue for me without uninstalling libreoffice-gtk.

Using LibreOffice 6.2.6.2 on Ubuntu 16.04.

The menu is ugly now, but not duplicated.
Comment 17 Konstantin 2019-08-23 16:37:29 UTC
Yes, changing VCL fixes an issue, because Gen is not GTK VCL)
Comment 18 darpandas47@gmail.com 2019-09-02 04:18:49 UTC
(In reply to OfficeUser from comment #13)
> REOPENED because issue appears again. I don't know why.

The same problem persists in LibreOffice 6.3 as well
Comment 19 Archisman Panigrahi 2019-09-13 19:35:42 UTC
The bug is still there in Libreoffice Build ID: 1:6.3.1~rc2-0ubuntu0.18.04.1~lo1, Running in KDE Neon 5.16.4.
Comment 20 john 2019-09-18 10:59:08 UTC
Created attachment 154256 [details]
doubled menus in Ubuntu 18.04 (Unity)

just to show that the same problem also exists with Unity in Ubuntu 18.04. The second copy doesn't fit, so a 'v' drop down gives the rest of them.
Comment 21 john 2019-09-18 11:00:51 UTC
I confirm this bug is present in version 6.2.6.2 as installed from the Ubuntu LibreOffice 6.2.x PPA.
https://launchpad.net/~libreoffice/+archive/ubuntu/libreoffice-6-2
Comment 23 Commit Notification 2019-10-08 14:26:44 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1c68ab312c5473ce642f75fc35a1edd6be187489

tdf#124391 Fix doubled menu in global menu

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2019-10-09 03:10:33 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/eccf0193885d1e46a207966eb52a408dc60e8109

tdf#124391 Fix doubled menu in global menu

It will be available in 6.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2019-10-09 03:10:46 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/commit/fd95a92d600b751ad6a23f35db446bf063cb722b

tdf#124391 Fix doubled menu in global menu

It will be available in 6.2.9.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 Mike Kaganski 2019-10-09 10:24:10 UTC
*** Bug 123484 has been marked as a duplicate of this bug. ***
Comment 27 Samuel Mehrbrodt (CIB) 2019-10-09 10:26:25 UTC
*** Bug 122287 has been marked as a duplicate of this bug. ***
Comment 28 Commit Notification 2019-10-09 10:28:55 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-8":

https://git.libreoffice.org/core/commit/46a575a64851512584abcddb0d30b907865251ce

tdf#124391 Fix doubled menu in global menu

It will be available in 6.2.8.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 29 Xisco Faulí 2019-10-14 16:30:25 UTC
*** Bug 128142 has been marked as a duplicate of this bug. ***
Comment 30 Xisco Faulí 2019-11-05 11:43:03 UTC
*** Bug 128491 has been marked as a duplicate of this bug. ***
Comment 31 the_cleaner 2019-11-11 15:20:41 UTC
Problem still appears on my system in following LO-components:
- LO manager screen 
- LO Base
- LO Math
All other components are OK
I use LO version 6.3.3.2.0, Linux kernel 5.3.10
Comment 32 the_cleaner 2019-11-11 15:26:14 UTC
Created attachment 155708 [details]
Double menus in LO ver. 6.3.3.2
Comment 33 Xisco Faulí 2019-11-11 15:28:36 UTC
(In reply to the_cleaner from comment #32)
> Created attachment 155708 [details]
> Double menus in LO ver. 6.3.3.2

Could you please paste the info from Help - about LibreOffice ?
Comment 34 the_cleaner 2019-11-11 19:24:40 UTC
Created attachment 155715 [details]
Screenshot ot Help screen

Here are screenshots of the Help screen and also the troublesome LO components.
Comment 35 Samuel Mehrbrodt (CIB) 2019-11-19 16:43:12 UTC
I can't reproduce this with current master and Unity environment.
Which DE are you using?
Can you try with a recent daily build?
Comment 36 Bernard Decock 2019-11-19 18:42:52 UTC
Created attachment 155949 [details]
Multiple instances of the menubar
Comment 37 Bernard Decock 2019-11-19 18:43:28 UTC
In my case I'm using Linux Mint 19.2 Cinnamon. I have only this problem as soon as I enable the extension LanguageTool and try to insert a formula into writer. If I disable LanguageTool, then the problem is gone.

I filed the bug as https://bugs.documentfoundation.org/show_bug.cgi?id=128491 which might be a duplicate of this bug. Today I managed to duplicate the menu as much as I wanted (see attachment)
Comment 38 Xisco Faulí 2019-11-19 21:51:46 UTC
(In reply to Bernard Decock from comment #37)
> In my case I'm using Linux Mint 19.2 Cinnamon. I have only this problem as
> soon as I enable the extension LanguageTool and try to insert a formula into
> writer. If I disable LanguageTool, then the problem is gone.
> 
> I filed the bug as
> https://bugs.documentfoundation.org/show_bug.cgi?id=128491 which might be a
> duplicate of this bug. Today I managed to duplicate the menu as much as I
> wanted (see attachment)

Since the issue is different ( yours is with LanguageTool enabled ), let keep them separated. Closing as RESOLVED FIXED
Comment 39 Marcus Tomlinson 2019-11-20 16:50:06 UTC
Created attachment 155982 [details]
Screenshots - 6.4.0.0-alpha - Ubuntu 19.10 - Unity DE

I can confirm what the_cleaner@t-online.de said about certain components working now, and I can appreciate that the problem is closer to being resolved, though the issue just seems a bit different now:

If you launch Writer directly - perfect, no duplicate menus.
If you launch Start Center - duplicate menus (see: 20-11-19-MT-SC.png)
If you launch Writer from Start Center - duplicate menus (see: 20-11-19-MT-SC-Writer.png)

About box - see: 20-11-19-MT-About.png

This is using 6.4.0.0-alpha on Ubuntu 19.10, Unity DE.
Comment 40 Marcus Tomlinson 2019-11-20 18:59:09 UTC
I don't have LanguageTool installed.
Comment 41 Xisco Faulí 2019-11-20 22:43:03 UTC
(In reply to Marcus Tomlinson from comment #40)
> I don't have LanguageTool installed.

Nevermind. Please, create a follow-up bug. this one is already long enough
Comment 42 Marcus Tomlinson 2019-11-22 11:15:00 UTC
Alright, new issue reported here: https://bugs.documentfoundation.org/show_bug.cgi?id=128954