Bug Hunting Session
Bug 88111 - Presentation: during slideshow screen draw, with OpenGL hardware acceleration active, rendering issues
Summary: Presentation: during slideshow screen draw, with OpenGL hardware acceleration...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta2
Hardware: Other Windows (All)
: highest major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: notBibisectable, regression
: 87310 88905 89339 89431 90082 (view as bug list)
Depends on:
Blocks: mab4.4
  Show dependency treegraph
 
Reported: 2015-01-06 14:15 UTC by Jacques Guilleron
Modified: 2015-12-17 10:58 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of presentation with a Math object (15.58 KB, application/vnd.oasis.opendocument.presentation)
2015-01-06 16:37 UTC, Laurent BP
Details
example presentation with hardware acceleration issues (250.74 KB, application/vnd.oasis.opendocument.presentation)
2015-01-15 13:30 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jacques Guilleron 2015-01-06 14:15:33 UTC
Steps to reproduce:

1 Open new Presentation.
2 Choose Insert > Object > Formula...
3 Write: x=2 over 4
4 Click out of the formula frame to validate.
5 Launch Slide Show.

Only fraction bar is visible.

Seen in:
LO 4.4.0.1 Build ID: 1ba9640ddd424f1f535c75bf2b86703770b8cf6f Locale: fr_FR
LO 4.4.0.0.beta2 Build ID: be92f32b8f21603a6b7a75dd645f7475bdee519d Locale:fr_FR
but not with:
LO 4.4.0.0.beta1 Build ID: 9af3d21234aa89dac653c0bd76648188cdeb683e Locale: fr_FR
& Windows 7 Home Premium

Jacques
Comment 1 Laurent BP 2015-01-06 16:37:07 UTC
Created attachment 111859 [details]
Example of presentation with a Math object
Comment 2 Laurent BP 2015-01-06 16:37:52 UTC
Confirmed with Version: 4.4.0.1.0+
Build ID: 4774b2f0e6a0e895d1e63256147eaff59efd0eda
TinderBox: Win-x86@51-TDF, Branch:libreoffice-4-4, Time: 2014-12-28_16:31:35
Locale: fr_FR

Not reproduced with LibO 4.3.5.2 
Set as regression
Comment 3 Laurent BP 2015-01-06 17:17:35 UTC
Confirmed with recent builds:
- Version: 4.4.0.1.0+
Build ID: 310c6e617f48ac94f2bd982b2dca6c05c06a2d51
TinderBox: Win-x86@51-TDF, Branch:libreoffice-4-4, Time: 2015-01-04_20:52:31
Locale: fr_FR
- Version: 4.5.0.0.alpha0+
Build ID: 8c7f6830e767897d3a0e88f75fc8d7ef7fca95dc
TinderBox: Win-x86@42, Branch:master, Time: 2015-01-06_00:47:25
Locale: fr_FR
Comment 4 Joel Madero 2015-01-06 17:40:12 UTC
MAB should always be set to highest, doing so now.
Comment 5 Laurent BP 2015-01-06 20:09:29 UTC
I can confirm that regression was introduced between beta1 and beta2.
Correction of version accordingly (it was my mistake).
Comment 6 Jean-Baptiste Faure 2015-01-07 05:29:22 UTC
Not reproducible for me with my onw build under Ubuntu 14.10 x86-64 with source code updated this morning.
Version 4.4.0.1.0+
Build ID: d7a507ab452bc84aeda00cc4d9bb7dbefde74339
Locale : fr_FR

MS-Windows only problem ?

Best regards. JBF
Comment 7 Laurent BP 2015-01-07 16:56:52 UTC
I do NOT reproduce on OpenSuse 13.2 with
Version: 4.4.0.1
Build ID: 1ba9640ddd424f1f535c75bf2b86703770b8cf6f
Locale: fr_FR

I agree with Jean-Baptiste: Win only pb :(
Comment 8 Laurent BP 2015-01-07 18:10:25 UTC
On Windows, if I uncheck Tools > Options > LibreOffice > View > Use hardware acceleration, bug disappears

However, I was unable to reproduce bug with any option
Comment 9 Laurent BP 2015-01-07 18:11:46 UTC
(In reply to Laurent BP from comment #8)
> On Windows, if I uncheck Tools > Options > LibreOffice > View > Use hardware
> acceleration, bug disappears
> 
> However, I was unable to reproduce bug with any option

The end is missing:
However, I was unable to reproduce bug with any option on Linux (OpenSuse 13.2)
Comment 10 Jacques Guilleron 2015-01-08 05:12:39 UTC
I confirm your observation in Comment 8: Uncheck Use hardware acceleration and the bug disappears.

Jacques
Comment 11 Maxim Britov 2015-01-11 00:01:54 UTC
seems my bug 87310 should be duplicate for this one.

I can see only images, not text. Affected only first slide after F5/Shift+F5.
If I switch to next and back I can see fine slide.
And yes, only with HW acceleration enabled and on Windows (tested 7/xp).
Comment 12 Joel Madero 2015-01-11 20:59:00 UTC
*** Bug 87310 has been marked as a duplicate of this bug. ***
Comment 13 V Stuart Foote 2015-01-15 13:30:00 UTC
Created attachment 112290 [details]
example presentation with hardware acceleration issues

On Windows 7 sp1, 64-bit en-US nVidia GTX260, nVidia 320.18 driver (9.18.13.2018)

With "Use hardware acceleration" set active (Tools -> Options -> View) launch of Slide Show does not render the text of the initial slide displayed. Advanced forward and then back, the full slide content does then draw.

However an OLE linked formula does not render in the slide show frame, but shows in the preview, next slide panels of slide show.

With use hardware acceleration set off, the text and formula will render on initial display.

In another twist, in the attached example presentation, first slide uses the new Focus master slide--which when hardware acceleration is off does not render.
Showing that issues with Windows OpenGL hardware rendering of graphics can go both directions--e.g. with acceleration and without.
Comment 14 V Stuart Foote 2015-01-30 02:17:05 UTC
*** Bug 88905 has been marked as a duplicate of this bug. ***
Comment 15 V Stuart Foote 2015-02-12 20:50:30 UTC
*** Bug 89339 has been marked as a duplicate of this bug. ***
Comment 16 V Stuart Foote 2015-02-17 13:42:25 UTC
*** Bug 89431 has been marked as a duplicate of this bug. ***
Comment 17 Laurent BP 2015-03-13 20:33:42 UTC
Hello,

This issue is fixed in LibO 4.4.2.1 :)

Resolved it as "Works for me" as we do not know which exact commit fixed it.
Comment 18 k-j 2015-03-28 19:56:33 UTC
*** Bug 90082 has been marked as a duplicate of this bug. ***
Comment 19 Robinson Tryon (qubit) 2015-12-17 10:58:30 UTC
Migrating Whiteboard tags to Keywords: (notBibisectable)
[NinjaEdit]