Bug 105015 - [Windows] Failure to populate system font list
Summary: [Windows] Failure to populate system font list
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: All Windows (All)
: highest major
Assignee: Khaled Hosny
URL: http://nabble.documentfoundation.org/...
Whiteboard: target:5.2.5 target:5.3.0.2 target:5.4.0
Keywords: haveBacktrace
: 103893 104971 105022 105076 105094 105166 105247 105291 105315 105383 105546 105554 (view as bug list)
Depends on:
Blocks: 103514
  Show dependency treegraph
 
Reported: 2016-12-31 08:36 UTC by Jon
Modified: 2018-04-07 04:32 UTC (History)
19 users (show)

See Also:
Crash report or crash signature: ["ImplReleaseTempFonts(SalData &)","SalAbort(rtl::OUString const &,bool)","rtl_cache_free"]
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon 2016-12-31 08:36:31 UTC
This bug was filed from the crash reporting server and is br-3012bebd-c9a3-4558-99db-0bc5d17b3ce8.
=========================================
Comment 1 Julien Nabet 2016-12-31 15:19:34 UTC
For the test, could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#Windows) and give a new try?

If you still reproduce the crash, did you install any specific fonts? If yes, could you disable them just for the test?
Comment 2 Jon 2017-01-01 08:05:07 UTC
(In reply to Julien Nabet from comment #1)
> For the test, could you rename your LO directory profile (see
> https://wiki.documentfoundation.org/UserProfile#Windows) and give a new try?
> 
> If you still reproduce the crash, did you install any specific fonts? If
> yes, could you disable them just for the test?

Crash reproduced after renaming profile folder. 

crashreport.libreoffice.org/stats/crash_details/5dc29b47-91aa-401b-b95e-30aa4e024ee4

I haven't installed any specific fonts except those that come with LO and M$Office.

Just so you see the sequence I open LO get to the navigation window with recent file history etc. 

Click on the spreadsheet I want to us and crashes.

Reverted back to 5.2.3 and opens just fine.
Comment 3 Julien Nabet 2017-01-01 19:05:56 UTC
Khaled: thought you might be interested in this one.

Meanwhile, let's put this one to NEW since there's a bt.
Comment 4 Julien Nabet 2017-01-01 19:08:11 UTC
*** Bug 105022 has been marked as a duplicate of this bug. ***
Comment 5 Khaled Hosny 2017-01-01 19:39:59 UTC
Interesting, we are aborting the application because no fonts were found. Did you install any font management software or changed any font related settings in Windows?
Comment 6 Jon 2017-01-01 20:11:04 UTC
(In reply to Khaled Hosny from comment #5)
> Interesting, we are aborting the application because no fonts were found.
> Did you install any font management software or changed any font related
> settings in Windows?

Never installed any additional fonts except ones that come bundled with LO or M$Office.

Not changed any font related settings in Windows that I am aware off. 

Not installed any font management software

Older versions of LO have been reinstalled and work with no error at all. 

This "bug" only seems to have appeared in this release.
Comment 7 Khaled Hosny 2017-01-01 21:45:38 UTC
I’m trying to identify the possible issue here since I can’t reproduce this crash locally. It is probably caused by the fix for bug 103514, but we need a way to reproduce the crash to be able to debug and eventually fix it.
Comment 8 Khaled Hosny 2017-01-04 18:47:57 UTC
*** Bug 105094 has been marked as a duplicate of this bug. ***
Comment 9 Khaled Hosny 2017-01-04 18:50:46 UTC
Bug 105094 shows that MS Office is installed, and comment 6 suggests the same, do all other people reporting this issue have MS Office installed (and what version)? Can anyone else with MS Office installed confirm if he can reproduce the crash?
Comment 10 V Stuart Foote 2017-01-04 20:43:22 UTC
This was side effect of backport to 5.2.4 of tdf#103514: Always ignore bitmap fonts on Windows

It has been reverted with:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f420f4c2e84deb182e4f675c1a0d45bede110ff2&h=libreoffice-5-2

5.2.4.2 Windows builds will continue to produce this issue. Requested a 5.2.4.3 build but that gained no traction.


=-ref-=

http://crashreport.libreoffice.org/stats/signature/ImplReleaseTempFonts(SalData%20&)
Comment 11 Marco Gaiarin 2017-01-05 10:50:23 UTC
Ok, i've downgraded to LO 5.2.3.3 and now i can open the file without troubles.

In last comment, i've not understood if a fixed 5.2.4.3 is still possible or i've to wait 5.2.5.

Thanks.
Comment 12 Julien Nabet 2017-01-05 10:59:26 UTC
(In reply to Marco Gaiarin from comment #11)
> Ok, i've downgraded to LO 5.2.3.3 and now i can open the file without
> troubles.
> 
> In last comment, i've not understood if a fixed 5.2.4.3 is still possible or
> i've to wait 5.2.5.
> 
> Thanks.
5.2.4 has already been officially released, so you must wait for 5.2.5
Comment 13 Khaled Hosny 2017-01-05 12:05:04 UTC
Though it will be fixed in the next 5.2.x release, it will show up again in 5.3, so people who suffer from this issue need to answer my questions in comment 9 to help me reproduce the issue in order to properly fix it.
Comment 14 Telesto 2017-01-05 13:25:53 UTC
I can't reproduce it with Windows 8 and MS Office 2003 
Version: 5.4.0.0.alpha0+
Build ID: 215cbfb460326010737433c2020638e9388a88a4
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-02_23:58:32
Locale: nl-NL (nl_NL); Calc: CL
Comment 15 Khaled Hosny 2017-01-05 13:40:39 UTC
(In reply to Telesto from comment #14)
> I can't reproduce it with Windows 8 and MS Office 2003 
> Version: 5.4.0.0.alpha0+
> Build ID: 215cbfb460326010737433c2020638e9388a88a4
> CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
> TinderBox: Win-x86@42, Branch:master, Time: 2017-01-02_23:58:32
> Locale: nl-NL (nl_NL); Calc: CL

There were some changes in 5.3 and 5.4 related to this area, so it might have fixed the underlying issue. To be sure can you test 5.3 and the affected 5.2 version?

For others who have MS Office, what version do you have installed?
Comment 16 Marco Gaiarin 2017-01-05 14:59:09 UTC
Some news.

Big (or a very similar one) hitted on a non-MSOffice installed PC. But LO bombs out printing on (selecting) a specific printer (HP Laserjet P1102).

Sorry, i'm going out now so i cannot do more tests.

PS: i'm rolling back to LO 5.1...
Comment 17 Khaled Hosny 2017-01-05 15:14:30 UTC
(In reply to Marco Gaiarin from comment #16)
> Some news.
> 
> Big (or a very similar one) hitted on a non-MSOffice installed PC. But LO
> bombs out printing on (selecting) a specific printer (HP Laserjet P1102).

Sounds like a different bug.
Comment 18 Jon 2017-01-05 19:44:06 UTC
(In reply to Khaled Hosny from comment #15)
> (In reply to Telesto from comment #14)
> > I can't reproduce it with Windows 8 and MS Office 2003 
> > Version: 5.4.0.0.alpha0+
> > Build ID: 215cbfb460326010737433c2020638e9388a88a4
> > CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
> > TinderBox: Win-x86@42, Branch:master, Time: 2017-01-02_23:58:32
> > Locale: nl-NL (nl_NL); Calc: CL
> 
> There were some changes in 5.3 and 5.4 related to this area, so it might
> have fixed the underlying issue. To be sure can you test 5.3 and the
> affected 5.2 version?
> 
> For others who have MS Office, what version do you have installed?

I have reproduced this issue on my work PC, that has MSOffice installed, version XP upgraded to 2003 then upgraded to 2007 which is the current version. The Work PC has Windows 8.1. I can recreate the crash and get the crash report again if needed. 

On my home PC I have MSOffice 2003 upgraded to 2007. The Home PC has Windows 10.

Without downgrading to MSOffice 2003 or XP to see if the issue remains I can provide very little else in way of information unless specifically asked for or told you need some thing specific.
Comment 19 Khaled Hosny 2017-01-05 20:20:25 UTC
(In reply to Jon from comment #18) 
> I have reproduced this issue on my work PC, that has MSOffice installed,
> version XP upgraded to 2003 then upgraded to 2007 which is the current
> version. The Work PC has Windows 8.1. I can recreate the crash and get the
> crash report again if needed. 
> 
> On my home PC I have MSOffice 2003 upgraded to 2007. The Home PC has Windows
> 10.

Thanks, that is very helpful. So both machines have MS Office 2007.

> Without downgrading to MSOffice 2003 or XP to see if the issue remains I can
> provide very little else in way of information unless specifically asked for
> or told you need some thing specific.

Can you test with the daily builds from http://dev-builds.libreoffice.org/daily/master/Win-x86@42/current/ and see if it crashes as well?
Comment 20 Jon 2017-01-06 07:10:15 UTC
(In reply to Khaled Hosny from comment #19)
> (In reply to Jon from comment #18) 
> > I have reproduced this issue on my work PC, that has MSOffice installed,
> > version XP upgraded to 2003 then upgraded to 2007 which is the current
> > version. The Work PC has Windows 8.1. I can recreate the crash and get the
> > crash report again if needed. 
> > 
> > On my home PC I have MSOffice 2003 upgraded to 2007. The Home PC has Windows
> > 10.
> 
> Thanks, that is very helpful. So both machines have MS Office 2007.
> 
> > Without downgrading to MSOffice 2003 or XP to see if the issue remains I can
> > provide very little else in way of information unless specifically asked for
> > or told you need some thing specific.
> 
> Can you test with the daily builds from
> http://dev-builds.libreoffice.org/daily/master/Win-x86@42/current/ and see
> if it crashes as well?

I have installed the daily build and it opens the file in question. This was using the home PC setup.

I will try the Work PC setup when I get into work.
Comment 21 Julien Nabet 2017-01-08 13:32:53 UTC
*** Bug 105166 has been marked as a duplicate of this bug. ***
Comment 22 V Stuart Foote 2017-01-08 14:48:22 UTC
Slight difference in traces for the SalAbort and the ImplReleaseTempFonts (both affected module(s) and the compiler for the build x86 v. amd64) but guess they have the same root cause in work on bug 103514 -- handling fonts in salfont.cxx

reverted for 5.2.5 and essentially correct at 5.3.0 and fully resolved in 5.4.0 master.

http://crashreport.libreoffice.org/stats/signature/SalAbort(rtl::OUString const &,bool)

http://crashreport.libreoffice.org/stats/signature/ImplReleaseTempFonts(SalData &)
Comment 23 V Stuart Foote 2017-01-11 14:19:44 UTC
The "SalAbort(rtl::OUString const &,bool)" with font handling at 5.2.4.2 is the other crash dump signature reflecting the issue.
Comment 24 V Stuart Foote 2017-01-11 14:23:01 UTC
*** Bug 105247 has been marked as a duplicate of this bug. ***
Comment 25 V Stuart Foote 2017-01-11 16:28:43 UTC
@Khaled, *

So it looks like there _are_ font handling crashes occurring in the 5.3.0.1 builds, was a little hard to tell with noise from the 5.2.4.2 issue.

Seems to occur when there is a font.cxx call for vcl or sfx needing font metric(s) to calculate layout:

sw printing preview screen font
sc printing size of print area
sw fontlist dialog
sw resize text frame
sc importing xml document
sw importing xml document
sm loading a formula

Here are direct links to stacktraces with symbols on the crash server.

5.3.0.1
http://crashreport.libreoffice.org/stats/crash_details/616fa7c9-7759-4c52-b4b9-2af79a183045

http://crashreport.libreoffice.org/stats/crash_details/5d375a50-6530-4e53-aebc-7387be63ea34

http://crashreport.libreoffice.org/stats/crash_details/392e51b8-862d-4a72-b7c3-5ee3807fa733

http://crashreport.libreoffice.org/stats/crash_details/9c84e519-3f61-4ffe-a1b8-da40fc940183

http://crashreport.libreoffice.org/stats/crash_details/4f3167a6-aa0a-43f1-8fc7-c749e8b13bc2

http://crashreport.libreoffice.org/stats/crash_details/59db86df-164e-4383-9dfc-baf120bb6d70

http://crashreport.libreoffice.org/stats/crash_details/6b7a6865-d58d-4a85-a2c1-d8a182fd0583

http://crashreport.libreoffice.org/stats/crash_details/a63ca0d1-aeb9-4922-8f98-3f924ba202f7

http://crashreport.libreoffice.org/stats/crash_details/b7477b1b-e7ea-42c4-9a2e-cd4b4a8e6ebf

http://crashreport.libreoffice.org/stats/crash_details/ea18adcd-bb29-46da-a676-1356b60e93c5

http://crashreport.libreoffice.org/stats/crash_details/7e6a8576-d99a-4f46-adf5-a8f7289da28a

http://crashreport.libreoffice.org/stats/crash_details/f530e327-0ff6-4b28-b1dd-b52357013c6a

http://crashreport.libreoffice.org/stats/crash_details/3362b038-5d4e-4221-8276-2b5a7218404a

http://crashreport.libreoffice.org/stats/crash_details/82ca390f-113a-45b4-81e5-7045ee8c48d1


5.3.0.0 (so alpha1+, beta1, or beta2)
http://crashreport.libreoffice.org/stats/crash_details/f952abf2-7da9-498c-bc0c-5298d3420099

http://crashreport.libreoffice.org/stats/crash_details/cd2a3787-8183-4280-8c2f-4546bd85a9fb

http://crashreport.libreoffice.org/stats/crash_details/4a985258-e7ba-4fc9-aeb8-74dc111c628e

http://crashreport.libreoffice.org/stats/crash_details/3f0b5887-fcf9-481e-b424-9e8ab2468545

http://crashreport.libreoffice.org/stats/crash_details/6f679a1c-5a46-4089-beeb-23d6ce415219

http://crashreport.libreoffice.org/stats/crash_details/8d081613-1635-43d3-8583-7e8c4e09af36

http://crashreport.libreoffice.org/stats/crash_details/25e06ef5-7ceb-4925-af97-48ecaaf600cf

http://crashreport.libreoffice.org/stats/crash_details/40e0e846-74f5-44c0-90c0-5b97815d09ec

http://crashreport.libreoffice.org/stats/crash_details/5b1cb499-36b3-4ab8-9a2e-bf4e1d487c95

http://crashreport.libreoffice.org/stats/crash_details/9a07535d-caab-426c-a63f-c76d8f44f08a

http://crashreport.libreoffice.org/stats/crash_details/bcc0b6e4-c319-45c0-9c78-e4c3b2369c55

http://crashreport.libreoffice.org/stats/crash_details/df020409-2c21-4891-a4b9-f31a712aa26a

http://crashreport.libreoffice.org/stats/crash_details/836c764e-dc9f-4518-89bf-ab0f65957b9b

http://crashreport.libreoffice.org/stats/crash_details/74fef50b-393f-4911-9faf-c3a2923de08c

http://crashreport.libreoffice.org/stats/crash_details/2762d227-1c80-4995-838a-28df3b6dee0f
Comment 26 V Stuart Foote 2017-01-11 18:37:05 UTC
Adding stacktrace crash report 5.3.0.1 (x86 build) from bug 103893 for the sm module

http://crashreport.libreoffice.org/stats/crash_details/3b93f248-b48a-4e43-b7ee-337f258def35
Comment 27 Khaled Hosny 2017-01-11 22:37:59 UTC
(In reply to V Stuart Foote from comment #25)
> @Khaled, *
> 
> So it looks like there _are_ font handling crashes occurring in the 5.3.0.1
> builds, was a little hard to tell with noise from the 5.2.4.2 issue.

This is already stated above and it is why I’m asking for more information, but so far little was given.
Comment 28 Khaled Hosny 2017-01-11 22:44:37 UTC
*** Bug 103893 has been marked as a duplicate of this bug. ***
Comment 29 Maxim Monastirsky 2017-01-12 01:24:19 UTC
@Khaled: Most of the stacks in comment 25 have some printer related stuff, so this might explain why some people can't reproduce the crash (different printer model). Indeed, I can reproduce the crash after installing the Windows built-in "Generic / Text only" driver, either by setting it as default, or selecting it in the print dialog.

Which immediately makes me suspect this thing in SalEnumFontsProcExW:

1389         // Ignore non-device font on printer.
1390         if (pInfo->mbPrinter && !(nFontType & DEVICE_FONTTYPE))
1391             return 1;

The problem is that not all printers have device fonts...

Also ,the previous code was:

if( (nFontType & RASTER_FONTTYPE) && !(nFontType & DEVICE_FONTTYPE) )

so the DEVICE_FONTTYPE check was only a way to not exclude some raster fonts.

Maybe that's the problem? Unfortunately I don't have a Window build right now, so can't test it myself.
Comment 30 Khaled Hosny 2017-01-12 05:52:55 UTC
(In reply to Maxim Monastirsky from comment #29)
> @Khaled: Most of the stacks in comment 25 have some printer related stuff,
> so this might explain why some people can't reproduce the crash (different
> printer model). Indeed, I can reproduce the crash after installing the
> Windows built-in "Generic / Text only" driver, either by setting it as
> default, or selecting it in the print dialog.

I see, what steps should I follow to do the same? Do you also have MS Office installed? 
> 
> Which immediately makes me suspect this thing in SalEnumFontsProcExW:
> 
> 1389         // Ignore non-device font on printer.
> 1390         if (pInfo->mbPrinter && !(nFontType & DEVICE_FONTTYPE))
> 1391             return 1;

But this check have been there for ever AFAIK, I’m certainly more than happy to not treat printers any different than screen. Also it should kick only if the OutputDev is a printer (which I assume should happen only if you are printer, but experience shows one shouldn’t assume much around this code base).

Hmm, checking the commit history again, it was originally:

// ignore non-scalable non-device font on printer
if( pInfo->mbPrinter )
    if( (nFontType & RASTER_FONTTYPE) && !(nFontType & DEVICE_FONTTYPE) )
        return 1;

It is certainly possible I screwed this up and the new condition is not equivalent to the old one. Are you able to revert to the old condition, build the code and test locally? Since you can reproduce this and I can’t.

> The problem is that not all printers have device fonts...
> 
> Also ,the previous code was:
> 
> if( (nFontType & RASTER_FONTTYPE) && !(nFontType & DEVICE_FONTTYPE) )
> 
> so the DEVICE_FONTTYPE check was only a way to not exclude some raster fonts.
> 
> Maybe that's the problem? Unfortunately I don't have a Window build right
> now, so can't test it myself.

This answers my two questions above :(
Comment 31 Khaled Hosny 2017-01-12 05:57:45 UTC
Thinking more, this might explain why it is fixed with 5.4 for Jon (comment 20) since that line is completely gone in 5.4. I think I’ll just do the same for 5.3 and hope it fixes things (until I manage to reproduce it locally).
Comment 32 Marco Gaiarin 2017-01-12 08:33:22 UTC
(In reply to Maxim Monastirsky from comment #29)
> @Khaled: Most of the stacks in comment 25 have some printer related stuff,
> so this might explain why some people can't reproduce the crash (different
> printer model).

I've noted also i (on 5.2) some correlation with printers, look at my comment #16.

Sorry, but i decided to roll back to 5.1 and now i've no time to collect crash info. I hope in next week...
Comment 33 Maxim Monastirsky 2017-01-12 09:20:24 UTC
(In reply to Khaled Hosny from comment #30)
> I see, what steps should I follow to do the same? Do you also have MS Office
> installed? 
Unrelated to MS Office.

Open Device Manager, Action > Add legacy hardware > Next > manually from a list (Advanced) > Printers > Next. In "Manufacturer" list select "Generic", and in "Printers" list select "Generic / Text Only". Complete the installation, and set that printer as default.

Now open Writer, type something, and open the print dialog...
Comment 34 V Stuart Foote 2017-01-12 15:43:32 UTC
confrimed following steps of comment 33 on Windows 10 Pro 64-bit en-US with admin install of

Version: 5.3.0.1 (x64)
Build ID: 3b800451b1d0c48045de03b5b3c7bbbac87f20d9
CPU Threads: 8; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
Locale: en-US (en_US); Calc: CL

Here are links to crashreport details for the above build using default GDI rendering when using each LO module, note that as reported bug 103893 with the sm Formula editor the crash is immediat on opening from StartCenter.

Will next check similar with OpenGL rendering.

=-=-=

Writer
http://crashreport.libreoffice.org/stats/crash_details/4ddeedee-a1ed-4b54-a856-8a2f1634c9d9

Calc
http://crashreport.libreoffice.org/stats/crash_details/e8c5d2dc-5ea2-459a-8563-fa78bca82da9

Draw
http://crashreport.libreoffice.org/stats/crash_details/cc9f486c-2973-421f-96d5-487eafe602c8

Impress
http://crashreport.libreoffice.org/stats/crash_details/e3bb39f9-84e7-40e7-9c45-36e2600dd2b5

sMath
http://crashreport.libreoffice.org/stats/crash_details/e312bb9d-f5c8-404b-a5d4-9b044eca9f7f
http://crashreport.libreoffice.org/stats/crash_details/d04ab02c-419d-4231-8472-f8119aef07d9
Comment 35 V Stuart Foote 2017-01-12 16:05:25 UTC
(In reply to V Stuart Foote from comment #34)
> 
> Will next check similar with OpenGL rendering.
> 

Same Windows 10 Pro 64-bit en-US system with OpenGL rendering enabled
Version: 5.3.0.1 (x64)
Build ID: 3b800451b1d0c48045de03b5b3c7bbbac87f20d9
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; Layout Engine: new; 
Locale: en-US (en_US); Calc: CL

Crashreport details for each module with OpenGL rendering. All stacktrace seem the same as with the GDI default rendering. And the Formula editor is affected at launch without having to run any print action.

Writer
http://crashreport.libreoffice.org/stats/crash_details/8e904858-a5b9-42c6-8760-81883948a413

Calc
http://crashreport.libreoffice.org/stats/crash_details/a35fb7d5-e5b1-4441-9431-1d165a3a462f

Draw
http://crashreport.libreoffice.org/stats/crash_details/663ff981-adce-4c17-a7b0-3fd695e6aca1

Impress
http://crashreport.libreoffice.org/stats/crash_details/e35881b0-465f-4dd8-8177-af69335be1d3

sMath
http://crashreport.libreoffice.org/stats/crash_details/7f432800-61de-416f-8251-f5326543403a
Comment 36 V Stuart Foote 2017-01-12 16:13:09 UTC
Also have these showing with the http://crashreport.libreoffice.org/stats/signature/rtl_cache_free signature
Comment 37 Maxim Monastirsky 2017-01-12 19:27:03 UTC
*** Bug 105291 has been marked as a duplicate of this bug. ***
Comment 38 Khaled Hosny 2017-01-12 21:27:13 UTC
I can reproduce this now based on the steps from comment 33 (it even crashes for me at the start), and a fix for 5.3 have been pushed to gerrit. Can’t reproduce with 5.4, but will double check if it needs same treatment.
Comment 39 Commit Notification 2017-01-13 11:41:34 UTC
Khaled Hosny committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=88d6675a40034fa786efd75cf14175f3c0c83e2e&h=libreoffice-5-3

tdf#105015: Don’t ignore all printer fonts

It will be available in 5.3.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 40 Khaled Hosny 2017-01-13 22:37:27 UTC
*** Bug 105315 has been marked as a duplicate of this bug. ***
Comment 41 Commit Notification 2017-01-15 12:46:48 UTC
Khaled Hosny committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=db146ea596c8056ef7a75d7d6c58d9293161d5da

tdf#105015: Don’t ignore all printer fonts

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 42 Xisco Faulí 2017-01-17 11:25:59 UTC
*** Bug 105383 has been marked as a duplicate of this bug. ***
Comment 43 Xisco Faulí 2017-01-19 10:07:46 UTC
*** Bug 105431 has been marked as a duplicate of this bug. ***
Comment 44 Julien Nabet 2017-01-23 10:19:20 UTC
*** Bug 104971 has been marked as a duplicate of this bug. ***
Comment 45 Xisco Faulí 2017-01-26 18:23:06 UTC
*** Bug 105554 has been marked as a duplicate of this bug. ***
Comment 46 Xisco Faulí 2017-01-26 18:29:06 UTC
*** Bug 105546 has been marked as a duplicate of this bug. ***
Comment 47 Jon 2017-01-28 08:35:49 UTC
Have just downloaded and installed 5.2.5.1 and all is now good, no crashes and able to print.

Jon
Comment 48 Mike Kaganski 2017-01-30 15:28:45 UTC
*** Bug 105076 has been marked as a duplicate of this bug. ***
Comment 49 Marco Gaiarin 2017-02-02 09:35:31 UTC
Ok, i confirm mee too that 5.2.5.1 works as expected, all crashes gone.
Comment 50 olexandr 2017-02-15 17:40:19 UTC
for 5.3.0 version this bug not confirmed