Bug Hunting Session
Bug 115967 - Distorted formulas on printing to PDF or exporting to PDF for RTL text
Summary: Distorted formulas on printing to PDF or exporting to PDF for RTL text
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.0.0.1 rc
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.3.4
Keywords: bibisected, bisected, regression
: 116746 117089 122409 124494 125773 128295 (view as bug list)
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2018-02-23 13:54 UTC by ogb1966
Modified: 2019-10-29 16:37 UTC (History)
16 users (show)

See Also:
Crash report or crash signature:


Attachments
PDF document showing the problem (see red ellipses) (58.19 KB, application/pdf)
2018-02-23 14:04 UTC, ogb1966
Details
Writer document at the origin of the above PDF (348.22 KB, application/vnd.oasis.opendocument.text)
2018-02-23 14:05 UTC, ogb1966
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ogb1966 2018-02-23 13:54:24 UTC
Description:
When I used the new version to generate a PDF from a Writer document all characters in formulas created with the formula editor were stacked together.
I this on several documents that I know worked fine on previous version and I got the same result.
In addition when I rolled back to 5.4 everything was corrected. 

Steps to Reproduce:
1.Create a document (specifically was a rtf document). 
2. Insert some formulas with formula editor.
3. Create PDF or Print as PDF.

Actual Results:  
Formulas are distorted in PDF.

Expected Results:
Readable formulas


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: StartModule
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36
Comment 1 ogb1966 2018-02-23 14:04:31 UTC
Created attachment 140089 [details]
PDF document showing the problem (see red ellipses)

I'll attached separately the original document too.
Comment 2 ogb1966 2018-02-23 14:05:52 UTC
Created attachment 140090 [details]
Writer document at the origin of the above PDF
Comment 3 V Stuart Foote 2018-02-23 15:20:03 UTC
Confirmed regression of the sm formula OLE objects are correct on canvas, but are malformed and misplaced when exported to PDF or with gs print to PDF.
Windows 10 Home 64-bit en-US with
Version: 6.0.1.1 (x64)
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 4; OS: Windows 10.0; UI render: GL (or Default); 
Locale: en-US (en_US); Calc: CL

The OLE formula objects are correct at Version: 5.4.5.1 (x64)
Build ID: 79c9829dd5d8054ec39a82dc51cd9eff340dbee8
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
Locale: en-US (en_US); Calc: CL
Comment 4 Timur 2018-02-23 15:33:14 UTC
No repro from scratch with LTR, seems RTL issue.
Comment 5 raal 2018-02-26 16:07:22 UTC
This seems to have begun at the below commit.
Adding Cc: to Armin Le Grand ; Could you possibly take a look at this one?
Thanks

283c0946ea76b829d4015eaa3145a813d0289036 is the first bad commit
commit 283c0946ea76b829d4015eaa3145a813d0289036
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Tue Aug 22 18:49:37 2017 +0200

    source sha:302af8c2da58719844d22483b65a9fe5b3674684

author	Armin Le Grand <Armin.Le.Grand@cib.de>	2017-08-22 10:05:15 +0200
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2017-08-22 14:42:28 +0200
commit	302af8c2da58719844d22483b65a9fe5b3674684 (patch)
tree	9a0d81cb81e1130e9467f1e4de2077cea78c38f5
parent	cc2cb0123ac599bf25c5e17b97b5d7bf93d3e487 (diff)
sw: Use primitive renderer for graphics
To allow using the prepared VectorData of imported
Metafiles (and EMF+), let Writer use a Primitive
Renderer for Graphic output. For now, use a temp
PrimitiveRenderer (until sw is fully adapted to
primitives).
Comment 6 Xisco Faulí 2018-04-27 14:00:32 UTC
*** Bug 116746 has been marked as a duplicate of this bug. ***
Comment 7 Xisco Faulí 2018-04-27 14:01:09 UTC
*** Bug 117089 has been marked as a duplicate of this bug. ***
Comment 8 Khaled Hosny 2019-04-03 21:33:02 UTC
*** Bug 124494 has been marked as a duplicate of this bug. ***
Comment 9 Farooq Karimi Zadeh 2019-07-11 13:24:24 UTC
I have the same problem using Ubuntu 18.04 x86 and Libreoffice  6.2.4.2 20(Build:2).
Comment 10 Xisco Faulí 2019-09-26 11:06:32 UTC
*** Bug 125773 has been marked as a duplicate of this bug. ***
Comment 11 Xisco Faulí 2019-09-26 11:07:14 UTC
*** Bug 122409 has been marked as a duplicate of this bug. ***
Comment 12 Xisco Faulí 2019-10-21 13:04:39 UTC
*** Bug 128295 has been marked as a duplicate of this bug. ***
Comment 13 Xisco Faulí 2019-10-21 15:58:47 UTC
Increasing severity due to the number of duplicates...
Comment 14 Commit Notification 2019-10-24 09:32:00 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/83baaec3a087f83d0ad3371d55671d9496771586

tdf#115967: Revert "sw: Use primitive renderer for graphics"

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2019-10-24 14:00:24 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/dca2adcdb6ed93dff76468d02e0de6984fae3ec9

tdf#115967: fix windows build

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2019-10-25 07:40:31 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/1560adf9cfd1d4ef076561b1c48e80c9936c940d

tdf#115967: Revert "sw: Use primitive renderer for graphics"

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 ogb1966 2019-10-29 16:37:20 UTC
I wanted to test it on 6.3.4 daily as suggested but I'm on Windows and I think there isn't a build for it. 
I would be glad to test it if a Windows 64 install will be available.

Anyway I don't know if the patch is in 6.4 alpha but it installed it and the problem still existes on this version.
Thanks.