Bug 135802 - Page style setting confusing
Summary: Page style setting confusing
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-16 13:43 UTC by Telesto
Modified: 2020-12-18 07:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (223.55 KB, application/vnd.oasis.opendocument.text)
2020-08-16 13:43 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-16 13:43:14 UTC
Description:
Page style setting confusing

Steps to Reproduce:
1. Open the attached file
2. Format Page Style for the first page -> Notice the next style being Landscape. Change it.. Nothing happens
3. Go to page 2 -> Format - Page Style -> Change the next style to landscape -> It's applied to the next page 

Reason: Format -> Paragraph -> Text Flow -> Breaks -> insert with page style on page 2.

 

Actual Results:
It's confusing having two settings for setting page style in different dialog which interact with each other without being visible at once

Expected Results:
Not sure how to fix this, but current solution is rather confusing IMHO


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: <buildversion>
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-08-16 13:43:28 UTC
Created attachment 164350 [details]
Example file
Comment 2 BogdanB 2020-08-16 14:11:15 UTC
I confirm this. I tried 5 minutes to find WHY this problem. And I had to read Telesto comment to find why. Should be an altert, something that the next page is already setup by a different component.
Comment 3 V Stuart Foote 2020-08-16 18:28:46 UTC
We last did this dance for bug 126608 -- the 'Default Page Style' has been changed from template defaults.

Anyhow one of the observations there was that bug 41316 is involved, but that ODF 1.3 provides no relief.
Comment 4 Telesto 2020-08-16 23:26:38 UTC
Adding R. Green into the loop. He had some issues in this area
Comment 5 Heiko Tietze 2020-08-31 09:18:27 UTC
(In reply to Telesto from comment #0)
> 2. Format Page Style for the first page -> Notice the next style being
> Landscape. Change it.. Nothing happens

If you add a manual page break with a special page style you shouldn't expect the application to override¹. Just force a page break (ctrl+enter) and get the landscape styled next page (before the differently formatted 3rd page).

I don't see an issue, => WFM. Maybe bug 134557 for better feedback.

¹ Blue dotted line between pages indicates the page break. Click it and use Edit Page Break to also get to the text flow setting.
Comment 6 Telesto 2020-08-31 10:39:44 UTC
(In reply to Heiko Tietze from comment #5)
> (In reply to Telesto from comment #0)
> > 2. Format Page Style for the first page -> Notice the next style being
> > Landscape. Change it.. Nothing happens
> 
> If you add a manual page break with a special page style you shouldn't
> expect the application to override¹. 

-> Not the point of course. I never said it should. However, the current way of managing things isn't to user friendly. Even if from technical point of view correct. This about accessibility. If there are more menu's. In circumstances doing the same thing, and under different circumstances doing different things, it becomes rather hard.

Especially if you don't know all aspects of the document design. You might the work of somebody else. 

The styles inspector might show it, but surely not the holy grail. 

For record, all the see also are more or less expressions of the same 'fundamental' issue GUI wise. [Not functionality wise]
Comment 7 BogdanB 2020-08-31 10:46:28 UTC
I use LibreOffice since 2012 and I didn't find alone how to change this. 
Maybe a red mesage should inform that the same properties is changed in another place by something else and how to change that.
Comment 8 Heiko Tietze 2020-10-23 09:35:18 UTC
(In reply to BogdanB from comment #7)
> I use LibreOffice since 2012 and I didn't find alone how to change this. 

You never looked at the Stylist with page styles being selected? 

Besides that the request "It's confusing having two settings for setting page style" is vague no expectation is made. One solution is to RTFM, another trial and error with a clear workflow.
Potential advanced solution is the style highlighting idea, bug 38194, bug 106556, and bug 34002, see also [1]. If we extend the idea to page styles we could show a bar in the document's margin that indicates what PgS is applied.

Removing UX for now.

[1] https://design.blog.documentfoundation.org/2019/11/05/proposal-to-conveniently-highlight-and-inspect-styles-in-libreoffice-writer/
Comment 9 Justin L 2020-12-18 07:25:18 UTC
These bug reports just need to be closed. Ultimately, the human needs to learn the tool they are using.