Bug 152217 - Black box in Basic IDE where the status bar should be (kf5 only)
Summary: Black box in Basic IDE where the status bar should be (kf5 only)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
7.5.0.0 alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Michael Weghorn
URL:
Whiteboard: target:7.6.0 target:7.5.3
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Statusbar KDE UI BASIC-IDE
  Show dependency treegraph
 
Reported: 2022-11-25 14:30 UTC by Rafael Lima
Modified: 2023-04-08 10:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the problem (60.18 KB, image/png)
2022-11-25 14:30 UTC, Rafael Lima
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Lima 2022-11-25 14:30:16 UTC
Created attachment 183774 [details]
Screenshot of the problem

If you open LibreOffice in a non-maximized window and then open the Basic IDE (Tools - Macros - Edit Macros) and the window is not maximized upon opening, then a black bar will appear where the statusbar should be.

This bug only affects kf5. It seems to be working fine in gtk3 and gen.

See attached screenshot for more info.

Steps to reproduce:
1) In KDE Plasma, open LibreOffice Calc (or any other LO app) and then tile it to the left side of the screen (Super + Left)
2) Open the Basic IDE (Tools - Macros - Edit Macros) and also tile this window to the left; then close the Basic IDE
3) Now open the Basic IDE again; it will open non-maximized and tiled to the left; however now a black bar will appear where the statusbar should be
4) Maximizing the window repaints the statusbar and the problem disappears

If the Basic IDE opens maximized, then the problem is not noticeable. The problem only occurs when the window opens in a non-maximized state.

Present in LO 7.5 from daily build:

Version: 7.5.0.0.alpha0+ (X86_64) / LibreOffice Community
Build ID: 24d7431876e87eba700a9f141dc8e030143a92ad
CPU threads: 16; OS: Linux 5.19; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Calc: CL threaded

Not present in

Version: 7.4.2.3 / LibreOffice Community
Build ID: 40(Build:3)
CPU threads: 16; OS: Linux 5.19; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Ubuntu package version: 1:7.4.2~rc3-0ubuntu1
Calc: threaded
Comment 1 Stéphane Guillou (stragu) 2022-12-03 23:50:19 UTC
Can reproduce with:

Version: 7.5.0.0.alpha0+ (X86_64) / LibreOffice Community
Build ID: a41c82407bbb73a4d87070326485ec4b4e954a65
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: kf5 (cairo+xcb)
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

But not with:

Version: 7.4.3.2 / LibreOffice Community
Build ID: 1048a8393ae2eeec98dff31b5c133c5f1d08b890
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: kf5 (cairo+xcb)
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded
Comment 2 Stéphane Guillou (stragu) 2023-01-18 22:09:18 UTC
Bibisected with linux-64-7.5 repo to first bad commit 5c4a00e051f4d9366ae8a2e98a1f2ab4b016e9a7 which points to core commit:

commit afc828b9833b7a612369e95606ba56d41ef2c369
author	Jan-Marek Glogowski <glogow@fbihome.de>	Sat May 28 23:47:21 2022 +0200
committer	Jan-Marek Glogowski <glogow@fbihome.de>	Tue Jun 21 17:26:06 2022 +0200
tree b60ec391ff6f93f85eb4f88d756c2f70b79b674c
parent dbaf5f6fad2ec10f69cf46f9cb697b8760c2a01f
VCL expect correct frame size for native menubars
Change-Id: I7faeace61b456c2b0f42c7a826f58018b70d46ae
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/135082

Jan-Marek, can you please have a look?
Comment 3 Commit Notification 2023-03-29 10:46:19 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f51b220b953ec71fb742f799fbe645a93cf3d944

tdf#149805 tdf#151677 tdf#152217 tdf#154043 tdf#153458 tdf#153800 Revert "VCL expect

It will be available in 7.6.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Michael Weghorn 2023-03-29 10:55:06 UTC
Fixed now by reverting the commit that caused the regression, s. more details in the commit message.
Comment 5 Commit Notification 2023-04-07 16:41:45 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "libreoffice-7-5":

https://git.libreoffice.org/core/commit/0d2e22e1700aca42246924c2083c2271a9ad0d79

tdf#149805 tdf#151677 tdf#152217 tdf#154043 tdf#153458 tdf#153800 Revert "VCL expect

It will be available in 7.5.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Stéphane Guillou (stragu) 2023-04-08 10:18:21 UTC
Fix verified in:

Version: 7.6.0.0.alpha0+ (X86_64) / LibreOffice Community
Build ID: ad5756f0529a80fbb537979bcfd9de7a83a69805
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: kf5 (cairo+xcb)
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded