Bug 33229 - Update old Sun/OpenOffic icons to the LibreOffice branding
Summary: Update old Sun/OpenOffic icons to the LibreOffice branding
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.0 RC3
Hardware: All All
: medium normal
Assignee: Thorsten Behrens (CIB)
QA Contact:
URL:
Whiteboard:
Keywords:
: 31608 34862 35046 35713 37070 38582 (view as bug list)
Depends on: 32147 37617
Blocks: 36741
  Show dependency treegraph
 
Reported: 2011-01-18 02:16 UTC by Thorsten Behrens (CIB)
Modified: 2011-12-02 08:31 UTC (History)
15 users (show)

See Also:
Crash report or crash signature:


Attachments
old OOo app install image with RC2 (77.20 KB, image/png)
2011-02-21 07:49 UTC, Alex Thurgood
Details
old OOo icons used in startcenter with RC2 on Mac (86.47 KB, image/png)
2011-02-21 07:50 UTC, Alex Thurgood
Details
Screenshots, See Comment 25 (142.14 KB, application/x-download)
2011-03-28 00:22 UTC, Rainer Bielefeld Retired
Details
OOo icons in various places (145.09 KB, image/png)
2011-03-30 14:56 UTC, Bernhard Dippold
Details
SVG source of Tango and Galaxy style icons in intermediate size (26px) (211.49 KB, image/svg+xml)
2011-03-30 15:34 UTC, Bernhard Dippold
Details
In the web wizard StarOffice icons are used to indicate ODF files (60.21 KB, image/png)
2011-03-31 15:33 UTC, Bernhard Dippold
Details
galaxy mimetype icons (131.96 KB, image/svg+xml)
2011-05-17 05:47 UTC, Thorsten Behrens (CIB)
Details
tango mimetype icons (167.83 KB, image/svg+xml)
2011-05-17 05:48 UTC, Thorsten Behrens (CIB)
Details
Main icons in Tools - Options shows OOo seagulls (LibO 3.4.0RC2) (82.78 KB, image/png)
2011-05-29 02:55 UTC, Bernhard Dippold
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Behrens (CIB) 2011-01-18 02:16:31 UTC
See $subject - the old mimetype icons are all still wearing the Sun branding.
Comment 1 Thorsten Behrens (CIB) 2011-01-18 02:22:09 UTC
Hm, seems patch size is limited - uploading associated patches to http://users.freedesktop.org/~thorsten/fdo33229
Comment 2 Thorsten Behrens (CIB) 2011-01-18 02:29:32 UTC
More background, and visuals here: http://luxate.blogspot.com/2011/01/libreoffice-initial-icons-milestone.html
Comment 3 Thorsten Behrens (CIB) 2011-01-18 06:53:29 UTC
Still fighting with the Mac installer image (DS_Store from the dmg root folder)
-

additionally, the following icon themes are not adapted yet, and I'm rather
reluctant to do so (they're default on some platforms, and the new icons don't
visually fit that well):

Crystal
Tango
Oxygen

These icon sets have been adapted:

Galaxy: ok
Classic: ok
Highcontrast: ok
Comment 4 Thorsten Behrens (CIB) 2011-01-18 13:12:20 UTC
Mac seems ok now, Chris rightly mentions that Math has a wrong icon in the startcenter. Still, sneak peek is here: http://users.freedesktop.org/~thorsten/libo-icons.png
Comment 5 Bernhard Dippold 2011-01-18 16:39:52 UTC
I don't know if you already took care about it:

On my Ubuntu version the favicon in the task pane consists of a circular blue symbol with two gulls - the same as you see in Tools-Options:
http://www.libreoffice.org/assets/Shuffler/Screenshot-03.png

I'd prefer 16px application icon (main16.png) for the task pane and the 32px application icon (main32.png) for the options main page.

Best regards

Bernhard
Comment 6 Christoph 2011-02-02 12:44:14 UTC
Most recent version of the icons for 3.3.1 can be found here:
http://wiki.documentfoundation.org/cgi_img_auth.php/d/d4/LibreOffice_Initial_Icons-pre_final.svg
Comment 8 Ed 2011-02-11 08:33:46 UTC
Can you please consider using different icons for ODF and non-ODF file types?  Something as simple as deleting or changing the colour of the upper-right triangle for non-ODF types would do.

Currently the only way to tell the difference between files in different formats with the same name is the extension (which some file managers hide anyway).  This makes things difficult if you export a copy of a file in a different format to send to someone with different software, for example.


Also I noticed the icons in the LO file picker and the options screen have not been changed in 3.3.1RC1.  Are these being worked on?
Comment 9 Ed 2011-02-13 05:02:23 UTC
Update:

I see the file picker does use LO icons for ODF files but not for any other types.  This is good that it uses different icons for ODF and non-ODF formats, but bad that the non-ODF icons are not clearly colour coded and are inconsistent with the icons provided for file managers to use with the same files.
Comment 10 Alex Thurgood 2011-02-21 07:49:15 UTC
Created attachment 43607 [details]
old OOo app install image with RC2

old OOo icon used for app install image
Comment 11 Alex Thurgood 2011-02-21 07:50:18 UTC
Created attachment 43608 [details]
old OOo icons used in startcenter with RC2 on Mac

old icons used in startcenter first launch with RC2 on Mac
Comment 12 Thorsten Behrens (CIB) 2011-02-22 02:02:46 UTC
Alex, I definitely cannot reproduce your problem - just to make sure, you run ppc, or x86? And what does your LibreOffice->About LibreOffice state, for the version field?
Comment 13 Thorsten Behrens (CIB) 2011-02-22 02:03:41 UTC
Sorry, Alex was not on Cc - Alex, could you check my previous question please?
Comment 14 Alex Thurgood 2011-02-22 02:20:42 UTC
Hi Thorsten,
Sorry about that, thought I was on copy.
X86
LibreOffice 3.3.0
Ooo330m19 build 6
Tag libreoffice 3.3.0.4
Comment 15 Alex Thurgood 2011-02-22 02:23:00 UTC
Fwiw the icons are fine in the nightly build from 19/02/2011.
Comment 16 Thorsten Behrens (CIB) 2011-02-22 05:26:16 UTC
Alex, ok, so there's the problem - you're running 3.3.0 final. The RC2 has the 3.3.1.2 tag - did you get it from http://www.libreoffice.org/download/pre-releases/ ?

So for 3.3.1, I consider this bug fixed.
Comment 17 Ed 2011-02-22 11:04:47 UTC
This is not fully solved in 3.3.1 RC 2 (clean installation with new profile on Windows 7 and Kubuntu Maverik).  There are still Sun/Oracle icons in the following places:

The start centre uses Sun icons with the "Oxygen" theme;

The Options panel uses Oracle icons with the "Galaxy" and "High Contrast" themes and Sun icons with the "Classic" theme on the home tabs of the mudule catagories;

The start centre window icon is still the Sun icon (Linux);

The "Template Management" window has a Sun window icon (Linux) and uses old icons for the templates in the list;

The "Printer Administration" menu item and Window icon sre Sun icons (Linux);

The top two icons on the left hand side of the quickstarter are Sun icons.

There are the ones I have found, there may still be more.
Comment 18 Thorsten Behrens (CIB) 2011-02-22 14:53:34 UTC
Ok, first reports come in:

Fridrich says: application icons are not updated on windows - can anyone verify?

Italo says: I know what happens only on the Mac, but the new icons work only for
ODF files while they do not show for other file formats - i.e. DOCs
and the likes - even if they are associated with LibreOffice.

Missed the boat for 3.3.1 though.
Comment 19 Alex Thurgood 2011-02-24 00:21:34 UTC
@Thorsten : aarrgghh !!! my bad, sorry, I was convinced I'd downloaded it from the prerel site :-/

Alex
Comment 20 Thorsten Behrens (CIB) 2011-03-03 02:00:13 UTC
*** Bug 34862 has been marked as a duplicate of this bug. ***
Comment 21 Thorsten Behrens (CIB) 2011-03-03 02:01:41 UTC
from bug 34862 - oxygen icon set needs a wholesale update, too (if visually acceptable).
Comment 22 Ed 2011-03-15 07:30:22 UTC
Another issue.

The Formula icon in the quick-start menu in the Linux version has a dark blue background which it shouldn't have.

On further testing I found that most of the issues I raised before are theme-defendant. All of them are an issue in at least one theme.
Comment 23 Rainer Bielefeld Retired 2011-03-27 23:47:07 UTC
*** Bug 35046 has been marked as a duplicate of this bug. ***
Comment 24 Rainer Bielefeld Retired 2011-03-27 23:53:41 UTC
*** Bug 35713 has been marked as a duplicate of this bug. ***
Comment 25 Rainer Bielefeld Retired 2011-03-27 23:57:21 UTC
Expecially theme "Oxygen" still urgently needs an update. 
We should get a more or less complete solution until 3.4?!

Bug 35046 - Quickstarter shows OpenOffice.org symbol when using Tango icon theme
now is a DUP of this one, I believe we should concentrate all discussion here!

@Thorsten, still your area?
Comment 26 Rainer Bielefeld Retired 2011-03-28 00:22:59 UTC
Created attachment 44928 [details]
Screenshots, See Comment 25

I did not check all themes and menus
Comment 27 Rainer Bielefeld Retired 2011-03-28 02:01:53 UTC
*** Bug 31608 has been marked as a duplicate of this bug. ***
Comment 28 Thorsten Behrens (CIB) 2011-03-30 02:03:30 UTC
@Rainer: yes, can have a go on this - question still pending, whether the various icon themes need adapted icons.

@Chris: any opinion on this? I'd otherwise just shove the icons in, and we deal with updated designs later?
Comment 29 bunkem 2011-03-30 08:06:16 UTC
I suggest that you wait until the set of icons for a theme is complete.  Then implement once.  This saves time and effort.

While I understand the need to get the icons updated and implemented, I know it is harder for the user if the icons change, then change again, and again.
Comment 30 Christoph 2011-03-30 12:52:36 UTC
@ Thorsten: It is unlikely that we'll provide optimized MIME type icons for the different icon styles (soon). We currently assume that "Tango" is the reference ... Galaxy being supported if possible. My take: Please go ahead with implementing them as far as it is _not_ about the 24/26px icons (e.g. for the toolbars). Here, we currently have drafts to be confirmed ...

@ Bernhard: Shall we use the latest designs by Paulo for 24px (Tango) and 26px (Galaxy)? I'd say "yes". See:
http://www.mail-archive.com/design@libreoffice.org/msg01260.html
Comment 31 Bernhard Dippold 2011-03-30 14:54:09 UTC
@Christoph: Paulo's icons are mature, they should be used. But they haven't got the hidden naming scheme Thorsten needs for his script. I'll update them and upload them to this issue.

@Thorsten: I agree with Christoph about the other themes.
Even if our icons don't fit Oxygen design principles very much, they are at least near to the quality of the present Oxygen icons. And by replacing them we (hopefully) solve the issue with OOo icons on the start center.

If you could address the other issues too, this would be great:
- replace the round icon with gulls in the options dialog (see Rainer's screenshot) in Galaxy and other themes
- replace the round favicon in the document pane, when the StartCenter is shown
- replace the round favicon in quickstarter (see https://bugs.freedesktop.org/show_bug.cgi?id=34847)
- replace OOo icon for printer setting in Ubuntu (desktop integration issue?) 

Thanks 
Bernhard
Comment 32 Bernhard Dippold 2011-03-30 14:56:03 UTC
Created attachment 45078 [details]
OOo icons in various places
Comment 33 Bernhard Dippold 2011-03-30 15:34:14 UTC
Created attachment 45079 [details]
SVG source of Tango and Galaxy style icons in intermediate size (26px)

Here are the 26px icons - I just added the named labels to the icons Paulo uploaded to the wiki: http://wiki.documentfoundation.org/File:Toolbar-Mimetype-Icons.svg

Both iconsets are 26x26 px, but the Tango icons show smaller icons (24x24) with more space around them.

Up to now we don't have HC icons - I don't know if they can be created during the next days.
Comment 34 Bernhard Dippold 2011-03-31 15:33:54 UTC
Created attachment 45113 [details]
In the web wizard StarOffice icons are used to indicate ODF files

If you create a website using the Web Wizard (File - Wizards - Web page ...), the icons used in the file list (ToC) for ODF files are StarOffice icons.

They are stored as .gif files in the /images folder below the main folder. 

They should be replaced by LibO icons.

If this task is too different from being included in this issue, please tell me to open a new one.

Bernhard
Comment 35 Thorsten Behrens (CIB) 2011-04-02 14:05:36 UTC
Aye. Let me see to get to this for 3.3.3 and 3.4
Comment 36 Bernhard Dippold 2011-04-05 12:20:40 UTC
Icons aren't distributed to Gnome icon folders to a larger scale than 48x48 pixel.

usr/share/icons/hicolor/48x48/apps contains libreoffice-.... icons
(while /48x48/apps/libreoffice-printeradmin.png is still an OOo icon), 
folders /128x128/apps/ or /256x256/apps/ don't contain any libreoffice icons.

As the larger icons are part of the provided graphical sources, they need to be distributed.

It seems that mimetype icons are not used in larger scale than 48x48, so we don't need to distribute them to the /128x128/mimetype/ and /256x256/mimetype folders. If this will be changed in future (Gnome 3?), we should keep this in mind...
Comment 37 Rainer Bielefeld Retired 2011-05-10 07:44:20 UTC
*** Bug 37070 has been marked as a duplicate of this bug. ***
Comment 38 Thorsten Behrens (CIB) 2011-05-17 05:47:09 UTC
Created attachment 46805 [details]
galaxy mimetype icons

Need to separate icon styles, for the cnvsvg.py script to work. Also updated/completed placeholder labels - please let's use this svg as the basis for further updates.
Comment 39 Thorsten Behrens (CIB) 2011-05-17 05:48:29 UTC
Created attachment 46806 [details]
tango mimetype icons

Split tango out, too, updated placeholder labels. Let's use this two svgs for further updates. Bernhard, please advise where/if to push to wiki, too.
Comment 40 Thorsten Behrens (CIB) 2011-05-17 08:28:43 UTC
toolbar mimetype icons just got pushed to -3-4.
Comment 41 Bernhard Dippold 2011-05-27 14:28:19 UTC
(In reply to comment #39)
> [... Galaxy and Tango Mimetype icons ...] Let's use this two svgs for
> further updates. Bernhard, please advise where/if to push to wiki, too.

Just upload them with a descriptive name and link it to the Gallery_Icons page:
http://wiki.documentfoundation.org/Gallery_Icons

The source is already at the wiki, as I told you in comment #33, but is linked at the gallery now.
Comment 42 Jean-Baptiste Faure 2011-05-28 22:40:58 UTC
Hi,

There is several OOo icons in options "chapters" (menu Tools > Options > first pages with text only) : LibreOffice, Writer, Writer/Web, Calc, Impress, Draw, Base, Math.

Best regards. JBF
Comment 43 Bernhard Dippold 2011-05-29 02:55:35 UTC
Created attachment 47264 [details]
Main icons in Tools - Options shows OOo seagulls (LibO 3.4.0RC2)

On Ubuntu Natty still wrong icons in Tools - Options with LibO 3.4.0RC2:

Tango: Main LibreOffice page (see screenshot)
Galaxy: Main, Writer, Writer/Web, Calc, Impress, Draw, Base
Oxygen: Main

Same problem as mentioned in attachment 44928 [details].

Jean-Baptiste: What's your OS and Icon Style (Tools - Options - View)?
Comment 44 Jean-Baptiste Faure 2011-05-29 03:23:30 UTC
(In reply to comment #43)
> [...]
> Jean-Baptiste: What's your OS and Icon Style (Tools - Options - View)?

Ubuntu 10.04 x86_64
Icon Style : Galaxy (yes I know, I am from old school ;-) )
Comment 45 Thorsten Behrens (CIB) 2011-05-29 05:35:00 UTC
Bernhard: ah whoops, sorry, misunderstood your earlier comment on that - indeed, the main options icon is unfixed. As per your screenshot from comment #32, can you confirm that's all fixed?

It would then be good to hunt down all remaining icons, list them in a new comment entry (bug starts to become slightly unwieldy), and propose replacement artwork (if not obvious, as for the tools->options case).
Comment 46 Bernhard Dippold 2011-05-29 07:40:12 UTC
@Thorsten:
Sorry, I can't test the appearances from comment 32 anymore:
- on Ubuntu 11.04 there is no hierarchical menu containing the different LibreOffice icons including the printer option.
- I can't activate Quickstarter in RC2 (even with unstable features activated there is no selection in Tools - Options - General - Memory.

For Tools - Options icons: It's not only the main icon in all the themes, but all the sub-application icons in Galaxy. 

Today and tomorrow I don't have the time to dig deeper in this topic, but I'll try to during the next days...
Comment 47 Andras Timar 2011-06-01 02:32:41 UTC
(In reply to comment #46)
> Today and tomorrow I don't have the time to dig deeper in this topic, but I'll
> try to during the next days...

Please use a fresh build from the libreoffice-3-4 branch. Last update of artwork was yesterday. I believe that all issues listed above are fixed now but please double check. Thanks.
Comment 48 Andras Timar 2011-06-22 23:38:33 UTC
*** Bug 38582 has been marked as a duplicate of this bug. ***
Comment 49 Rainer Bielefeld Retired 2011-12-02 08:11:32 UTC
Is this very general bug really still required? IMHO we should close it.
Comment 50 Thorsten Behrens (CIB) 2011-12-02 08:31:49 UTC
well, according to Andras it should all be fixed - let's close this for now, and have (potentially) remaining issues dealt with indepedently.