Bug Hunting Session
Bug 36301 - Crash on exit from LibreOffice
Summary: Crash on exit from LibreOffice
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.0 Beta2
Hardware: x86 (IA32) Windows (All)
: medium blocker
Assignee: Don't use this account, use tml@iki.fi
URL:
Whiteboard:
Keywords:
: 36454 36487 36500 36509 36532 36585 36645 (view as bug list)
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-04-16 06:43 UTC by Carl F
Modified: 2014-05-23 03:15 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carl F 2011-04-16 06:43:31 UTC
APPCRASH
  Application Name:	soffice.bin
  Application Version:	3.4.1.500
  Application Timestamp:	4da4974b
  Fault Module Name:	configmgr.uno.dll
  Fault Module Version:	3.4.1.500
  Fault Module Timestamp:	4da996c1
  Exception Code:	c0000005
  Exception Offset:	00006546
  OS Version:	6.1.7601.2.1.0.256.48
  Locale ID:	1033
  Additional Information 1:	0a9e
  Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:	0a9e
  Additional Information 4:	0a9e372d3b4ad19135b953a78882e789
Comment 1 Carl F 2011-04-16 06:55:46 UTC
DEV300m103.
Can not optionally save any file and mandatory save does not work.
On exit, always crashes with referenced error
Comment 2 Kohei Yoshida 2011-04-18 18:17:06 UTC
Q1. What were you doing when the application crashed?

Q2. Can you give us step-by-step instructions on how to reproduce the crash?

Q3. What produced this crash output?  I'm not familiar with this format.

Thanks.
Comment 3 Don't use this account, use tml@iki.fi 2011-04-19 03:21:41 UTC
I see the problem too in a fresh build of the 3.4 branch. Carl F: no need to give any more information. For the future, not that the "APPCRASH" information you included is fairly useless for debugging, at least at this stage of our build and debugging process.

The problem in saving ODF formats (and possibly others) is a different one, and that has been fixed already (bug #36263).

Re-titling as there really aren't any different LibreOffice "apps". It's all one same soffice.bin process regardless of what Writer, Calc, Impress etc windows one happens to have open.

I don't see why BASIC would be related, setting component to just "Libreoffice".
Comment 4 Carl F 2011-04-19 05:37:56 UTC
The listed information is the auto windows dump that occurs when the crash occurs.

The crash occurs every time I save a file or exit the program.
The sequence after installation is:
1) open the program  e.g. writer
2) close the program
3) The crash occurs

the second sequence is:
1) open the program  e.g. writer
2) save the file
3) the crash occurs
Comment 5 Carl F 2011-04-19 06:15:22 UTC
(In reply to comment #1)
> DEV300m103.
> Can not optionally save any file and mandatory save does not work.
> On exit, always crashes with referenced error

An error window appears with the following information:
Error saving the document Untitled1:
General Error
General input/output error

Then get the windows error "LibreOffice 3.4 has stopped working"


Using Windows 7 SP1  64bit
LibreOffice 3.4.0
DEV300m103 (Build:1)
Comment 6 Don't use this account, use tml@iki.fi 2011-04-19 06:45:24 UTC
Please, no need to add any more information now that is just potentially confusing and related to other problems; I am on to the crash and debugging it and contemplating how to fix it. Anything that gives an error dialog with "General Error" etc is somn different thing, most likely caused by the already fixed Zip archive handling bug.
Comment 7 Zack 2011-04-20 10:51:31 UTC
I was experiencing this problem when using the workaround to get swriter.exe to run, but I'm not experiencing any problems with crashing on exit with the Beta 2.
Comment 8 Don't use this account, use tml@iki.fi 2011-04-21 02:03:04 UTC
*** Bug 36454 has been marked as a duplicate of this bug. ***
Comment 9 Don't use this account, use tml@iki.fi 2011-04-21 02:04:01 UTC
Zack, it does happen in beta2 too, trust me.
Comment 10 Don't use this account, use tml@iki.fi 2011-04-22 06:29:44 UTC
*** Bug 36487 has been marked as a duplicate of this bug. ***
Comment 11 Zack 2011-04-22 11:53:02 UTC
(In reply to comment #9)
> Zack, it does happen in beta2 too, trust me.
Yep, you're right.  I'm experiencing it on my laptop now.

Windows Vista SP2 32 bit.
Comment 12 Zack 2011-04-22 11:53:44 UTC
*** Bug 36500 has been marked as a duplicate of this bug. ***
Comment 13 Volker Merschmann 2011-04-22 14:09:30 UTC
*** Bug 36509 has been marked as a duplicate of this bug. ***
Comment 14 Don't use this account, use tml@iki.fi 2011-04-23 13:18:59 UTC
*** Bug 36532 has been marked as a duplicate of this bug. ***
Comment 15 manj_k 2011-04-25 08:34:56 UTC
*** Bug 36585 has been marked as a duplicate of this bug. ***
Comment 16 Don't use this account, use tml@iki.fi 2011-04-26 10:36:15 UTC
Fixed in what I would say is an extremely unclean manner in the 3.4 branch now. I hate to call it a "fix", but it makes the problem go away, so whatever...
Comment 17 Allen 2011-04-26 10:49:28 UTC
(In reply to comment #16)
> Fixed in what I would say is an extremely unclean manner in the 3.4 branch now.
> I hate to call it a "fix", but it makes the problem go away, so whatever...

Hi Tor, is this fix going to make it into v3.4 Beta 3?
Comment 18 Don't use this account, use tml@iki.fi 2011-04-26 11:06:52 UTC
Yes.
Comment 19 Zack 2011-04-27 15:41:35 UTC
*** Bug 36645 has been marked as a duplicate of this bug. ***
Comment 20 Claude 2011-06-04 14:14:15 UTC
(Originally #36532 which was marked as duplicate of 36301) The bug was fixed.  Nevertheless there is still some unusual behavior, which made till 3.4.0
When the option "Load Libre Office during system startup" is checked, at startup quickstarter loads, opens its screen and stays displayed on screen.  It does not disappear, although it installs itself in the tray bar.  You have to turn it off manually, to remove it from the desktop.  Not big deal, but that didn´t happen before this bug came up.
The same happens with XPSP3 and Vista Home Premium.
Claude
Comment 21 vitriol 2011-06-04 14:27:31 UTC
@Claude
See Bug 37110. I think not related to this bug.