Download it now!
Bug 40571 - UI EDITING Crash when modifying defined name
Summary: UI EDITING Crash when modifying defined name
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: All All
: high critical
Assignee: Markus Mohrhard
URL:
Whiteboard: target:3.4.4
Keywords: regression
: 40909 41382 41594 41676 42256 42323 42513 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-01 17:05 UTC by Bruce Leary
Modified: 2014-09-24 05:45 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
Simple spreadsheet to use to illustrate crash bug (7.79 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-09-01 17:05 UTC, Bruce Leary
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bruce Leary 2011-09-01 17:05:39 UTC
Created attachment 50833 [details]
Simple spreadsheet to use to illustrate crash bug

1) Insert-Names-Defined (Ctrl-F3)
2) Click on any name
3) Without making any change, click Modify.

CRASH

I found this bug while trying to create a simple spreadsheet that illustrates a much more serious bug; namely 3.4.3 is unable to use a named formula after the sheet is reloaded.  If you delete the named formula and add it back again then it is usable again until the sheet is saved and closed.  I have a complex sheet that has this problem and have not yet been able to create a simple failure case.  This was not a problem in 3.4.2.
Comment 1 digital ant 2011-09-02 16:53:58 UTC
confirmed in LibO 3.4.3, OSX 10.6.8, EN US
Comment 2 gibi 2011-09-04 02:23:17 UTC
Confirmed with 3.4.3 Linux X64
 
=> modifying Platform to All/All

Please note that the crash occurs even if you modify the value of the range before clicking on [OK] or [Modify].

Some time I get a 100% CPU rather than a crash when working on an already saved document. On a new one, it's always a crash.
Comment 3 vitriol 2011-09-04 02:42:23 UTC
Nominated as most annoying bug.
Comment 4 Markus Mohrhard 2011-09-04 02:49:54 UTC
I'll have a look at it.
Comment 5 Katarina Behrens 2011-09-04 06:10:58 UTC
Doesn't crash w/ master anymore (not that it would matter, but wanna test my changed e-mail address :))
Comment 6 Eike Rathke 2011-09-05 16:45:14 UTC
Cherry-picking http://cgit.freedesktop.org/libreoffice/core/commit/?id=792dee46f2b35a21167af182416803c0b80b517c from master should fix this.
Comment 7 Markus Mohrhard 2011-09-05 18:18:42 UTC
Eike's patch solves the problem. Pushed to 3-4.

http://cgit.freedesktop.org/libreoffice/calc/commit/?h=libreoffice-3-4&id=3eea3945e2457667a4e16d93bd2dec4ffaa88011
Comment 8 vitriol 2011-10-01 07:52:36 UTC
*** Bug 41382 has been marked as a duplicate of this bug. ***
Comment 9 vitriol 2011-10-08 12:05:49 UTC
*** Bug 41594 has been marked as a duplicate of this bug. ***
Comment 10 vitriol 2011-10-11 05:03:46 UTC
*** Bug 41676 has been marked as a duplicate of this bug. ***
Comment 11 GerardF 2011-10-26 09:18:28 UTC
*** Bug 42256 has been marked as a duplicate of this bug. ***
Comment 12 Markus Mohrhard 2011-10-27 14:57:08 UTC
*** Bug 42323 has been marked as a duplicate of this bug. ***
Comment 13 vitriol 2011-11-02 08:16:48 UTC
*** Bug 42513 has been marked as a duplicate of this bug. ***
Comment 14 Stephan Zietsman 2011-11-06 23:52:21 UTC
*** Bug 40909 has been marked as a duplicate of this bug. ***
Comment 15 Viktor Mileikovskyi 2011-11-11 02:54:50 UTC
For me fixed in 3.4.4 (RC2). Many thanks!