Bug Hunting Session
Bug 62561 - FORMATTING / UI: Add "Remove hyperlink" to (context) menu in Calc
Summary: FORMATTING / UI: Add "Remove hyperlink" to (context) menu in Calc
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: low enhancement
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard: target:6.4.0
Keywords:
: 102911 113840 120373 (view as bug list)
Depends on:
Blocks: Context-Menu Unify-Across-Apps Hyperlink-Dialog Hyperlink-Calc 120373
  Show dependency treegraph
 
Reported: 2013-03-20 15:48 UTC by Peter
Modified: 2019-08-12 09:13 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter 2013-03-20 15:48:24 UTC
In version 3 of calc, you could remove all the hyperlinks from a range of cells by selecting the cells and choosing "Clear Direct Formatting."  That does not work in version 4.  I see that https://bugs.freedesktop.org/show_bug.cgi?id=33604 reports this is not a bug for Writer in version 3.3 and is two years old.  The equivalent functionality was available in Calc at that time.

If this feature has been intentionally removed from Calc, do you expect us to edit each individual cell separately to remove that cell's link?  That would be absurd.  If you choose to mark this "notabug," I will have to revert back to version 3.

I realize that I can use cut + paste special/text to do this, but some of the cells may have numbers or formulas.  Personally I would prefer an explicit "Remove Hyperlink" option in the menus instead of "Clear Direct Formatting."
Comment 1 Cor Nouws 2013-04-23 10:45:06 UTC
Hi Peter,
Could you pls check in 4.0.2? I can just select more cells there with links, hit Ctrl+M and all links are removed...
Thanks,
Comment 2 ign_christian 2013-05-13 03:10:30 UTC
Both Ctrl-M & "Clear Direct Formatting" work on LO 4.0.3.3 (Win7 Home Premium 32bit)

Mark as 'enhancement' because of request to have "Remove Hyperlink" option in menu.
Comment 3 Thomas Lendo 2017-09-06 20:42:32 UTC
For the sake of usability, I suggest to reuse the context menu entries of Writer and duplicate it for Calc:
* Open Hyperlink
* Edit Hyperlink...
* Copy Hyperlinks Location
* Remove Hyperlink
Comment 4 Thomas Lendo 2017-09-06 21:24:02 UTC
*** Bug 102911 has been marked as a duplicate of this bug. ***
Comment 5 roland 2017-10-13 10:10:22 UTC
This bug is still in LO 5.3.1.2 (Ubuntu 17.04) and has been around for a really long time.

Ctrl+M does not do what it's supposed to do and the link remains in the cell.
Comment 6 andreas_k 2018-09-05 17:43:09 UTC
Hi the issue is that add the context menu entries from writer to calc (cell.xml and celledit.xml) the entries wasn't shown.

  <menu:menuitem menu:id=".uno:OpenHyperlinkOnCursor"/>
  <menu:menuitem menu:id=".uno:EditHyperlink"/>
  <menu:menuitem menu:id=".uno:CopyHyperlinkLocation"/>
  <menu:menuitem menu:id=".uno:RemoveHyperlink"/>
  <menu:menuitem menu:id=".uno:OpenSmartTagMenuOnCursor"/>
  <menu:menuitem menu:id=".uno:ThesaurusFromContext"/>

So there are two options from my point of view:

1. make the editHyperlink, ... actions working in calc
2. use clear direct formating

I prefer option 1 cause RemoveHyperlink and some other commands are ONLY available in context menu (which is fine) and option 2 is always possible.

So if someone fix the coding part, I'll add the Hyperlink stuff from writer.
Comment 7 Timur 2018-10-10 15:27:16 UTC
*** Bug 120373 has been marked as a duplicate of this bug. ***
Comment 8 Heiko Tietze 2018-10-12 09:39:07 UTC Comment hidden (obsolete)
Comment 9 Eyal Rozenberg 2018-10-12 19:07:12 UTC
Please take a few moments to read the opening comment(s) in bug 120373, which is not an exact dupe of this one but just "close enough"; it's perspective is somewhat wider.
Comment 10 Cor Nouws 2018-10-13 09:16:54 UTC Comment hidden (obsolete)
Comment 11 Cor Nouws 2018-10-13 09:17:30 UTC
(In reply to Cor Nouws from comment #10)

> Indeed. If you don't know that Ctrl+M does the trick, you're lost..

(and that also clears formatting that you may not want to be removed)
Comment 12 andreas_k 2019-01-28 22:06:52 UTC
The command RemoveHyperlink is only available in sw apps cause the uno command is defined in WriterCommands.xcu so the Hyperlink uno commands has to be moved to generic first and can than be used in the calc context menu.
Comment 13 Commit Notification 2019-07-15 09:33:24 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/040f348ee00a0d01653b3071be3d9886a08f87fe%5E%21

tdf#62561 Add remove/edit hyperlink to calc context menu

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Samuel Mehrbrodt (CIB) 2019-08-12 09:13:03 UTC
*** Bug 113840 has been marked as a duplicate of this bug. ***