Bug 68695 - EDITING: Comments cannot be resized while editing - missing squares around the comment/note
Summary: EDITING: Comments cannot be resized while editing - missing squares around th...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected) release
Hardware: All All
: high minor
Assignee: Not Assigned
Keywords: bibisected, bisected, regression
: 83065 90123 93852 103887 108451 119763 133255 133696 141150 143492 148804 155642 (view as bug list)
Depends on:
Blocks: Calc-Comments
  Show dependency treegraph
Reported: 2013-08-29 07:50 UTC by Peter Draganov
Modified: 2023-07-01 13:46 UTC (History)
28 users (show)

See Also:
Crash report or crash signature:

This is how it looks like - no squares at corners and centers of edges (54.00 KB, image/jpeg)
2013-08-29 14:20 UTC, Peter Draganov
test document - comment is in the first cell (7.40 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-12-09 11:53 UTC, Peter Draganov
Screenshots which show how small the comment box is and how complicated it is to resize it (358.31 KB, image/png)
2020-06-06 10:41 UTC, Daniel
Comment overflowing its box when Print Screen is pressed (Ubuntu 20) (61.30 KB, image/png)
2020-09-17 07:08 UTC, Dan Dascalescu
Right clicking on a cell briefly displays it in its entirety (299.26 KB, image/gif)
2020-09-17 07:10 UTC, Dan Dascalescu
Sample spreadsheet with one cell with one comment (15.05 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-09-17 07:12 UTC, Dan Dascalescu

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Draganov 2013-08-29 07:50:30 UTC
It is the same with Windows version
Comment 1 tommy27 2013-08-29 13:01:02 UTC Comment hidden (obsolete)
Comment 2 Peter Draganov 2013-08-29 14:20:46 UTC
Created attachment 84845 [details]
This is how it looks like - no squares at corners and centers of edges

Mouse cursor is not changed to arrows at edges and comment cannot be resized
Comment 3 tommy27 2013-08-30 09:53:29 UTC
Ok, now I understand and I can reproduce.

in 4.0.4 the "resize" corners are visible immediately after you create a new comment... so you can resize it while editing.

in 4.1.0 those "resize" corners are invisible till you save the comment (press enter) and then reopen it again (right click menu -> show comment) and click on it. so basically you cannot resize while editing.

adding REGRESSION keyword and Calc expert to CC list.
modified summary notes as well.
Comment 4 trevor.jenkins 2013-09-12 08:18:28 UTC
Same on Mac OS X with version
Comment 5 Grobe 2013-10-15 18:38:10 UTC
The bug is still present in LibO version (Windows XP SP3)

A short video clip shows that "nothing happens" when trying to resize the comment box.
Not possible to tell when mouse buttons is clicked on thougth.
Comment 6 David 2013-12-08 11:10:15 UTC Comment hidden (obsolete)
Comment 7 retired 2013-12-09 11:23:47 UTC Comment hidden (obsolete)
Comment 8 Peter Draganov 2013-12-09 11:53:35 UTC
Created attachment 90506 [details]
test document - comment is in the first cell
Comment 9 Peter Draganov 2013-12-09 11:54:37 UTC
The problem is since version 4.1
Comment 10 Bug Reports 2014-02-05 12:44:39 UTC
the problem still exists in 4.2
Comment 11 RNL 2014-03-05 17:20:47 UTC
I confirm Comment 5 in version Drives me insane! I run Win 7 Ultimate,  64-bit.
Comment 12 Peter Draganov 2014-03-05 17:33:01 UTC Comment hidden (no-value)
Comment 13 David 2014-03-06 14:14:15 UTC Comment hidden (obsolete)
Comment 14 tommy27 2014-03-07 05:43:06 UTC Comment hidden (obsolete)
Comment 15 David 2014-03-14 12:32:13 UTC Comment hidden (obsolete)
Comment 16 Bug Reports 2014-03-14 12:58:22 UTC
(In reply to comment #15)
> I have discovered that in the Linux versio (have not yet tried Windows) If
> you select the cell, right click and Select "Show Comment" from the pull
> down menu, then click in the comment area the box points are displayed and
> the box resized. If the points are not displayed try clicking on the
> border. You can then right click on the selected cell and choose "hide
> comment"

Thats right, but that are a way too much clicks if you are using comments a lot.
Even it worked in a former version.
Comment 17 m.loikasek 2014-11-10 16:42:34 UTC
Build-ID: 62ad5818884a2fc2e5780dd45466868d41009ec0

Bug still exists. 
When you right click on the cell with the comment and select view comment then you can resize it. But in an older version you could resize the comment while editing it. This is way more comfortable and you would expect it to work that way. If I hadn't searched for it in bugzilla I would never thought of the option to view the comment and then to resize it. 
Please change that back so you can resize a comment while editing.
Comment 18 e 2015-01-02 16:36:55 UTC Comment hidden (me-too)
Comment 19 raal 2015-03-20 08:58:50 UTC
*** Bug 90123 has been marked as a duplicate of this bug. ***
Comment 20 dm04 2015-03-20 09:45:42 UTC Comment hidden (me-too)
Comment 21 Larry Bradley 2015-08-31 00:03:17 UTC Comment hidden (obsolete)
Comment 22 Larry Bradley 2015-08-31 00:07:23 UTC Comment hidden (me-too)
Comment 23 raal 2015-09-12 06:17:42 UTC Comment hidden (obsolete)
Comment 24 raal 2015-09-12 06:17:52 UTC
*** Bug 93852 has been marked as a duplicate of this bug. ***
Comment 25 web_libreoffice 2015-11-16 12:30:40 UTC Comment hidden (me-too)
Comment 26 Robinson Tryon (qubit) 2015-12-14 05:32:39 UTC Comment hidden (obsolete)
Comment 27 David 2016-02-12 00:22:39 UTC Comment hidden (me-too)
Comment 28 Peter Draganov 2016-02-12 06:32:53 UTC
As you can see in Comment 3, 4.0.4 was OK.
Comment 29 Xisco Faulí 2016-10-06 13:36:18 UTC
Regression introduced by

author	Armin Le Grand <alg@apache.org>	2013-05-02 16:29:07 (GMT)
committer	Caolán McNamara <caolanm@redhat.com>	2013-05-10 11:08:40 (GMT)
commit 54a1feb9b9bd654774b9aa60cda7ef9a1cd11064 (patch)
tree 2aefd9d1d8e0970f06d3623ea08c1b2734ee1285
parent a356da4e2adefd86d6f802c0753b3718909e4e4c (diff)

Resolves: #i122142# use simple text hilight frames
use simple text hilight frame when captions are in TextEdit mode

(cherry picked from commit bdcd01c39324f5c74e0f696f2afc3449243e6c4b)


Adding Cc: to Armin Le Grand
Comment 30 Armin Le Grand 2016-10-07 08:37:46 UTC
As https://bz.apache.org/ooo/show_bug.cgi?id=122142 explains it was an error to show the handles in captions when edit was active. To change this, bigger changes would have to be done on EditEngine (due to it painting directly and thus uncontrolled to the edit views). Reactivating this would lead to awful paint errors.
Problem is more that comments at cells do not behave like the rest of draw objects: Normally pressing ESC leaves the edit mode, but keeps the object selected, pressing RETURN re-activates TextEdit.
Thus I see more a problem in that SC immediately hides the caption when in edit mode and pressing ESC -> this should lead to the object being selected, the next ESC should hide it.
Comment 31 Buovjaga 2016-11-24 08:42:42 UTC
*** Bug 103887 has been marked as a duplicate of this bug. ***
Comment 32 Buovjaga 2017-02-24 17:46:35 UTC
*** Bug 83065 has been marked as a duplicate of this bug. ***
Comment 33 Yousuf Philips (jay) (retired) 2017-06-10 23:53:27 UTC
*** Bug 108451 has been marked as a duplicate of this bug. ***
Comment 34 QA Administrators 2018-06-11 02:34:14 UTC Comment hidden (obsolete)
Comment 35 Peter Draganov 2018-06-11 06:38:59 UTC Comment hidden (me-too)
Comment 36 Telesto 2018-09-09 09:11:27 UTC
*** Bug 119763 has been marked as a duplicate of this bug. ***
Comment 37 David 2018-09-09 16:59:20 UTC Comment hidden (obsolete)
Comment 38 David 2018-09-09 17:48:06 UTC Comment hidden (obsolete)
Comment 39 QA Administrators 2019-12-10 04:05:40 UTC Comment hidden (obsolete)
Comment 40 David 2019-12-10 06:20:05 UTC Comment hidden (obsolete)
Comment 41 David 2019-12-10 06:36:28 UTC Comment hidden (obsolete)
Comment 42 David 2019-12-10 06:57:28 UTC Comment hidden (obsolete)
Comment 43 Peter Draganov 2019-12-10 08:49:28 UTC Comment hidden (me-too)
Comment 44 Xisco Faulí 2020-05-22 10:34:08 UTC
*** Bug 133255 has been marked as a duplicate of this bug. ***
Comment 45 joe 2020-05-23 01:52:12 UTC Comment hidden (me-too)
Comment 46 steve 2020-06-04 23:29:48 UTC Comment hidden (me-too)
Comment 47 David 2020-06-05 03:58:00 UTC Comment hidden (me-too)
Comment 48 David 2020-06-05 04:07:49 UTC Comment hidden (obsolete)
Comment 49 David 2020-06-05 05:00:53 UTC Comment hidden (obsolete)
Comment 50 Tomaz Vajngerl 2020-06-05 07:09:37 UTC Comment hidden (obsolete)
Comment 51 David 2020-06-05 07:42:31 UTC Comment hidden (obsolete)
Comment 52 Telesto 2020-06-05 08:12:38 UTC Comment hidden (obsolete)
Comment 53 Timur 2020-06-05 08:53:47 UTC
(In reply to steve -_- from comment #46)
> in 7.0b1 the problem exists also after the comment was created or the > document re-opened. I can't find any way to resize the comment. 
7.1+ : cannot resize while editing, but possible with Show Comment. 
SO not cleat what's the exact change you refer to.

(In reply to David from comment #47)
> Confirmed, someone has mucked with this component in 7.0b1 and made it to
> where comment (and other related components) resizing that was a buggy
> two-step process is now *BROKEN* and not possible.  
If there was a change, just write exact new behavior, instead of additional talk .

(In reply to Telesto from comment #52)
> Please create a new bug report..
No need to make too many reports on the *same* issue of resizing comments.
New report is for different issue, not the same issue that changed behavior.

So far this is Minor severity but High importance for being regression with many CCed users and duplicates.
Comment 54 David 2020-06-05 09:08:16 UTC Comment hidden (obsolete)
Comment 55 David 2020-06-05 09:09:08 UTC Comment hidden (obsolete)
Comment 56 David 2020-06-05 09:14:57 UTC
This "Show Comments" workaround stopped working, and no other workaround has been found on since the following:

Version: (x64)
Build ID: 94f789cbb33335b4a511c319542c7bdc31ff3b3c
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL

(Updated build info since bug changed.)
Comment 57 David 2020-06-05 09:34:11 UTC
*** Bug 133696 has been marked as a duplicate of this bug. ***
Comment 58 Timur 2020-06-05 12:16:55 UTC
I don't see that Show Comment stopped working and don't understand what changed. 
Needed are exact steps, better with screenshot with comments or Screencast.
Comment 59 Daniel 2020-06-06 10:41:32 UTC
Created attachment 161677 [details]
Screenshots which show how small the comment box is and how complicated it is to resize it

I copied over my attachment from bug #119763 which describes exactly the same problem. Read there (not much text) if you want to know more
Comment 60 steve 2020-06-06 11:01:23 UTC
Retested, macOS 10.15.5


* open calc
* add comment and keep writing until the writing goes beyond the space of the default comment size


Writing continues outside of the comment box.


Comment box should grow as users keep typing their comment and the comment exceeds the default comment box size.

With 7.0b1 I no longer see the problem, that even with View > Comments the handles to resize an existing comment do not exist. They did show as expected in this second test. I will watch this and send an update if they go missing again for existing comments.

So this is indeed the behavior described in the original report and no additional bad behavior is happening now.
Comment 61 Dan Dascalescu 2020-09-17 07:08:18 UTC Comment hidden (off-topic)
Comment 62 Dan Dascalescu 2020-09-17 07:10:30 UTC Comment hidden (off-topic)
Comment 63 Dan Dascalescu 2020-09-17 07:12:07 UTC Comment hidden (off-topic)
Comment 64 Xisco Faulí 2020-11-18 12:06:56 UTC Comment hidden (off-topic)
Comment 65 Timur 2021-03-22 17:05:17 UTC
*** Bug 141150 has been marked as a duplicate of this bug. ***
Comment 66 Timur 2021-07-22 14:00:47 UTC
*** Bug 143492 has been marked as a duplicate of this bug. ***
Comment 67 Armin Le Grand 2022-01-05 10:04:00 UTC
This commit was developed for another code base, and not merged by me. For complex changes like this, side-effects are to be expected; sadly I dont't have the cycles to deal with all the fallout. Un-Ccing myself for the while.
Comment 68 Jean-Baptiste Faure 2022-02-03 16:56:12 UTC Comment hidden (obsolete)
Comment 69 Timur 2022-02-04 11:22:57 UTC
No, this cannot be closed. Because bug is valid and there are many users who need it fixed. How to fix is another issue, wait for someone or make it into a tender bundle.
Comment 70 Jean-Baptiste Faure 2022-02-04 15:57:03 UTC
(In reply to Timur from comment #69)
> No, this cannot be closed. Because bug is valid and there are many users who
> need it fixed. How to fix is another issue, wait for someone or make it into
> a tender bundle.

WontFix does not mean the bug is not valid.
Since the bug has been reported the situation has changed due to the fix of bug 114956 and the need to be able to resize a comment while editing is now less strong than it was.
According the comments #30 and #67 from Armin Le Grand whose advice about the code should be listened to, the code modifications needed to restore previous behavior is risky and prone to weird side effects.

So I think closing this bug report as WontFix would be a prudent decision.

Best regards. JBF
Comment 71 larrybradley 2022-02-04 21:11:05 UTC Comment hidden (no-value)
Comment 72 David 2022-02-04 21:37:02 UTC Comment hidden (me-too)
Comment 73 larrybradley 2022-02-04 21:59:59 UTC Comment hidden (no-value)
Comment 74 Jeff Fortin Tam 2022-02-04 22:30:53 UTC Comment hidden (me-too)
Comment 75 David 2022-02-05 01:05:45 UTC Comment hidden (me-too)
Comment 76 larrybradley 2022-02-05 01:40:58 UTC
(In reply to David from comment #75)
> (In reply to Jean-François Fortin Tam from comment #74)
> > Then would it make more sense to un-duplicate and reopen bug #68695 then,
> > which talks about a specific usability/efficiency problem with the current
> > UI/UX specifically when creating a new comment in a cell?
> I, as one of the earlier submitters would agree that is a good course of
> action. This used to work properly until a change committed in version
>  And though, as earlier poster stated, it may only seem to
> be one extra step, but if you have to work with calc sheets with comments a
> lot (like I do), those extra steps require you to stop what you're doing an
> use the work-around, which shouldn't have to be done and we didn't have to
> do in OpenOffice or the earlier LibreOffice versions.

Understood. Who makes the final call on this? I look forward to the resolution. You guys do good work. Thanks.
Comment 77 Timur 2022-04-26 19:46:31 UTC
*** Bug 148804 has been marked as a duplicate of this bug. ***
Comment 78 jim walker 2023-02-25 18:33:43 UTC Comment hidden (me-too)
Comment 79 joe 2023-02-25 19:50:58 UTC Comment hidden (me-too)
Comment 80 Commit Notification 2023-06-23 18:45:48 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":


related tdf#68695 tdf#141136 sc: comment can't resize; avoid context change

It will be available in 24.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:

Affected users are encouraged to test the fix and report feedback.
Comment 81 Justin L 2023-06-23 20:36:19 UTC
comment 81 removes the OOo code that enabled comment resizing on insert. So it is a good code pointer, but needs to be re-worked as per comment 30.

In no way is comment 81 expected to fix this bug report. I only included the number because of the close affiliation with OP's report.
Comment 82 Stéphane Guillou (stragu) 2023-07-01 13:46:58 UTC
*** Bug 155642 has been marked as a duplicate of this bug. ***