Bug 78503 - EDITING: Some cells overlap the cell to the left when Calc option "Use printer metrics for text formatting" is enable.
Summary: EDITING: Some cells overlap the cell to the left when Calc option "Use printe...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.1 rc
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 88593 89208 89474 90091 90615 90952 90984 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-09 22:17 UTC by m.a.riosv
Modified: 2018-02-26 11:31 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file to test (28.18 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-05-09 22:17 UTC, m.a.riosv
Details
How it looks for me. (7.94 KB, image/png)
2014-05-13 15:01 UTC, Jacques Guilleron
Details
Configuration file with the ussue. (deleted)
2014-05-13 17:09 UTC, m.a.riosv
Details
How it looks for me with the issue. (11.75 KB, image/png)
2014-05-13 17:11 UTC, m.a.riosv
Details
Sample file to test (24.03 KB, application/xml)
2014-06-09 12:08 UTC, m.a.riosv
Details
How it looks for me (151.13 KB, image/png)
2015-01-23 15:33 UTC, matti.haveri
Details
Sample file (17.14 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-01-23 15:34 UTC, matti.haveri
Details
How it looks for me (167.28 KB, image/png)
2015-01-23 15:46 UTC, matti.haveri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description m.a.riosv 2014-05-09 22:17:12 UTC
Created attachment 98785 [details]
Sample file to test

Win7x64Ultimate
Version: 4.2.3.3 Build ID: 882f8a0a489bc99a9e60c7905a60226254cb6ff0
Version: 4.2.5.0.0+ Build ID: 948728a4159a8ba74ecc663373d31f1840fed9ac
  TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-05-09_01:06:23

Last working:
Version: 4.2.2.1 Build ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f

In the attached file, when value doesn't keeps in O3 the ##### are showed mixed with value showed in cell N3
Comment 1 Jacques Guilleron 2014-05-13 15:00:09 UTC
Hello Miguel Angel,

I don't reproduce with LO 4.2.4.1, LO 4.3.0.0.alpha1+
Build ID: 657004ae5c9f4a07b2cdafbb21bc8657842d4d74
TinderBox: Win-x86@39, Branch:master, Time: 2014-05-08_00:35:12
& Windows 7 Home Premium

I join a screenshot.

regard,

Jacques
Comment 2 Jacques Guilleron 2014-05-13 15:01:41 UTC
Created attachment 98983 [details]
How it looks for me.
Comment 3 m.a.riosv 2014-05-13 17:09:26 UTC
Created attachment 98987 [details]
Configuration file with the ussue.
Comment 4 m.a.riosv 2014-05-13 17:11:59 UTC
Created attachment 98988 [details]
How it looks for me with the issue.

Hi Jacques, thanks for review.

I have forgot to try with a clean profile, what solve the issue, that is in the registrymodifications.xcu attached. I haven't the tools to find what in the configuration file is the source of the issue. But will be nice to find it, there are sometimes issues when updating with the user profile.
Comment 5 m.a.riosv 2014-06-09 12:08:11 UTC
Created attachment 100730 [details]
Sample file to test

I think I have found where to begin the search.

When the option for calc:
Menu/Tools/Options/LibreOffice cal/General - Use printer metrics for text formatting
is enable shows the issue, if disable not.
Visible how E1 overlaps D1, and I1 overlaps H1.

But even without it enable, I think it's not fine how those cells are shown partially.

Reproducible with a clean user profile:
Version: 4.2.5.1 Build ID: 881bb88abfe2992c6cede97c23e64a9885de87de
Version: 4.2.6.0.0+Win-x86@42, Branch:libreoffice-4-2, Time: 2014-06-04_14:23:07
Version: 4.3.0.0.beta2 Id. compilation: a06aa316117a6ff0f05c697c82831c227812d810
Version: 4.4.0.0.alpha0+Win-x86@39, Branch:master, Time: 2014-06-04_04:27:18

Last version working for me:
Version: 4.2.4.2 Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8
Comment 6 ign_christian 2014-08-08 07:27:18 UTC
(In reply to comment #5)
> Created attachment 100730 [details]
> Sample file to test
I can reproduce with that file with 4.3.1.0.0+ Time: 2014-07-30_10:54:10 under Ubuntu 12.04 x86

This bug is quite strange. I also have similar but different issue in Bug 66089
Comment 7 m.a.riosv 2015-01-20 21:05:53 UTC
*** Bug 88593 has been marked as a duplicate of this bug. ***
Comment 8 matti.haveri 2015-01-23 15:31:49 UTC
This might be the same bug as 88593 although in my case only certain column widths produce it. The numbers are displayed correctly with some bigger _or_ smaller column widths.

I don't mind if the numbers are obscured with ## characters in too narrow columns but in my case I got totally incorrect values when LibreOffice 4.3.4 and 4.3.5 omit significant numbers and misplace the decimal comma (see the attached screenshot and sample file).

The decimal comma is misplaced so, depending on the column width, the displayed number is 70-2000 times more than it really is. So, depending on the column width the calculation 7830 * 0,45 = 3551,6282571 is displayed as the following variations:

,628
1,6283
51,62826
3552 (correct)
3551,6 (correct)
3551,63 (correct)
3551,62826 (correct)

I had prepared the spreadsheet in an older version of LibreOffice and after upgrading to v4.3.4 I noticed the incorrect result in one cell.

Setup: Mac mini (Late 2009), OS X 10.10.1. Locale setting Finnish -- otherwise default settings. Resetting the user profile does not help. BTW, on a MacBook Pro Retina the incorrect values are displayed VERY briefly before changing to the correct values. I had to watch out this very carefully and even then didn't always notice it when the file opens.

On the other hand, LibreOffice 4.2.3 displays the correct spreadsheet numbers on the Mac mini.

I have found some workarounds to fix the issue:

1. LibreOffice Calc > General > Use printer metrics for text formatting ON

2. LibreOffice Calc > Calculate > Limit decimals for general number format ON

3. Format > Cells... > Numbers > Number > Format: use some other setting than General
Comment 9 matti.haveri 2015-01-23 15:33:39 UTC
Created attachment 112726 [details]
How it looks for me

Depending on the column width the calculation 7830 * 0,45 = 3551,6282571 (in red) is displayed as the following variations:

,628
1,6283
51,62826
3552 (correct)
3551,6 (correct)
3551,63 (correct)
3551,62826 (correct)
Comment 10 matti.haveri 2015-01-23 15:34:58 UTC
Created attachment 112727 [details]
Sample file
Comment 11 matti.haveri 2015-01-23 15:46:19 UTC
Created attachment 112729 [details]
How it looks for me

Depending on the column width the calculation 7830 * 0,45 = 3551,6282571 (in red) is displayed as the following variations:

,628
1,6283
51,62826
3552 (correct)
3551,6 (correct)
3551,63 (correct)
3551,62826 (correct)
Comment 12 raal 2015-02-07 18:50:37 UTC
*** Bug 89208 has been marked as a duplicate of this bug. ***
Comment 13 Alex Thurgood 2015-02-20 17:38:20 UTC
*** Bug 89474 has been marked as a duplicate of this bug. ***
Comment 14 m.a.riosv 2015-03-19 17:56:13 UTC
*** Bug 90091 has been marked as a duplicate of this bug. ***
Comment 15 m.a.riosv 2015-04-09 13:44:25 UTC
*** Bug 85942 has been marked as a duplicate of this bug. ***
Comment 16 m.a.riosv 2015-04-14 22:32:32 UTC
*** Bug 90615 has been marked as a duplicate of this bug. ***
Comment 17 spam.monopolycar 2015-05-03 06:56:17 UTC
*** Bug 90984 has been marked as a duplicate of this bug. ***
Comment 18 m.a.riosv 2015-05-07 13:49:59 UTC
*** Bug 90952 has been marked as a duplicate of this bug. ***
Comment 19 QA Administrators 2016-09-20 09:37:19 UTC Comment hidden (obsolete)
Comment 20 m.a.riosv 2016-09-21 22:25:40 UTC
Seems works with 5.2.2.1, although columns wide change a bit with/without using printer metrics.
Comment 21 Xisco Faulí 2018-02-26 11:31:05 UTC
The content of attachment 98987 [details] has been deleted