Bug Hunting Session
Bug 87288 - FORMATTING: FONT SELECTION. Condensed font variations not selectable (Small Caps also)
Summary: FORMATTING: FONT SELECTION. Condensed font variations not selectable (Small C...
Status: RESOLVED DUPLICATE of bug 35538
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2014-12-13 17:01 UTC by Tobias Simon
Modified: 2018-01-30 14:04 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
Fontin Sans for Testing (87.35 KB, application/zip)
2015-09-01 16:32 UTC, Iandol
Details
screenshot (56.96 KB, image/png)
2015-09-01 16:36 UTC, Iandol
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Simon 2014-12-13 17:01:32 UTC
The DejaVu font family distributed wit LibreOffice contains Condensed fonts.
Even though they are displayed in the font selection dialogue as distinct font variations, selecting them has no effect. Instead the corresponding non-condensed fonts appear to be used in the preview and the document. Reopening the dialogue also shows the corresponding non-condensed font variation being chosen.

DejaVu Serif contains these fonts:
Book
Condensed - (reverts to Book)
Fett - (localized Bold)
Condensed Bold - (reverts to Bold)
Condensed Italic - (reverts to Italic)
Kursiv - (localized Italic)
Fett Kursiv - (localized Bold Italic)
Condensed Bold Italic - (reverts to Bold Italic)

Selecting one of the condensed variations shows no effect. Only the 4 standard veriations are efectivly selectable.

DejaVu Sans contains these fonts:
ExtraLight - (works as expected)
Book
Condensed
Fett - (localized Bold)
Condensed Bold
Condensed Oblique
Oblique - (reverts to Condensed Oblique)
Bold Oblique
Condensed Bold Oblique

Here Oblique reverts to Condensed Oblique, but the actually selected font appears to be Oblique (non-condensed). I guess this has to do something with the order, in which the font variations appear in the list.

Liberation and PT use different font family names.
Also the 10 variations of Source Code Pro work as expected. They only differ in weight and slope, not width.

The OS X fonts Futura, Helvetica Neue and Papyrus contain condensed variations, which all revert to the corresponding non-condensed font variations. However Futura Condensed ExtraBold and Helvetica Neue Condensed Black work - there are no corresponding font variations with the same weight.

The free font Fontin Sans contains a Small Caps font variation, also Bold, Italic and Bold Italic. Small Caps is not shown in the font selection dialogue, but used in preview and document, when the font (regular variation) is selected. The other variations work as expected.

-- TL;DR

Font variations only work as expected, when they differ in weight or slope.
Variations in width and shape fail in one or more ways.

Font designers (and users) are not expecting this, and they shouldn't have to.
Comment 1 Tobias Simon 2014-12-13 19:44:48 UTC
Using FontForge, I found, that different values in
> Font Information > General > Italic Angle
or
> Font Information > OS/2 > Misc > Weight Class
cause LibreOffice to treat the fonts as different.

Same values in the above fields, but a different value in
> Font Information > OS/2 > Misc > Width Class
results in behaviour as seen with DejaVu.

Same Values in all three fields cause LibreOffice to confuse the two fonts with another.

With changes to
> Font Information > OS/2 > Misc > Weight Class
I was able to "repair" the fonts. A small change from '400 Regular' to '401 Regular' was sufficient.

Changes to the italic angle didn't work though, no idea why.



A dirty fix for the bug may be to enforce a unique weight class for every discovered font in a font family. If two weight classes match, internally increment one weight class by 1. Since the weight classes normally increment in steps of 100, it is safe to assume, that there is enough room to find unique weight classes for every font.
Comment 2 Alex Thurgood 2014-12-15 09:34:29 UTC
Confirming, this is similar to other font weight issues already known with LO on OSX
Comment 3 Dan 2015-02-02 09:59:35 UTC
This is a rather nasty bug (at least on OS X) in an excellent piece of softfare that LO undoubtedly is.

In fact, the whole Character dialogue could use an overhaul, ideally catering for OTF stylistic sets as well.
Comment 4 Christian Lohmaier 2015-09-01 14:39:31 UTC
*** Bug 83006 has been marked as a duplicate of this bug. ***
Comment 5 Christian Lohmaier 2015-09-01 14:41:54 UTC
Not restricted to Mac, also occurs on Linux - setting OS to ALL (even if it only means unix-like ones in this case)
Comment 6 Christian Lohmaier 2015-09-01 14:47:21 UTC
*** Bug 93157 has been marked as a duplicate of this bug. ***
Comment 7 Maxim Monastirsky 2015-09-01 15:03:55 UTC
(In reply to Christian Lohmaier from comment #5)
> Not restricted to Mac, also occurs on Linux
I can't reproduce the original problem (with DejaVu Serif Condensed) under Fedora 22 with 4.4 and current master.

(In reply to Christian Lohmaier from comment #6)
> *** Bug 93157 has been marked as a duplicate of this bug. ***
Not sure that's a duplicate. This bug is about a variation this is present in the list but doesn't work, while Bug 93157 is about a variation that is not present in the list. Besides, since 4.1 we're getting a lot of similar font-related bugs from Mac users, so it seems that there is indeed some Mac specific problem.
Comment 8 Iandol 2015-09-01 16:32:10 UTC
Created attachment 118316 [details]
Fontin Sans for Testing

From my duplicate #83006 — here is Fontin Sans, a free font where the small caps variant is wrongly displayed instead of the regular variant. This font substitution/style error is still present in V5.1alpha
Comment 9 Iandol 2015-09-01 16:36:02 UTC
Created attachment 118317 [details]
screenshot

screenshot showing regular fontin sans showing the small caps variant:

ersion: 5.1.0.0.alpha1+
Build ID: 87514b0907dfbb479e2646b5ff951c68babf3417-GL
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2015-08-31_00:06:37
Locale: en-US (en.UTF-8)
Comment 10 Alex Thurgood 2015-11-16 10:26:04 UTC
*** Bug 95816 has been marked as a duplicate of this bug. ***
Comment 11 Poren Chiang 2016-03-31 12:11:54 UTC
Bug 98397 seems relevant to this bug.

LibreOffice 5.0.2 on OS X would have similar problem. Fonts tested:

* Source Han Sans TC (ref: https://github.com/adobe-fonts/source-han-sans)
  a. "Normal" and "Medium" font weight is not available. 

  b. Manually typing "Normal" in [Character] dialog -> [Typeface] works, 
     (showing "The same font will be used on both your printer...") but 
     renders the same as "Regular" weight. Sometimes the dialog would 
     display the current typeface as "Normal" instead of "Regular".

  c. Manually typing "Medium" in [Typeface] wouldn't work.

  d. Incorrectly shows "Italic" and "Bold Italic"
     (“italic” is not meaningful to CJK fonts.)

* Source Sans Pro
  e. "Semibold" Behaves correctly.

* Roboto
  a. "Medium" is not available, only "Medium Italic" shown.

  c. Manually typing "Medium" wouldn't work.

* PingFang TC (OS X 10.11 builtin font)
  a. "Medium" and "Semibold" is not available for. 

  b. Manually typing "Semibold" would work.

  c. Manually typing "Medium" would not work.

---

I'll update to 5.1.1 later today and see if the problem persists.
Comment 12 Alex Thurgood 2016-09-06 09:47:35 UTC
DUP of 69254 ?
Comment 13 Thomas Linard 2018-01-05 10:02:23 UTC

*** This bug has been marked as a duplicate of bug 35538 ***