Bug 49813 - Enhanced autofilter popup window (Data > Filter > Auto Filter) should be resizeable (too narrow) (width too small)
Summary: Enhanced autofilter popup window (Data > Filter > Auto Filter) should be resi...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: high enhancement
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.4.0 target:6.3.4
Keywords:
: 65283 72747 78806 82145 94250 95597 102362 104408 116704 126576 128167 (view as bug list)
Depends on:
Blocks: AutoFilter
  Show dependency treegraph
 
Reported: 2012-05-11 11:20 UTC by MySh
Modified: 2020-05-19 08:55 UTC (History)
28 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot in odg file (100.05 KB, application/vnd.oasis.opendocument.graphics)
2014-05-26 06:47 UTC, Kevin Suo
Details
screenshot showing the too narrow autofilter (198.91 KB, image/png)
2014-10-16 10:20 UTC, Kevin Suo
Details
Screenshot: AutoFilter dialog in Apache OpenOffice 4.1 (55.16 KB, image/png)
2014-11-10 07:02 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MySh 2012-05-11 11:20:56 UTC
New enhanced autofilter popup window looks and works fine when working with narrow columns, but since its width is fixed it looks to be too narrow when working with wide columns containing long data (especially if data is the same at the beginning and differs only at the end) so that when trying to filter you can’t see the whole length of the content, which makes it very hard to find the content you want to filter for.
Probable solution: it should either have width of the top column cell or be resizeable so user could set its size manually (either for every column, or for a sheet, or at least for program itself).
Also it would be nice to have ability to change its vertical size to see all filtering values.
Comment 1 Mirosław Zalewski 2013-08-14 15:28:43 UTC
*** Bug 65283 has been marked as a duplicate of this bug. ***
Comment 2 Mirosław Zalewski 2013-08-14 15:31:24 UTC
Comment in Bug 65283 mentions workaround:
after opening autofilter pop-up window, one can press Shift + F1. Then, whole entry will be shown in tooltip (just hover your mouse above long entry).
Comment 3 Kevin Suo 2014-05-26 06:47:26 UTC
Created attachment 99832 [details]
screenshot in odg file

Setting importance to high, as this feature is very important for data analyst in spreadsheet.

The long text (actually not very long) in a filter is not fully shown even if the column width is very wide.
Comment 4 Kevin Suo 2014-10-16 10:20:30 UTC
Created attachment 107920 [details]
screenshot showing the too narrow autofilter
Comment 5 Kevin Suo 2014-10-16 10:21:22 UTC
*** Bug 82145 has been marked as a duplicate of this bug. ***
Comment 6 Adolfo Jayme 2014-10-25 20:08:58 UTC
*** Bug 78806 has been marked as a duplicate of this bug. ***
Comment 7 Kevin Suo 2014-11-10 07:02:01 UTC
Created attachment 109189 [details]
Screenshot: AutoFilter dialog in Apache OpenOffice 4.1

Just for information, in Apache OpenOffice 4.1 autofilter has the same width as the column (thus it is resizable by resizing the column width).
Comment 8 Ellert Hardarson 2015-02-04 09:05:30 UTC
Still the same in LibreOffice Version: 4.3.3.2
Comment 9 Adolfo Jayme 2015-11-08 16:46:42 UTC
*** Bug 94250 has been marked as a duplicate of this bug. ***
Comment 10 Adolfo Jayme 2015-11-08 16:47:06 UTC
*** Bug 95597 has been marked as a duplicate of this bug. ***
Comment 11 Adolfo Jayme 2015-11-08 16:52:38 UTC
*** Bug 72747 has been marked as a duplicate of this bug. ***
Comment 12 Matias Lopez 2015-11-24 13:56:15 UTC
I'm using LibreOffice version 5.0.2.2 and this popup is still not resizable. Long values that only change at the end are not easy to select. This will be a great improvement when added. Thank you.
Comment 13 Cor Nouws 2015-11-24 14:56:46 UTC
(In reply to Matias Lopez from comment #12)
> I'm using LibreOffice version 5.0.2.2 and this popup is still not resizable.
> Long values that only change at the end are not easy to select. This will be
> a great improvement when added. Thank you.

Hi Matias,

Thanks for your encouraging words and support.
It does not help in general to make implementation faster, however. Would be nice if it worked like that :) But it's about the interest of the developers, and their other work load, or new developers that stand up, that makes the difference.

Cheers - Cor
Comment 14 Buovjaga 2016-10-09 13:36:57 UTC
*** Bug 102362 has been marked as a duplicate of this bug. ***
Comment 15 Adolfo Jayme 2016-12-05 12:43:31 UTC
*** Bug 104408 has been marked as a duplicate of this bug. ***
Comment 16 Grigory Shorin 2016-12-19 13:13:45 UTC Comment hidden (me-too)
Comment 17 torben.andresen 2017-01-06 13:45:06 UTC
Changing this would be great. I'm using Libreoffice at Work and we have often long values in lists. And the AutoFilter Popup is not very helpful.
Comment 18 Iván Baldo 2017-06-29 19:47:46 UTC
Still happens in 5.4.0.1.
I don't understand, this should be an easy fix, make the dialog resizable and/or add an horizontal scroll bar...
It makes LibreOffice unusable in some common situations :-(
Fingers crossed...
Comment 19 raal 2017-08-20 06:43:24 UTC
*** Bug 111778 has been marked as a duplicate of this bug. ***
Comment 20 m.a.riosv 2018-03-30 09:55:12 UTC
*** Bug 116704 has been marked as a duplicate of this bug. ***
Comment 21 Andy Blackton 2019-03-12 16:52:20 UTC
I strongly support this. The dialog should be resizeable.

If anybody takes it up. A great thanks!
Comment 22 Roman Kuznetsov 2019-07-28 18:52:57 UTC
*** Bug 126576 has been marked as a duplicate of this bug. ***
Comment 23 prog-amateur 2019-10-08 11:11:06 UTC
Hello, the status is to 'NEW', while this lack of feature has been open in 2012 (version 4.0). 
I am on LibreOffice 6.3 and see that this issue still remains on Calc when I want to filter the data (a long csv list). In the era of data analysis and statistics, it is difficult to scroll thousands of lines  because the pop-up is tight and small. 

For a 5x5 table, it's okay, but in a working context, it is almost unusable. I hope it is something that will be able to be solved soon. Thank you.
Comment 24 Roman Kuznetsov 2019-10-16 14:32:20 UTC
*** Bug 128167 has been marked as a duplicate of this bug. ***
Comment 25 Xisco Faulí 2019-10-16 14:39:13 UTC
Hi Caolán,
Considering the amount of duplicates, I thought you might be interested in this issue...
Comment 26 Caolán McNamara 2019-10-29 14:55:33 UTC
https://gerrit.libreoffice.org/#/c/81690/ would make the popup at least the width of the column its shown in, which I imagine solves the majority of the problems
Comment 27 Commit Notification 2019-10-29 20:00:10 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/bdbc439ac6c6a0eb615d55dcaaf0722f3013b812

tdf#49813 make autofilter popup at least the width of its column

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 28 Roman Kuznetsov 2019-10-30 06:32:32 UTC
(In reply to Caolán McNamara from comment #26)
> https://gerrit.libreoffice.org/#/c/81690/ would make the popup at least the
> width of the column its shown in, which I imagine solves the majority of the
> problems

let's see to reaction from users
Comment 29 Commit Notification 2019-10-30 07:26:04 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/e5b2c2c5b85a239bba332ca754eef5328949e7ee

tdf#49813 make autofilter popup at least the width of its column

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 30 Caolán McNamara 2019-11-26 09:50:24 UTC
lets call it fixed as the initial issue was wrt the width and the solution is one of the initial suggested solutions