Bug 67527 - FILEOPEN: LO can't open files over SMB from KDE because of missing dependencies - wants to repair! [summary in comment 59]
Summary: FILEOPEN: LO can't open files over SMB from KDE because of missing dependenci...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: high critical
Assignee: Stephan Bergmann
QA Contact:
URL:
Whiteboard: target:4.4.0
Keywords: regression
: 58236 67675 67769 67892 68119 71981 73187 75055 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-07-30 09:29 UTC by mail
Modified: 2017-03-21 15:34 UTC (History)
28 users (show)

See Also:
Crash report or crash signature:


Attachments
Can edit and save (10.38 KB, image/png)
2013-07-30 13:40 UTC, Samuel Wolf
Details
Can not edit or save (9.69 KB, image/png)
2013-07-30 13:40 UTC, Samuel Wolf
Details
'ps aux' immediately after failed attempt to open an xls file from SMB share (16.72 KB, text/plain)
2014-01-30 22:13 UTC, Bryan Berndt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mail 2013-07-30 09:29:39 UTC
I'm running LO 4.1.0.4 from your PPA on Ubuntu 12.04 64bit - libreoffice (1:4.1.0-0ubuntu1~precise1~ppa1)

After the last update to 4.1.0.4 I can't open odt, ods & xlsx (can be more extensions that I haven't found yet) over SMB within Nautilus. However .doc works fine.

If I open any of the others i get that the file is corrupt and the possibility to repair the file. Problem is that it's not corrupt, my colleagues can open them (other OS and software), and if I copy the file to my local computer I'm able to open them without a problem.

Doesn't matter if I start Writer and use the open file option there.

Even if i use this with terminal it's no problem:
$ libreoffice --writer /home/user/.gvfs/path/to/document.odt

So I don't know how to give you more information since I can't reproduce it through the terminal. Is there any way to debug with GUI or get a log file? Can't find any answers on Google for that.

To reproduce:
Nautilus -> Browse Network -> Windows network -> SHARE -> double click *.odt
Comment 1 Samuel Wolf 2013-07-30 13:32:52 UTC
Can not save or change .odb file over smb/nautilus mount, work fine in LO4.0.
It look like it is the same source problem you have.
Comment 2 Samuel Wolf 2013-07-30 13:40:06 UTC
Created attachment 83298 [details]
Can edit and save
Comment 3 Samuel Wolf 2013-07-30 13:40:36 UTC
Created attachment 83299 [details]
Can not edit or save
Comment 4 Björn Michaelsen 2013-07-31 09:53:56 UTC
confirmed by comment #2 => NEW, regression as claimed to have worked with 4.0.x.

Can you test (maybe in a VM) if a later Ubuntu version (e.g. 13.04) still shows the issue? => NEEDINFO
Comment 5 Samuel Wolf 2013-07-31 13:42:41 UTC
My system is debian 7.1 (wheezy) amd64.
Comment 6 Joel Madero 2013-08-01 19:02:10 UTC
Bjoern - going to go ahead and mark this as NEW - as you've confirmed. I'll leave any further discussion to you and maiil@rittsel.com - seems like a nasty one so upping priority.
Comment 7 mail 2013-08-05 12:45:35 UTC
(In reply to comment #4)
> confirmed by comment #2 => NEW, regression as claimed to have worked with
> 4.0.x.
> 
> Can you test (maybe in a VM) if a later Ubuntu version (e.g. 13.04) still
> shows the issue? => NEEDINFO

Hi Björn,

I've installed 13.04 in a VM and funny enough it didn't work with the default installation of 4.0, however, I installed 4.1.0.4 through PPA for 13.04 (raring), and it works just fine!

I ran ps aux | grep libreoffice on both machines and they both show the same:

rittsel   2824  0.0  0.1 143728  3184 ?        Sl   04:46   0:00 /usr/lib/libreoffice/program/oosplash --writer /run/user/rittsel/gvfs/smb-share:server=XXXXX,share=bibliotek/Serverdrift/Backupunderlag.ods
rittsel   2845  0.7  3.0 808068 61496 ?        Dl   04:46   0:00 /usr/lib/libreoffice/program/soffice.bin --writer /run/user/rittsel/gvfs/smb-share:server=XXXXX,share=bibliotek/Serverdrift/Backupunderlag.ods --splash-pipe=6
Comment 8 vivAce 2013-08-07 07:16:54 UTC
Might this bug be similar to Bug 67675 & Bug 67769?
Comment 9 mail 2013-08-07 08:13:30 UTC
(In reply to comment #8)
> Might this bug be similar to Bug 67675 & Bug 67769?


Looks like it's exactly the same as 67675, but 67769 says it disappears after 10 seconds, that's not the case for me. I get the repair dialog, just as 67675.
Comment 10 Ildar 2013-08-07 08:24:16 UTC
I have the same problem
Comment 11 Maxim Monastirsky 2013-08-08 11:16:59 UTC
*** Bug 67675 has been marked as a duplicate of this bug. ***
Comment 12 Maxim Monastirsky 2013-08-08 11:18:18 UTC
*** Bug 67892 has been marked as a duplicate of this bug. ***
Comment 13 Maxim Monastirsky 2013-08-08 11:19:16 UTC
*** Bug 67769 has been marked as a duplicate of this bug. ***
Comment 14 Mike 2013-08-08 21:25:30 UTC
Can confirm this issue on my machine with Ubuntu 12.04 with LO 4.1.0.4 from ppa:libreoffice/ppa . I can only open .odt or .odp files successfully either from a local folder or by going via ~/.gvfs/sharename/document.odt . Opening from the share in Nautilus triggers the repair dialog.
Comment 15 Maxim Monastirsky 2013-08-11 15:27:03 UTC
Here is a WORKAROUND:

For Nautilus users:
Open the .desktop file (such as /usr/share/applications/libreoffice4.1-writer.desktop for LO Writer) and comment the following line:
X-GIO-NoFuse=true

For Dolphin users:
Open the same file, and comment the following line:
X-KDE-Protocols=file,http,smb,ftp,webdav
Comment 16 Maxim Monastirsky 2013-08-13 19:41:52 UTC
I've made some testing of this bug, and it seems that it depends on distribution\packages-source combination, as follows:

What was tested:
----------------
1) Ubuntu 12.04.2, 13.04 (64-bit) with packages from PPA and packages from libreoffice.org
2) Fedora 19 (64-bit) with packages from repos and packages from libreoffice.org
3) Ubuntu 13.10 (64-bit) with packages from repos
LO 4.1.0.4 was used in all cases.

Reproduction steps:
-------------------
1) Double-click in Nautilus
-OR-
2) From CLI: libreoffice(4.1) --writer smb://ip_address/share_name/document.odt
Both methods always gave the same results. Each time I couldn't open the document, applying the workaround from comment 15 did the job.

Results:
--------
1) Cases when I got the repair dialog:
Ubuntu 12.04.2 + Packages from PPA

2) Cases when LO just closed immediately (just like in bug 67769):
Ubuntu 12.04.2 + Packages from libreoffice.org
Ubuntu 13.04 + Packages from libreoffice.org
Ubuntu 13.10 + Packages from repos
Fedora 19 + Packages from libreoffice.org

3) Cases when I couldn't reproduce the bug:
Fedora 19 + Packages from repos

4) Uncertain:
Ubuntu 13.04 + Packages from PPA (This one is really strange, as it works when double-clicking in Nautilus, but don't work from the CLI, unless you opened Nautilus and mounted the share before that.)
Comment 17 Maxim Monastirsky 2013-08-13 20:19:32 UTC
Just to correct some inaccuracy in my last comment: Fedora 19 + Packages from repos behave the same as Ubuntu 13.04 + Packages from PPA.
Comment 18 Maxim Monastirsky 2013-08-15 13:45:40 UTC
*** Bug 68119 has been marked as a duplicate of this bug. ***
Comment 19 Bryan Berndt 2013-08-16 19:39:02 UTC
Problem happens with me as well.  Fedora 18, x64, (KDE) LibreOffice 4.1, installed with rpm's from the LibreOffice site.  

Doubleclicking on any Libreoffice file from a SBM share in Dolphin browser, Libreoffice starts, if its not already running, and then I get the bouncing icon next to my mouse cursor for a little while, and then no document.  No obvious error, or anything, just no document.  Clicking on a plain text file, for example works fine.  LibreOffice 4.0 worked fine.


Work around in comment 15 also fixes problem. (so far with .xls files, Using Calc)
Comment 20 Stephan Bergmann 2013-08-19 16:55:20 UTC
What I can reproduce on a Fedora 19 (x86_64) machine is as follows:

Installed a local samba server with
$ sudo yum install samba samba-client
$ sudo setsebool samba_enable_home_dirs on
$ sudo systemctl start smb.service
$ sudo smbpasswd -a "$USER"
first.

Then, used Nautilus "Connect to Server" to connect to smb://127.0.0.1/<USER>, and opened some *.odt file via double-click in the Fedora 19 distro LibreOffice (4.1.0), which worked as expected.

Then, used command line ".../soffice smb://127.0.0.1/"$USER"/...odt" to open that *.odt file in various LibreOffice versions:

It opened the document as expected in all those LibreOffice versions that are built with GIO support (the distro's LO 4.1.0, my own-built master).

But it failed to do anything and just silently returned with all those LibreOffice versions that are built with old GnomeVFS support (the LO 3.6, 4.0, 4.1 available from <http://www.libreoffice.org/download>).

So I created an own-built master with GnomeVFS rather than GIO support (--disable-gio --enable-gnome-vfs), which also failed to do anything, ultimately because the call to gnome_vfs_get_file_info in gvfs::Content::getInfo (ucb/source/ucp/gvfs/gvfs_content.cxx) failed with GNOME_VFS_ERROR_NOT_SUPPORTED.  The reason for that, in turn, was that package gnome-vfs2-smb was not installed on the machine.

That is, installing the Fedora 19 package gnome-vfs2-smb made the command line ".../soffice smb://127.0.0.1/"$USER"/...odt" work for all those cases for which it had previously failed, incl. the LO 3.6., 4.0, 4.1 available from <http://www.libreoffice.org/download>.

This likely explains comment 19 "No obvious error, or anything, just no document."

What I could not (yet?) reproduce is a repair dialog appearing.

So, the new NEEDINFO request is whether there is anybody
Comment 21 Stephan Bergmann 2013-08-19 16:57:20 UTC
(In reply to comment #20)
> So, the new NEEDINFO request is whether there is anybody

please ignore that junk at the end of the comment
Comment 22 Maxim Monastirsky 2013-08-19 17:06:40 UTC
(In reply to comment #20)
> What I could not (yet?) reproduce is a repair dialog appearing.
As it's reproducible only under Ubuntu 12.04, I guess it's caused by old versions of GNOME\Samba libs. This explains the fact you can't reproduce that on a recent distro.
Comment 23 Stephan Bergmann 2013-08-20 07:24:42 UTC
(In reply to comment #22)
> (In reply to comment #20)
> > What I could not (yet?) reproduce is a repair dialog appearing.
> As it's reproducible only under Ubuntu 12.04, I guess it's caused by old
> versions of GNOME\Samba libs. This explains the fact you can't reproduce
> that on a recent distro.

That makes it sound suspiciously like yet another fallout of GLib bug <https://bugzilla.gnome.org/show_bug.cgi?id=695925> "GUINT32/64_SWAP_LE_BE macros do not enclose val argument in parentheses," "which [...] caused trouble with LibreOffice, where running 'soffice sftp://.../.../test.odt' to access an .odt file via GVFS failed to properly type-detect that file as a Writer document and produced bogus error messages about the file being broken."
Comment 24 Stephan Bergmann 2013-08-20 07:47:51 UTC
(In reply to comment #23)
> (In reply to comment #22)
> > (In reply to comment #20)
> > > What I could not (yet?) reproduce is a repair dialog appearing.
> > As it's reproducible only under Ubuntu 12.04, I guess it's caused by old
> > versions of GNOME\Samba libs. This explains the fact you can't reproduce
> > that on a recent distro.
> 
> That makes it sound suspiciously like yet another fallout of GLib bug
> <https://bugzilla.gnome.org/show_bug.cgi?id=695925> "GUINT32/64_SWAP_LE_BE
> macros do not enclose val argument in parentheses," "which [...] caused
> trouble with LibreOffice, where running 'soffice sftp://.../.../test.odt' to
> access an .odt file via GVFS failed to properly type-detect that file as a
> Writer document and produced bogus error messages about the file being
> broken."

Björn, can you verify whether on Ubuntu 12.04 this issue is indeed caused by <https://bugzilla.gnome.org/show_bug.cgi?id=695925> "GUINT32/64_SWAP_LE_BE macros do not enclose val argument in parentheses" not yet being fixed?  (Note that it does not suffice to have that GLib header fix in place, you also need to have any relevant packages that include that header rebuilt.)
Comment 25 Björn Michaelsen 2013-08-20 11:16:53 UTC
Confirming Ubuntu 12.04 does not have the extra parathesis, filed:

 https://bugs.launchpad.net/ubuntu/+source/glib2.0/+bug/1214352

and adding remote bugs.
Comment 26 Maxim Monastirsky 2013-08-21 05:57:44 UTC
@Stephan Bergmann: Just tried to install gnome-vfs2-smb on Fedora 19 as you suggested, but in my case it didn't help. LO 4.1.0.4 from libreoffice.org still closes immediately, either when double-clicking in nautilus or using the CLI. BUT it helps with 4.2.0.0.alpha0+ Build ID: f4004429d339009bec6babe30becdc9c727940b8 TinderBox: Linux-x86-64@8-SLED11, Branch:master, Time: 2013-08-18_23:20:11

There is a problem also with distro's (Fedora 19) packages you didn't notice: The CLI doesn't work until you open nautilus and manually open the share. It's a problem because the whole point of using CLI is to avoid the GUI.

It's even worse for KDE users, since they can't even open by double-clicking in Dolphin, until they open nautilus and manually mount the share (although this can be avoided, by appling the workaround from comment 15, or by reverting commit 673be8e76856c6bc39f448f3374db4ae84258952)

BTW There is a seperate bug report about the CLI (bug 49776). Should we close it as a duplicate of the current bug?
Comment 27 Stephan Bergmann 2013-08-21 07:39:38 UTC
[Please note bug 49776 comment 6 about the two different kinds of LO builds involved, the --enable-gnome-vfs and --enable-gio kinds.]

(In reply to comment #26)
> @Stephan Bergmann: Just tried to install gnome-vfs2-smb on Fedora 19 as you
> suggested, but in my case it didn't help. LO 4.1.0.4 from libreoffice.org
> still closes immediately, either when double-clicking in nautilus or using
> the CLI.

Hm, that's bad, and I cannot reproduce it on my up-to-date Fedora 19 x86_64 box with <http://donate.libreoffice.org/home/dl/rpm-x86_64/4.1.0/en-US/LibreOffice_4.1.0_Linux_x86-64_rpm.tar.gz>:  With the setup from comment 20, "/opt/libreoffice4.1/program/soffice smb://127.0.0.1/"$USER"/Documents/test.odt" first pops up an "Authentication Required" dialog and then loads the document.

> BUT it helps with 4.2.0.0.alpha0+ Build ID:
> f4004429d339009bec6babe30becdc9c727940b8 TinderBox: Linux-x86-64@8-SLED11,
> Branch:master, Time: 2013-08-18_23:20:11

OK, that tinderbox is indeed one that produces LO builds of the first, --enable-gnome-vfs kind (cf. e.g. <http://tinderbox.libreoffice.org/cgi-bin/gunzip.cgi?tree=MASTER&full-log=1377058201.26472#5>), so it will be affected by presence of gnome-vfs2-smb package.  Odd though that things don't work for you with the above LO 4.1 of the same kind.

> There is a problem also with distro's (Fedora 19) packages you didn't
> notice: The CLI doesn't work until you open nautilus and manually open the
> share. It's a problem because the whole point of using CLI is to avoid the
> GUI.

See the comment at <https://bugzilla.redhat.com/show_bug.cgi?id=895690#c15> "Libreoffice causing errors when SAVING files by gvfs-mount (Samba)."

> BTW There is a seperate bug report about the CLI (bug 49776). Should we
> close it as a duplicate of the current bug?

I would prefer to wait until somebody who observed that bug in the past with a LO build of one kind is able to verify the bug is fixed with a later LO build of the same kind.
Comment 28 siegles 2013-10-17 21:51:37 UTC
Same problem as comment 19 with Ubuntu 13.04. simply no document. 4.0.2.2 works fine, 4.1 does not.
Comment 29 Maxim Monastirsky 2013-10-18 08:13:42 UTC
(In reply to comment #28)
> Same problem as comment 19 with Ubuntu 13.04. simply no document. 4.0.2.2
> works fine, 4.1 does not.
Hi,
Unfortunately you didn't say which LO package do you use - from PPA or from libreoffice.org. Each of them has completely different problems.

- If you're using the packages from PPA, then the bug should be solved with 4.1.2 (unfortunately the PPA currently stuck with 4.1.1). When it will be updated to 4.1.2, it should work if you also install 'gvfs-backends' and 'libreoffice-gnome' packages. That way it works with Ubuntu 13.10.

- If you're using the packages from libreoffice.org site, then theoretically it should work if you install 'libgnomevfs2-extra' package. But for some reason it's not working. I can confirm that it's not working with 4.1.2.3 under both Ubuntu 13.04 and 13.10 (64-bit). Same happens under Fedora 19 (64-bit), as you can see from the first paragraph of comment 26. And it's still the case for 4.1.2.3. There is definitely some problem with the official builds.

So currently you have to apply the workaround from comment 15, or upgrade to Ubuntu 13.10.
Comment 30 Bryan Berndt 2013-11-20 21:42:46 UTC
Problem still exists, it seems, for me.  Using Fedora 19 x64 this time, and the RPMs from the LibreOffice site.  Version 4.1.3.
Comment 31 Joel Madero 2013-11-20 22:11:41 UTC
Can someone do a bibisect of this so that we can maybe get a range? 

https://wiki.documentfoundation.org/QA/HowToBibisect
Comment 32 Maxim Monastirsky 2013-11-21 07:06:35 UTC
(In reply to comment #31)
> Can someone do a bibisect of this so that we can maybe get a range? 
@Joel Madero: There is no need for bibisect. The problem probably is with the build environment where we build official releases (maybe some old headers or something similar). Please see Stephan Bergmann's comment at comment 20 that it works in his own build, and also see my comment at comment 26 that it works with a build from tinderbox, but not with the official build. Same under Ubuntu - see comment 29.
Comment 33 Björn Michaelsen 2013-11-21 07:56:46 UTC
(In reply to comment #29)
> - If you're using the packages from PPA, then the bug should be solved with
> 4.1.2 (unfortunately the PPA currently stuck with 4.1.1). When it will be
> updated to 4.1.2, it should work if you also install 'gvfs-backends' and
> 'libreoffice-gnome' packages. That way it works with Ubuntu 13.10.
Note that the ppa has:
1:4.1.3~rc2-0ubuntu1~saucy1~ppa3
1:4.1.3~rc2-0ubuntu1~raring1~ppa1
1:4.1.3~rc2-0ubuntu1~precise1~ppa1

so all versions should be good, unless the bug is in the respective baseline on that ppa.
Comment 34 Stephan Bergmann 2013-11-21 09:18:02 UTC
(In reply to comment #30)
> Problem still exists, it seems, for me.  Using Fedora 19 x64 this time, and
> the RPMs from the LibreOffice site.  Version 4.1.3.

What problem exactly still exists?

Also, do you have the gnome-vfs2-smb package installed, see comment 20?
Comment 35 Maxim Monastirsky 2013-11-21 10:18:26 UTC
(In reply to comment #34)
> What problem exactly still exists?
@Stephan Bergmann: Bryan Berndt explained his problem at comment 19.
Comment 36 Stephan Bergmann 2013-11-21 10:43:02 UTC
(In reply to comment #35)
> (In reply to comment #34)
> > What problem exactly still exists?
> @Stephan Bergmann: Bryan Berndt explained his problem at comment 19.

Ah, right.  So /if/ he doesn't have gnome-vfs2-smb package installed, his findings in comment 30 would be consistent with my findings in comment 20.

Bryan, can you please clarify?
Comment 37 Maxim Monastirsky 2013-11-21 13:36:53 UTC
@Stephan Bergmann: I found what causes the problem with the official build: Looking at the strace output showed that libORBit-2.so.0 can't be found. So I did 'sudo yum install ORBit2' and now it works!
Comment 38 Maxim Monastirsky 2013-11-21 18:09:52 UTC
(In reply to comment #33)
> Note that the ppa has:
> 1:4.1.3~rc2-0ubuntu1~saucy1~ppa3
> 1:4.1.3~rc2-0ubuntu1~raring1~ppa1
> 1:4.1.3~rc2-0ubuntu1~precise1~ppa1
> 
> so all versions should be good, unless the bug is in the respective baseline
> on that ppa.
Indeed. I can confirm that it works now under Ubuntu 13.04 (64-bit). Thanks.
Comment 39 Maxim Monastirsky 2013-11-24 12:47:49 UTC
(In reply to comment #37)
> @Stephan Bergmann: I found what causes the problem with the official build:
> Looking at the strace output showed that libORBit-2.so.0 can't be found. So
> I did 'sudo yum install ORBit2' and now it works!
I can confirm the same for Ubuntu 13.10 (64-bit). Installing 'liborbit2' package solves the problem.

But unfortunately it still won't work under KDE, unless exporting 'OOO_FORCE_DESKTOP=gnome'. That is: Running 'soffice smb://some_ip/share/document.odt' under KDE doesn't work, but 'OOO_FORCE_DESKTOP=gnome soffice smb://some_ip/share/document.odt' does work. Tested under Fedora 19 (64-bit) & Ubuntu 13.10 (64-bit). Tested with 4.1.3.2 & master build (Build ID: 732ec36edfd09d2091d70c4d71b5f182fe279c45 TinderBox: Linux-rpm_deb-x86_64@46-TDF) built with --enable-gnome-vfs.

Same for MATE desktop. Tested with MATE 1.6.0 under Fedora 19 (64-bit) & LMDE MATE Edition (64-bit).
Comment 40 Maxim Monastirsky 2013-11-25 11:06:21 UTC
*** Bug 71981 has been marked as a duplicate of this bug. ***
Comment 41 Maxim Monastirsky 2013-11-26 16:37:17 UTC
@Stephan Bergmann: I found why builds with --enable-gnome-vfs won't work under KDE. It's because there is a check for GNOME desktop at http://opengrok.libreoffice.org/xref/core/desktop/source/app/appinit.cxx#86. Removing that check solves the problem. Is it OK to just remove that check, or there could be some side effects which I'm not aware of?
Comment 42 Stephan Bergmann 2013-11-26 16:53:16 UTC
(In reply to comment #41)
> @Stephan Bergmann: I found why builds with --enable-gnome-vfs won't work
> under KDE. It's because there is a check for GNOME desktop at
> http://opengrok.libreoffice.org/xref/core/desktop/source/app/appinit.cxx#86.
> Removing that check solves the problem. Is it OK to just remove that check,
> or there could be some side effects which I'm not aware of?

No idea whether it would make sense to use that GnomeVFSContentProvider on non-Gnome desktops, too.  Maybe mmeeks knows?
Comment 43 Michael Meeks 2013-11-26 17:45:28 UTC
In general not using gnome-vfs at all is what makes most sense ;-)
gio - if anything - but surely KIO uses paths into a FUSE mount just like GNOME does - making that mostly pointless ?
Comment 44 Maxim Monastirsky 2013-11-26 18:59:42 UTC
(In reply to comment #43)
> but surely KIO uses paths into a FUSE mount just like GNOME does -
> making that mostly pointless ?
No, KIO doesn't deal with any kind of mount. It just downloads the file into a temp folder, and opens it from there. It may cause troubles as in Bug 39591.

The problem now is that starting with 4.1 the .desktop files contain 'X-KDE-Protocols' definition, which is the equivalent of 'X-GIO-NoFuse'. So when users double-click on a file we get 'smb://adderss/share/filename', and should deal with it ourselves. And because the official build uses gnome-vfs, it fails. So there are 3 solutions:

1. Make gnome-vfs work under KDE as suggested above.
2. Force gnome desktop in official build (by exporting OOO_FORCE_DESKTOP=gnome in startup script, or something similar). It won't hurt anyone, since we don't ship KDE4 integration anyway.
3. Remove 'X-KDE-Protocols' from .desktop files. (But it will bring back Bug 39591.)
Comment 45 Maxim Monastirsky 2013-11-27 06:24:02 UTC
(In reply to comment #44)
> 3. Remove 'X-KDE-Protocols' from .desktop files. (But it will bring back Bug
> 39591.)
Also it won't solve the problem for MATE desktop, which is not detected as GNOME (See http://opengrok.libreoffice.org/xref/core/vcl/unx/generic/desktopdetect/desktopdetector.cxx#369. BTW the code there is broken, since MATE doesn't define XDG_CURRENT_DESKTOP)
Comment 46 grahha 2013-11-29 10:31:48 UTC
Still an issue with Ubuntu 12.04.3 and LibreOffice 1:4.1.3~rc2-0ubuntu1~precise1~ppa1
Comment 47 iveand 2013-12-10 22:47:14 UTC
confirming the problem still exists in Ubuntu 12.04.3, with LO 4.1.3 PPA version (version 4.1.3~rc2-0ubuntu1~precise1~ppa1) as prior comment indicates.  Workaround of:

sudo sed -i 's/X-GIO-NoFuse=true/#X-GIO-NoFuse=true/' /usr/share/applications/libreoffice-* as

as alluded to above does seem to help.
Comment 48 iveand 2013-12-10 22:52:18 UTC
Update: attempting to open a .odt on a remote linux share using sftp (so not using samba) will result in the SAME ERROR.  The .desktop sed hack does NOT solve the problem in this regard.  So, from what I know there is no workaround for Ubuntu 12.04.3 to open .odf files on sftp shares.
Comment 49 Maxim Monastirsky 2014-01-01 13:50:21 UTC
*** Bug 73187 has been marked as a duplicate of this bug. ***
Comment 50 Ritesh Khadgaray 2014-01-24 18:45:29 UTC
(In reply to comment #48)
> Update: attempting to open a .odt on a remote linux share using sftp (so not
> using samba) will result in the SAME ERROR.  The .desktop sed hack does NOT
> solve the problem in this regard.  So, from what I know there is no
> workaround for Ubuntu 12.04.3 to open .odf files on sftp shares.

Hi. This works fine with precise.  Is there an lp for this ?
Comment 51 Bryan Berndt 2014-01-27 21:58:31 UTC
(In reply to comment #36)
> (In reply to comment #35)
> > (In reply to comment #34)
> > > What problem exactly still exists?
> > @Stephan Bergmann: Bryan Berndt explained his problem at comment 19.
> 
> Ah, right.  So /if/ he doesn't have gnome-vfs2-smb package installed, his
> findings in comment 30 would be consistent with my findings in comment 20.
> 
> Bryan, can you please clarify?

Sorry, been away for a while. And Just added myself to the CC list, so I can try to keep up.

Im now on Fedora 20, x64, and using Libre Office 4.1.4.  problem still exists, as explained in comment 19. Though, the failure is MUCH faster, less than a second.

The fix in comment 15 still works, as well. 

I use KDE, gnome-vfs2-smb is NOT installed.
Comment 52 Ritesh Khadgaray 2014-01-30 20:52:22 UTC
Hi

(In reply to comment #51)
> (In reply to comment #36)
> > (In reply to comment #35)
> > > (In reply to comment #34)
> > > > What problem exactly still exists?
> > > @Stephan Bergmann: Bryan Berndt explained his problem at comment 19.
> > 
> > Ah, right.  So /if/ he doesn't have gnome-vfs2-smb package installed, his
> > findings in comment 30 would be consistent with my findings in comment 20.
> > 
> > Bryan, can you please clarify?
> 
> Sorry, been away for a while. And Just added myself to the CC list, so I can
> try to keep up.
> 
> Im now on Fedora 20, x64, and using Libre Office 4.1.4.  problem still
> exists, as explained in comment 19. Though, the failure is MUCH faster, less
> than a second.
> 
> The fix in comment 15 still works, as well. 
> 
> I use KDE, gnome-vfs2-smb is NOT installed.

works fine using lo 4.1.4 shipped with fc20. Would you provide the "ps aux" o/p , after trying to open the document ( without the c#15 workaround).

I personally prefer this (c#15). Is there a reason we do not do delegate this to gvfs/kio backend by default ?


__self:
http://techbase.kde.org/Projects/KioFuse
https://wiki.gnome.org/Projects/KioGioBridge
Comment 53 Bryan Berndt 2014-01-30 22:13:50 UTC
Created attachment 93088 [details]
'ps aux' immediately after failed attempt to open an xls file from SMB share

'ps aux' immediately after failed attempt to open an xls file from SMB share 

As requested.

I removed the comment in the .desktop file or Libreoffice Calc. (comment 15) Then tried to open an xls file from a SMB share, by doubleclicking on the icon in Dolphin. I see the Libreoffice logo for a second, and then nothing.
Comment 54 iveand 2014-01-31 20:05:03 UTC
I have just confirmed this bug is NOT PRESENT for the following:

Client: Ubuntu 14.04
LibreOffice Version 4.1.3.2
Connection: smb:// from nautilus, so mounted to ~/.gvfs

Client: Ubuntu 12.04.3
LibreOffice Version: 4.1.4.2
Connection: cifs entry in /etc/fstab

I have just confirmed this bug IS STILL present for the following:

Client: Ubuntu 12.04.3
LibreOffice Version: 4.1.4.2
Connection: smb:// from nautilus, so mounted to ~/.gvfs

(the work-around from comment 15 above does still work, however)
Comment 55 iveand 2014-01-31 20:06:17 UTC
Sorry I wasn't clear enough: I mean that in Ubuntu 14.04 this bug seems SOLVED.  The workaround of comment 15 is NOT REQUIRED.
Comment 56 Bryan Berndt 2014-01-31 23:27:41 UTC
Just tried the latest LibreOffice 4.2.0.4 from the main libreoffice site.

Problem still exists (comment 19), and is still fixed with comment 15.
Comment 57 iveand 2014-02-01 16:45:46 UTC
Bryan,

What OS are you running?  Again from my testing I see the problem SOLVED in Ubuntu 14.04, but still present in Ubuntu 12.04.  It is some combination of LibreOffice 4.1 (+) in combination with *something* present in Ubuntu 12.04 that is not in Ubuntu 14.04.  I am not sure about interim releases.  I can't speak to Windows or OSX.
Comment 58 iveand 2014-02-01 16:47:56 UTC
Bryan, sorry I missed the earlier comment where you indicate you are using Fedora 20, KDE desktop.

To clarify, my testing results above are with Gnome-Shell / Unity / Cinnamon desktops, and I have not tested with KDE.
Comment 59 Maxim Monastirsky 2014-02-02 07:45:29 UTC
@iveand, Bryan Berndt: Too bad you didn't read carefully the whole thread. Anyway, here is a summary:

- The repair dialog is an Ubuntu 12.04 specific bug, related to glib package. See https://launchpad.net/bugs/1214352

The problem with KDE is another problem, mostly related to missing packages:

- For the build from distro repositories, you should also install 'gvfs' and 'gvfs-smb' packages for Fedora, or 'gvfs', 'gvfs-backends', 'libreoffice-gnome' for Ubuntu.

- For the build from libreoffice.org, you should also install 'gnome-vfs2', 'gnome-vfs2-smb', 'ORBit2' for Fedora, or 'libgnomevfs2-0', 'libgnomevfs2-extra', 'liborbit2'. You should also export 'OOO_FORCE_DESKTOP=gnome', otherwise it won't work.
Comment 60 gegon69 2014-02-27 15:08:21 UTC
I have the same problem with version 4.1.5.3
mainly libreoffice files .odt .ods .odp

My SO: Ubuntu 12.04
Comment 61 Renato S. Yamane 2014-03-08 15:48:41 UTC
Same problem.
Kubuntu 13.10
Libreoffice 4.1.5 (PPA)
Comment 62 Koen Roggemans 2014-03-11 19:33:20 UTC
Same problem on Ubuntu 12.04/64 with LibreOffice 4.2.1.1 (ppa)
Comment 63 dduck 2014-03-14 13:23:13 UTC
Same problem on Ubuntu 12.04/64 with LibreOffice 4.2.1.1 (download from LO site)
Comment 64 sophie 2014-03-17 16:52:07 UTC
*** Bug 75055 has been marked as a duplicate of this bug. ***
Comment 65 Björn Michaelsen 2014-03-21 13:41:49 UTC
*** Bug 58236 has been marked as a duplicate of this bug. ***
Comment 66 Bryan Berndt 2014-07-30 20:56:14 UTC
(In reply to comment #59)
> @iveand, Bryan Berndt: Too bad you didn't read carefully the whole thread.
> Anyway, here is a summary:
> 
> - The repair dialog is an Ubuntu 12.04 specific bug, related to glib
> package. See https://launchpad.net/bugs/1214352
> 
> The problem with KDE is another problem, mostly related to missing packages:
> 
> - For the build from distro repositories, you should also install 'gvfs' and
> 'gvfs-smb' packages for Fedora, or 'gvfs', 'gvfs-backends',
> 'libreoffice-gnome' for Ubuntu.
> 
> - For the build from libreoffice.org, you should also install 'gnome-vfs2',
> 'gnome-vfs2-smb', 'ORBit2' for Fedora, or 'libgnomevfs2-0',
> 'libgnomevfs2-extra', 'liborbit2'. You should also export
> 'OOO_FORCE_DESKTOP=gnome', otherwise it won't work.

Upgraded to LO 4.3 with the rpm's from the LO web site. (rpm -U.....) Problem is recreated, as with every upgrade so far (comment 15).  Most of the packages you mention were already installed.  Then added  the export to a KDE environment script: http://forums.opensuse.org/showthread.php/478619-LibreOffice-looks-ugly-in-SUSE-KDE ; vairation of post #3.

I log into the SMB file server, and then when I double click the file I want to opem it asks to log in again, I assume that this is GVFS asking that.  Once I do, then file opens.
Comment 67 Maxim Monastirsky 2014-08-08 07:09:24 UTC
Again: This one doesn't need bibisecting.
Comment 68 Björn Michaelsen 2014-08-08 09:47:13 UTC
Scoping this bug clearly only on the missing deps for KDE thanks to the excellent summary in comment 59. Everything else is fdo#49776. Please dont scope-creep this bug, thanks.
Comment 69 Stephan Bergmann 2014-10-08 09:04:47 UTC
(In reply to Björn Michaelsen from comment #68)
> Scoping this bug clearly only on the missing deps for KDE thanks to the
> excellent summary in comment 59.

...which has become moot with <http://cgit.freedesktop.org/libreoffice/core/commit/?id=f9f9aa9873c5851da86d33ca75e937ac022206a3> "Remove smb from X-KDE-Protocols lines," see <http://lists.freedesktop.org/archives/libreoffice/2014-October/063904.html> "Re: X-KDE-Protocols=...,smb,..."
Comment 70 Norbert X 2015-02-24 22:14:27 UTC
I'm on Ubuntu 12.04.5 with all updates and LibreOffice Version: 4.4.1.2
Build ID: 40m0(Build:2) (libreoffice 1:4.4.1~rc2-0ubuntu1~precise1) from PPA.

What I did:
1. I have shared my Public folder using nautilus-share (0.7.3-1ubuntu2), placed test.odt file in it.
2. I navigate Nautilus to smb://localhost, and double clicked on test.odt file.
3. 'LibreOffice 4.4' dialog opened with text:
   
   "The file 'test.odt' is corrupt and therefore cannot be opened. LibreOffice can try to repair the file.

   The corruption could be the result of document manipulation or of structural document damage due to data transmission.

   We recommend that you do not trust the content of the repaired document.
Execution of macros is disabled for this document.

   Should LibreOffice repair the file?

   Yes     No"
4a. If I click 'Yes', the file is opened, but the title of the document is "Untitled 1 (repaired document)", not original name.
4b. If I click 'No', the dialog 'LibreOffice 4.4' is opened with text:
   The file 'test.odt' could not be repaired and therefore cannot be opened.

   OK"

   I click 'OK' here, the next window "LibreOffice 4.4.1.2" is opened with text:
   "General Error.
   General input/output error.

   OK"

   If I click OK here - no files are opened.


Bug exists in LibreOffice "Version: 4.3.6.2 Build ID: 430m0(Build:2)" (1:4.3.6~rc2-0ubuntu1~precise1) too.

This functionality is essential. Please fix this bug.
I (and you) can't tell Windows users, that they should not open office files from network shares in GNU/Linux.
Comment 71 Björn Michaelsen 2015-02-24 22:35:15 UTC
(In reply to Norbert X from comment #70)
> I'm on Ubuntu 12.04.5 with all updates and LibreOffice Version: 4.4.1.2
> Build ID: 40m0(Build:2) (libreoffice 1:4.4.1~rc2-0ubuntu1~precise1) from PPA.

see comment 59: Ubuntu 12.04 means you have a broken glib: https://bugs.launchpad.net/ubuntu/+source/glib2.0/+bug/1214352

Unless there is evidence that your troubles are not caused by this (which would mean: patching glib on Ubuntu 12.04 _and_ rebuilding _ALL_ packages that use it), your bug is lp#1214352 and not fdo#67527 -- which also means nothing _in_ _LibreOffice_ can be done to fix your problem.

Thanks.
Comment 72 Norbert X 2015-02-28 20:40:35 UTC
Thank you, Björn Michaelsen!
I understood about Ubuntu 12.04. I wrote about bug on launchpad and sent e-mail to ubuntu-devel-discuss@lists.ubuntu.com.

I did some research with different versions of LibO and on different distros.
The test method was as follows: I set Samba public share on my other laptop, created document in this share, then connect to it.
Here is a Google Docs Table (goo.gl/jY9Ubj):
* I got message about repairing only in 12.04.5 with LibO 4.x
* In other distros I got 'Document in Use' very often.

After this research I can't determine why 'Document in Use' message is produced.
Comment 73 Hilario Fochi Silveira 2015-03-18 20:04:25 UTC
RHEL (Centos) 7.0.1406 / LibreOffice 4.1.4.2  / KDE 4.10.5

We have tried to implement the instructions in post 59 but nothing really worked, not at all.

The only hint that worked partially, but very badly was to comment out the #X-KDE-Protocols=file,http,smb,ftp,webdav as described in post 15.

When you double click a document LibreOffice opens in fact a copy located in /var/tmp/kdecache-.../krun. LO saves only this copy. When you close this document, LO still does nothing. When you close LO itself, there is a new windows asking you to upload your changes to the samba server.

It is up to the end user to control if the document should or not be updated in the samba server. Also, as this solution does not create the corresponding ~lock file, the samba server does not know that the file is being edited and this can lead to many people editing the same file simultaneously leading to unpredictable results and loss of data.

We are in the process of substituting all legacy windows machines for linux desktops, but this issue is really a show stopper. 

Shouldn't this bug be reopened up to a final solution?

Are there any well behaving work-around for this?
Comment 74 Stephan Bergmann 2015-03-19 11:34:45 UTC
(In reply to Hilario Fochi Silveira from comment #73)
> Shouldn't this bug be reopened up to a final solution?

For a final solution, see the closing paragraph of <http://lists.freedesktop.org/archives/libreoffice/2014-October/063904.html> "Re: X-KDE-Protocols=...,smb,...," i.e., bug 70712:

"Ultimately, the best approach (if technically possible) would probably 
be to have some KDE-specific backend in LO for smb (etc.) URLs, similar 
to the --enable-gio resp. --enable-gnome-vfs GNOME-specific backends, so 
that LO could receive smb URLs from Dolphin but would not need to rely 
on GNOME-related functionality to access them, cf. 
<https://bugs.freedesktop.org/show_bug.cgi?id=70712> 'KDE: Support of 
opening and saving to a remote fs via KIO.'"
Comment 75 andis.lazdins 2015-11-17 06:50:00 UTC
Just today got this error again with Libreoffice 4.5 on Ubuntu 14.04, Mate
The workaround sed -i 's/X-GIO-NoFuse=true/#X-GIO-NoFuse=true/' /usr/local/share/applications/libreoffice* works as always. I'm just wandering, why this option is not implemented by default. It would save a lot of time.
Comment 76 Pier Paolo Alberoni 2015-11-25 11:25:55 UTC
Hi, I install libreOffice.5.0.3 on  fedora 20 few days ago and I ran in the same problem.

The workaround sed -i 's/X-GIO-NoFuse=true/#X-GIO-NoFuse=true/' /usr/share/applications/libreoffice* works.

I support the previous comment.

Cheers Pier Paolo
Comment 77 Mamoth 2017-03-16 11:37:32 UTC
Hello.

I run Linux Mint 17.3 Cinnamon (so using Nemo 2.8.7 as a file browser) and I have the same issue with LO 5.3.0.3 .

The soution in comment 15 (putting in comment the line "X-GIO-NoFuse=true" in file  /usr/share/applications/libreoffice-writer.desktop) works indeed. Of course, the fix has to be done in al the libreoffice-XXXX.desktop files.
Comment 78 Mamoth 2017-03-16 11:41:03 UTC
Hello.

I run Linux Mint 17.3 Cinnamon (so using Nemo 2.8.7 as a file browser) and I have the same issue with LO 5.3.0.3 .

The soution in comment 15 (putting in comment the line "X-GIO-NoFuse=true" in file  /usr/share/applications/libreoffice-writer.desktop) works indeed. Of course, the fix has to be done in al the libreoffice-XXXX.desktop files.
Comment 79 Mamoth 2017-03-21 14:59:40 UTC
Hello.

I tried the same solution on another PC running Xubuntu 16.04 with LO 5.1.6.2. It makes a "General input/output error".
Comment 80 Mamoth 2017-03-21 15:34:32 UTC
PS: I tried upgrading LO using LO's generic PPA, obtaining LO 5.3.1 and re-editing the libreoffice-XXXX.desktop files, but not no avail.