Download it now!
Bug 82038 - Other: Send as --email error
Summary: Other: Send as --email error
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other Mac OS X (All)
: medium major
Assignee: Stephan Bergmann
URL:
Whiteboard: BSA target:4.4.0 target:4.3.5 target:...
Keywords: regression
: 82389 82443 82495 82819 83105 85752 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-02 04:49 UTC by Greg
Modified: 2014-11-11 16:38 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen shots and system configuration text report (122.21 KB, application/zip)
2014-08-02 04:49 UTC, Greg
Details
SimpleCommandMail.hpp generated with master sources (3.63 KB, application/octet-stream)
2014-08-10 13:14 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Greg 2014-08-02 04:49:20 UTC
Created attachment 103850 [details]
Screen shots and system configuration text report

Email settings are correct in preferences (points to /Applications/Mail). Oracle Java 1.8 is enabled/selected in Preferences/advanced

Current behavior:  
When I choose "Send" (No matter which email choice I select), I get a dialog box saying:

"An error occurred in sending the message. Possible errors could be a missing user account or a defective setup. Please check the LibreOffice settings or your e-mail program settings."




Expected behavior:

Email opens up (with the chosen content) so I can address it. -- 
              
Operating System: Mac OS X
Version: 4.3.0.4 release
Comment 1 Julien Nabet 2014-08-02 06:03:43 UTC
Greg: just for information, did it work with previous version or is it your first LO install?
Comment 2 Greg 2014-08-02 07:48:40 UTC
No problem with previous versions sending email copies in assorted formats -- I used that feature 3-6 times a month.   New behavior for this version.

  Current work-around is "save as" then set up an email and add the saved attachment.


On Friday, August 1, 2014 11:03 PM, "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org> wrote:
 

>
>
> 
>Julien Nabet  changed bug 82038 
>
>What
>Removed
>Added
>CC    serval2412@yahoo.fr  
>See Also    https://bugs.freedesktop.org/show_bug.cgi?id=43277  
>Comment # 1 on bug 82038 from Julien Nabet  
>Greg: just for information, did it work with previous version or is it your
first LO install?
>________________________________
> You are receiving this mail because: 
>	* You are on the CC list for the bug.
>	* You reported the bug.
>
>
Comment 3 Julien Nabet 2014-08-09 06:21:11 UTC
With 4.3.0.4, I could reproduce this.
I don't reproduce this with 4.2.6 -> regression
but dup with 43277

*** This bug has been marked as a duplicate of bug 43277 ***
Comment 4 Julien Nabet 2014-08-10 12:50:04 UTC
*** Bug 82389 has been marked as a duplicate of this bug. ***
Comment 5 Julien Nabet 2014-08-10 12:53:17 UTC
Some gdb + adding some message in catch exception, I got this:
component context fails to supply service 'com.sun.star.system.SimpleCommandMail' of type 'com.sun.star.system.XSimpleMailClientSupplier'

from this part:
744         if ( ! xSimpleMailClientSupplier.is() )
745         {
746             try {
747                 xSimpleMailClientSupplier = SimpleCommandMail::create( xContext );
748             }
749             catch ( const uno::Exception & )
750             {}
751         }
See http://opengrok.libreoffice.org/xref/core/sfx2/source/dialog/mailmodel.cxx#744
Comment 6 Julien Nabet 2014-08-10 13:06:11 UTC
Stephan: This problem isn't present on Linux, any idea if it could be related with Uno part?
Comment 7 Julien Nabet 2014-08-10 13:14:36 UTC
Created attachment 104382 [details]
SimpleCommandMail.hpp generated with master sources
Comment 8 Stephan Bergmann 2014-08-11 08:27:31 UTC
This apparently got broken with <http://cgit.freedesktop.org/libreoffice/core/commit/?id=ee39446353a7fd6ba28b6fcf915bc6c020f3bda6> "Why would we need GNOME and KDE scripts on OS X?" which (accidentally?) stopped building shell/Library_cmdmail.mk for MACOSX.

Tor, can you have a look please?
Comment 9 Commit Notification 2014-08-11 09:38:03 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a59e2d4f05679142f10950c15a78b952ef0aac9e

fdo#82038: Make sending email from LO work again on OS X



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Adolfo Jayme 2014-08-11 23:44:26 UTC
*** Bug 82443 has been marked as a duplicate of this bug. ***
Comment 11 Julien Nabet 2014-08-12 13:00:17 UTC
*** Bug 82495 has been marked as a duplicate of this bug. ***
Comment 12 Maxim Monastirsky 2014-08-19 15:26:20 UTC
*** Bug 82819 has been marked as a duplicate of this bug. ***
Comment 13 Commit Notification 2014-09-04 11:00:37 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5496d431f991ce9e8e0dc953d2cb1d40db899ee0&h=libreoffice-4-3

fdo#82038: Make sending email from LO work again on OS X


It will be available in LibreOffice 4.3.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Tino Hendricks 2014-10-16 20:15:00 UTC
Just downloaded and installed Version: 4.3.3.0.0+ Build ID: b3e96abc32623891a7147c9f8fa6477ffcddd643

Again (still?) 

"LibreOfficeDev was unable to find a working e-mail configuration.
Please save this document locally instead and attach it from within your e-mail client."
Comment 15 Rudolf Kollien 2014-11-04 14:25:44 UTC
In 4.3.2.2 on Mac OSX Yosemite too. 
Worked in previous version (4.1, as i remember).
Comment 16 Rudolf Kollien 2014-11-04 14:36:37 UTC
Still in 4.3.3.2.
Comment 17 Rudolf Kollien 2014-11-04 14:38:32 UTC
*** Bug 83105 has been marked as a duplicate of this bug. ***
Comment 18 Commit Notification 2014-11-06 13:13:39 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f3f63f555df87449b2d2a33718589b3afb3d9ddf

fdo#82038: senddoc, uri-encode got lost on Mac

It will be available in 4.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 19 Stephan Bergmann 2014-11-06 14:49:35 UTC
(In reply to Commit Notification from comment #18)
> Stephan Bergmann committed a patch related to this issue.
> It has been pushed to "master":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=f3f63f555df87449b2d2a33718589b3afb3d9ddf
> 
> fdo#82038: senddoc, uri-encode got lost on Mac
> 
> It will be available in 4.4.0.

requested backport to libreoffice-4-3 towards LO 4.3.4 at <https://gerrit.libreoffice.org/#/c/12289>
Comment 20 retired 2014-11-07 17:30:39 UTC
Verified: OSX 10.10

Version: 4.4.0.0.alpha2+
Build ID: bd15fb03dfc3a14b8f1f233080ec3084e0bf25be
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2014-11-07_07:29:01

Thanks a lot Stephan, this was very annoying.
Comment 21 retired 2014-11-07 17:32:05 UTC
*** Bug 85752 has been marked as a duplicate of this bug. ***
Comment 22 Commit Notification 2014-11-10 16:12:57 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cbf7cb4ab0c76932dd5e0db3958c163fac459114&h=libreoffice-4-3

fdo#82038: senddoc, uri-encode got lost on Mac

It will be available in 4.3.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 23 Stephan Bergmann 2014-11-10 17:08:58 UTC
(In reply to Commit Notification from comment #22)
> Stephan Bergmann committed a patch related to this issue.
> It has been pushed to "libreoffice-4-3":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=cbf7cb4ab0c76932dd5e0db3958c163fac459114&h=libreoffice-4-3
> 
> fdo#82038: senddoc, uri-encode got lost on Mac
> 
> It will be available in 4.3.4.

...should read "4.3.5" (bot bug).  Backport to libreoffice-4-3-4 requested at <https://gerrit.libreoffice.org/#/c/12336/>.
Comment 24 Commit Notification 2014-11-11 16:38:53 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-4-3-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3b928e097b61fbed0f6fd97d2755f1158091c9f6&h=libreoffice-4-3-4

fdo#82038: senddoc, uri-encode got lost on Mac

It will be available in 4.3.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.