Bug 114076 - FILEOPEN: artifacts on Images ( white lines )
Summary: FILEOPEN: artifacts on Images ( white lines )
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Armin Le Grand (CIB)
URL:
Whiteboard: target:6.1.0 target:6.0.3
Keywords: bibisected, bisected, regression
: 114803 115533 115694 115984 116271 116309 (view as bug list)
Depends on:
Blocks: EMF-WMF Images
  Show dependency treegraph
 
Reported: 2017-11-26 20:55 UTC by Xisco Faulí
Modified: 2018-03-09 16:18 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (32.04 KB, image/png)
2017-11-26 20:56 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-11-26 20:55:11 UTC
Steps to reproduce:
1. Open attachment 43525 [details] from bug 34454
2. Check Figures in page 5, 6 and 7

Observed behaviour: White lines ( artefacts ) are displayed on the images

Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: 2618e4a13d719122e6358d9d96864d1691e56a02
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: th-TH (ca_ES.UTF-8); Calc: group threaded
Comment 1 Xisco Faulí 2017-11-26 20:56:17 UTC
Created attachment 138001 [details]
screenshot
Comment 2 Xisco Faulí 2017-11-26 20:57:21 UTC
Regression introduced by:

author	Armin Le Grand <Armin.Le.Grand@cib.de>	2017-11-16 11:54:21 (GMT)
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2017-11-18 12:07:47 (GMT)
commit	059469926e359153b9b291790ef2df84fa63fda9 (patch)
tree	0afc7da1aa97c22250823ae43acdfdfd3fdd77b0
parent	d74b26b41bfea3ba7a1834953b2bfe9b7ff0d70f (diff)
RotateFlyFrame3: Corrected Contour when rotated
When rotated, the contour has to be adapted to that state
and also needs to be calculated in untransformed state,
added needed code. Also need to add a ClipRegion set at
the target OutputDevice (e.g. from Contour) to the prepared
GraphicPrimitive. It was sometimes used due to a VCL_Based
PrimitiveRenderer being used, but that is just a coincidence.

Bisected with: bibisect-linux64-6.0

Adding Cc: to Armin Le Grand
Comment 3 Xisco Faulí 2017-12-03 20:29:40 UTC
*** Bug 114222 has been marked as a duplicate of this bug. ***
Comment 4 Patrick Jaap 2017-12-07 10:30:44 UTC
I can confirm this bug.

For me ALL figures of the document are affected in current master. But it does not look like an EMF bug. It can be resolved by zooming in and out or dragging the pictures: the white lines will then disappear. Seems to be caused from scrolling actions.

I could not observe this behavior with other EMF+ pictures.

I will have a look into Armin's patch, which seems to cause this problem.
Comment 5 Xisco Faulí 2018-02-14 09:58:53 UTC
*** Bug 115694 has been marked as a duplicate of this bug. ***
Comment 6 Telesto 2018-02-14 14:37:48 UTC
*** Bug 114803 has been marked as a duplicate of this bug. ***
Comment 7 Telesto 2018-02-14 14:41:15 UTC
Only for the record. The problem isn't limited to EMF+ (see bug 114803). Normal image + anchoring as character
Comment 8 kompilainenn 2018-02-23 16:46:38 UTC
i have same problem with all PNG images in to my Writer documents.

LO 6.0.2.1 64 bit on Windows 7
Comment 9 Telesto 2018-02-24 08:11:35 UTC
*** Bug 115984 has been marked as a duplicate of this bug. ***
Comment 10 Telesto 2018-02-24 08:14:19 UTC
*** Bug 115533 has been marked as a duplicate of this bug. ***
Comment 11 Armin Le Grand (CIB) 2018-02-26 12:31:27 UTC
Just a repaint error, no problem in the model/loaded stuff. Press CTRL+SHIFT+R to repaint (one possibility, switches ruler - also possible to minimize/reshow window). Some BoundRect seems to be too small...
Comment 12 Armin Le Grand (CIB) 2018-02-26 14:01:10 UTC
Looking into it. Probably a missing 1/2Pixel due to rendering AAed, but Writer scrolling in pixels (a general weakness: When scrolling in pixels - and this is not possible to do diffefrently - the mapping aka ViewTransformation which has nowadays sub-pixel precision will not match with up to one pixel offset).
Comment 13 Armin Le Grand (CIB) 2018-02-26 14:02:50 UTC
Where it may happen: The general graphic paint (paintGraphicUsingPrimitivesHelper) in writer is using primitives now, and these use a ClipRegion that is set at the OutputDevice. Thus, all 'graphic' representations will be affected.
Comment 14 Armin Le Grand (CIB) 2018-02-26 14:14:42 UTC
Fix on gerrit. Checked locally scrolling in all directions, works as intended.
Comment 15 Commit Notification 2018-02-26 21:52:52 UTC
Armin Le Grand committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c1230cede19ae3633e51c7ca780cb34d9dbaa20f

tdf#114076: Expand ClipRange to next PixelBound

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Armin Le Grand (CIB) 2018-02-26 21:56:08 UTC
Fix in master, done.
Comment 17 Armin Le Grand (CIB) 2018-02-27 14:28:04 UTC
Cherry-picked to libreoffice-6-0 branch
Comment 18 Commit Notification 2018-02-27 16:14:13 UTC
Armin Le Grand committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e4d0e964b5be550c88c8c6693beca483c2ca1a1b&h=libreoffice-6-0

tdf#114076: Expand ClipRange to next PixelBound

It will be available in 6.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Xisco Faulí 2018-02-28 09:43:38 UTC
Verified in

Version: 6.1.0.0.alpha0+
Build ID: e2cb154195fdc2ffccdb6f5e87cae8b29640b3eb
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Thanks Armin!
Comment 20 Telesto 2018-03-09 14:04:38 UTC
@Xisco,
The patch didn't make it into 6.0.2 as far I can tell..
Comment 21 Telesto 2018-03-09 14:08:44 UTC
*** Bug 116271 has been marked as a duplicate of this bug. ***
Comment 22 Telesto 2018-03-09 14:09:02 UTC
*** Bug 116309 has been marked as a duplicate of this bug. ***
Comment 23 Xisco Faulí 2018-03-09 16:18:00 UTC
(In reply to Telesto from comment #20)
> @Xisco,
> The patch didn't make it into 6.0.2 as far I can tell..

You're right. it's not in https://wiki.documentfoundation.org/Releases/6.0.2/RC1...