Bug Hunting Session
Bug 82504 - EDITING: Background color button should fill cell background and not paragraph color when in a cell
Summary: EDITING: Background color button should fill cell background and not paragrap...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords: topicUI
: 61866 85540 88806 101090 114315 (view as bug list)
Depends on:
Blocks: Notebookbar-Tabbed Writer-Tables-Enhancements Button-Controls
  Show dependency treegraph
 
Reported: 2014-08-12 10:42 UTC by Yousuf Philips (jay) (retired)
Modified: 2019-02-10 07:29 UTC (History)
15 users (show)

See Also:
Crash report or crash signature:


Attachments
picture with to be changed button and the one to stay (63.04 KB, image/png)
2014-10-28 08:49 UTC, Cor Nouws
Details
Screenshots to demonstrate cell background bug (1012.12 KB, application/pdf)
2015-08-18 10:25 UTC, Norbert X
Details
Please see video, it is fixed? (1.22 MB, video/mp4)
2019-01-22 19:45 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-08-12 10:42:43 UTC
Steps:
1) Open Writer
2) Create a table
3) While in a cell, click on the background color icon in the table toolbar
4) It will not fill the cell background but the paragraph background

Tested in 3.3.0, 4.3.2 and master. This is quite confusing because the background color icon in calc fills the cell background and the background color icon even in the table toolbar in writer fills the paragraph background.
Comment 1 Cor Nouws 2014-08-12 11:12:17 UTC
Hi Jay,

(In reply to comment #0)

> 3) While in a cell, click on the background color icon in the table toolbar

Isn't that the icon with 'ab', iow, bacjground color for text ?
One would indeed  wish that that is an icon for the cell's background, that one currently can set by selecting a cell (or more) and then Table properties, tab Background..
So If this is true, this should be an enhancement for another icon on the toolbar :)
Ciao!
Cor
Comment 2 sophie 2014-08-12 12:50:37 UTC
Hi Jay, for me this is neither a bug nor an enhancement:
- background of the paragraph --> just as you did
- background of the cell --> select the cell and click on the background color icon. 
The background icon reacts depending on the mode your are, if you are in edit mode in the table, that will affect the paragraph, if you're in selection mode, that will affect the cell. Closing as works for me. Please reopen if you disagree :) Sophie
Comment 3 Yousuf Philips (jay) (retired) 2014-08-12 13:27:47 UTC
After both Cor and Sophie's comments, its hard decide which of these two options to go forward with for this issue.

1) that the default behaviour of the background icon should always be to set a cell's background color if inside a cell.

2) that a cell background color icon be created for the table toolbar and the formatting toolbar be used exclusively for paragraph background color.

One of the benefits i see with a dedicated cell background color icon is that it would work correctly whenever a table properties section comes in the sidebar.
Comment 4 retired 2014-08-13 10:07:12 UTC
Can son
Comment 5 Cor Nouws 2014-08-13 11:05:56 UTC
(In reply to comment #2)

> - background of the cell --> select the cell and click on the background
> color icon. 

For me it does not in master (where I initially tested ;) > new bug.
Comment 6 Cor Nouws 2014-08-13 11:07:54 UTC
(In reply to comment #3)

> One of the benefits i see with a dedicated cell background color icon is
> that it would work correctly whenever a table properties section comes in
> the sidebar.

It's also not correct that the Icon shows 'ab' when it's supposed to do the cells background..
Comment 7 Cor Nouws 2014-08-13 11:13:16 UTC
(In reply to comment #5)

> For me it does not in master (where I initially tested ;) > new bug.

   see bug 82555
Comment 8 Yousuf Philips (jay) (retired) 2014-08-13 11:27:01 UTC
Not sure what you mean by 'ab'. A screenshot would be good.
Comment 9 Yousuf Philips (jay) (retired) 2014-10-28 07:07:18 UTC
*** Bug 85540 has been marked as a duplicate of this bug. ***
Comment 10 Yousuf Philips (jay) (retired) 2014-10-28 07:25:40 UTC
(In reply to Jay Philips from comment #3)
> 1) that the default behaviour of the background icon should always be to set
> a cell's background color if inside a cell.

I think this is the best choice, as users in coming from calc are used to clicking the same background color icon to fill the cell.
Comment 11 Luke 2014-10-28 07:36:58 UTC
See attachment 108550 [details] for a Sample table demonstrating the issue

Steps to reproduce
1) In Writer create a table
2) In one Cell use Table Toolbar->Background->green
3) In another cell, Table->Table Properties->Background->green

Expected Results:
Cell from 2) looks like Cell from 3)

Actual Results:
Cell 2) is just partially filled with a white border
Comment 12 Cor Nouws 2014-10-28 08:49:11 UTC
Created attachment 108560 [details]
picture with to be changed button and the one to stay

Hi Jay, *

> I think this is the best choice, as users in coming from calc are used to
> clicking the same background color icon to fill the cell.

Yes, that's by far best. Add since change paragraph background is still on the standard toolbar, people can choose.
I would suggest another icon too when changing the behaviour..
Comment 13 Yousuf Philips (jay) (retired) 2014-11-21 13:39:21 UTC
Setting this to enhancement.
Comment 14 Luke 2015-01-24 08:32:58 UTC Comment hidden (obsolete)
Comment 15 Yousuf Philips (jay) (retired) 2015-01-25 11:42:13 UTC Comment hidden (obsolete)
Comment 16 Cor Nouws 2015-02-03 10:08:29 UTC
*** Bug 88806 has been marked as a duplicate of this bug. ***
Comment 17 Norbert X 2015-08-18 10:25:21 UTC
Created attachment 117994 [details]
Screenshots to demonstrate cell background bug

Dear all. I have the same problem. I was going to report new bug and went to this report. I reported a bug to Ubuntu Launchpad (https://bugs.launchpad.net/bugs/1485955) too.
Here are my bug report and screenshots.

> Steps to reproduce:
>    1. Launch LibreOffice Writer
>    2. Insert table to the new document (Table -> Insert -> Table)
>    3. Write some multirow text in table cells
>    4. Try to change cell background:
>       4.1. place cursor on desired cell
>       4.2. select color from palette from "Background Color" drop-down (located on Table toolbar).
>       4.3. click "Background Color" button on Table toolbar.
>
> Expected results:
>    background color of TABLE CELL (where cursor was) is changed to desired color.
>
> Actual results:
>    background color of TEXT PARAGRAPH (where cursor was) is changed to desired color.
>
> Workaround:
>    There is slow non-intuitive background - select whole cell, select color from palette from "Background Color" drop-down (located on Table toolbar), click "Background Color" button on Table toolbar.
>
> Affected versions:
>    LibreOffice 3.5.7.2 Build ID: 350m1(Build:2) = pre-installed Ubuntu 12.04.5 LTS version;
>    LibreOffice 4.2.7.2 Build ID: 420m0(Build:2) = pre-installed Ubuntu 14.04.2 LTS version;
>    LibreOffice 4.4.2.2 Build ID: 40m0(Build:2) = pre-installed Ubuntu 15.04 version.
>
> Comment:
>    I can't believe how this bug is possible. It is inherited from OO.org (I saw it on OO.org 3.2 in Ubuntu 10.04.4 LTS too).
>    Microsoft Word 2003 and 2007 of course have normal behaviour with cell background.
>    I attached pdf document with screenshots.

Bug exists in LibO 5 too.

So please confirm this bug. For me it seems that priority should be Normal. This is a very often used functionality. Thank you!
Comment 18 Cor Nouws 2015-08-18 11:04:31 UTC
Hi Norbert,

Thanks for posting that information here and for reminding that..

(In reply to Norbert X from comment #17)

> So please confirm this bug. For me it seems that priority should be Normal.

The bug is confirmed, proposed solution in comment #12. So I'll change settings accordingly.
Comment 19 Yousuf Philips (jay) (retired) 2015-08-18 20:53:50 UTC
(In reply to Cor Nouws from comment #12)
> Created attachment 108560 [details]
> picture with to be changed button and the one to stay

The 'ab' icon is limited to sifr.

> Yes, that's by far best. Add since change paragraph background is still on
> the standard toolbar, people can choose.
> I would suggest another icon too when changing the behaviour..

Paragraph background is no longer by default in the standard toolbar since 4.4. There isnt a need for a new icon as a new UNO command isnt being created, but the behaviour of the command is acting the same as when you select a cell as when you are inside a cell as using the button.
Comment 20 Norbert X 2015-08-31 18:42:57 UTC Comment hidden (obsolete)
Comment 21 Robinson Tryon (qubit) 2015-12-13 11:24:13 UTC Comment hidden (obsolete)
Comment 22 Maxim Monastirsky 2017-01-09 21:41:44 UTC
*** Bug 101090 has been marked as a duplicate of this bug. ***
Comment 23 bordfeldt 2017-06-10 17:28:36 UTC
This problem still exists in LO 5.3.3.2. 

My opinion is, that it is very illogical and distracting that the background button in the table toolbar sets the paragraph background color and not the cell background color.

In this bug report in comment 2 from sophie I found in the first place the ability to resolve this issue: That I have to select the cell first and can then do the backgound operations with the button in the table toolbar. It should be enough, to put the cursor in a cell to change its background color.

I think in the table toolbar should be only functions which deal with table- and not with paragraph-settings.

In the breeze-icon-set there should be two different icons for the buttons for cell- and paragraph-background, too. 

It would be useful too, if the functionality would be the same in "table-toolbar -> background color" and in the table-properties-dialogue->Background-settings.
Comment 24 Shunesburg69 2017-06-10 17:42:14 UTC Comment hidden (me-too)
Comment 25 Yousuf Philips (jay) (retired) 2017-06-11 02:30:17 UTC Comment hidden (obsolete)
Comment 26 Shunesburg69 2017-06-27 16:34:57 UTC Comment hidden (off-topic)
Comment 27 Daniel Grigoras 2017-06-27 16:48:58 UTC Comment hidden (off-topic)
Comment 28 Heiko Tietze 2017-07-31 15:38:21 UTC
*** Bug 61866 has been marked as a duplicate of this bug. ***
Comment 29 Norbert X 2017-09-01 16:59:17 UTC Comment hidden (obsolete)
Comment 30 Maxim Monastirsky 2017-12-07 19:54:07 UTC
*** Bug 114315 has been marked as a duplicate of this bug. ***
Comment 31 bordfeldt 2018-02-04 14:30:36 UTC
Bug still exists in 6.0.0.3 on Windows 10 pro.
Comment 32 Luke 2018-04-29 15:11:53 UTC
With all the interest and dupes this would make a good 100 paper cuts project.
Comment 33 Jim Raykowski 2018-12-15 10:07:52 UTC
Hi All,

To set a single table cell background the Table Properties dialog Background tab page can be used.

Currently the Background Color button will only set the cell background color for multi-selected table cells. For non multi-selected cells the paragraph background color is set for the cell with the cursor.

Here is a patch that makes the Background Color button set cell background color, not paragraph color, for the cell with the cursor:

https://gerrit.libreoffice.org/#/c/65195/

Testing and comments appreciated.
Comment 34 Commit Notification 2019-01-06 19:16:29 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/47e9db9c8490167e265b17ae44bb790a160703b5%5E%21

tdf#82504 writer table cell background color SvxColorItem uno function

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 35 BogdanB 2019-01-22 19:45:35 UTC
Created attachment 148529 [details]
Please see video, it is fixed?

Tested on 6.3 from 21.01.2019 but I think it is not fixed. Please see my video.

I tested 3 different options which a user could think is a background (as the tooltip says). But it is not a backgroud, just a paragraph background.

Version: 6.3.0.0.alpha0+
Build ID: 1e38d5b976dacd8b42b8330b4b9635a058ffe20b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-01-21_21:44:37
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 36 Daniel Grigoras 2019-01-22 20:22:32 UTC
(In reply to BogdanB from comment #35)
> Created attachment 148529 [details]
> Please see video, it is fixed?

Well, it's not fixed. The first option should fill with colour the entire cell.
Comment 37 Telesto 2019-01-22 21:03:22 UTC
(In reply to BogdanB from comment #35)
> Created attachment 148529 [details]
> Please see video, it is fixed?
> 
> Tested on 6.3 from 21.01.2019 but I think it is not fixed. Please see my
> video.
> 
> I tested 3 different options which a user could think is a background (as
> the tooltip says). But it is not a backgroud, just a paragraph background.
> 
> Version: 6.3.0.0.alpha0+
> Build ID: 1e38d5b976dacd8b42b8330b4b9635a058ffe20b
> CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
> TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
> 2019-01-21_21:44:37
> Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
> Calc: threaded

Hmm, looks partially fixed.. Fine with the Table toolbar, but not working in tabbed mode.

Version: 6.3.0.0.alpha0+
Build ID: 6740443311268b7d918bf4f43134d64fb78a0109
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-15_23:37:04
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 38 BogdanB 2019-01-23 04:58:31 UTC
"ab" button in standard layout is changeing the background indeed, the same as contextual menu.

But I wait for the tabed toolbar to be fixed to mark this as fixed...
Comment 39 Jim Raykowski 2019-02-09 22:50:40 UTC
Hello All,

From Jay's original post:

Step 3: While in a cell, click on the background color icon in the table toolbar

IMHO, since this bug report is specific to the background color icon in the table toolbar I believe the status of this bug report should be changed to Fixed and that other related bugs should be opened in new bug reports.
Comment 40 Buovjaga 2019-02-10 07:29:34 UTC
Right, one report per issue. Please someone create new reports and mention them in a comment.