Bug 31865 - [Task]: LibreOffice 3.3 release blockers / stoppers
Summary: [Task]: LibreOffice 3.3 release blockers / stoppers
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Rainer Bielefeld Retired
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on: 30929 31585 31654 31716 31741 31770 31805 31833 31938 32052 32126 32133 32142 32185 32193 32196 32229 32250 32304 32330 32338 32435 32563 32583 32635 32897 33049 33088 33099 33105 33108 33135
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-23 08:41 UTC by Rainer Bielefeld Retired
Modified: 2011-01-25 09:19 UTC (History)
13 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2010-11-23 08:41:07 UTC
This is the Meta issue to track the potential stoppers for the release of LibO
3.3.

If anyone wants to raise an Bug for the release, please add the Bug ID as dependent Bug here to the Meta Bug in field "Depends on". Additionally please leave a comment here why you want to declare that issue as a blocker for a.m. release.
Comment 1 Rainer Bielefeld Retired 2010-11-23 08:47:28 UTC
Nominate Bug 31494 - LibreOffice 3.3 crashes upon exiting on Windows:
It seems that no "real" problems exists, but such a visible error message is too deterring for new LibreOffice users.
Comment 2 Don't use this account, use tml@iki.fi 2010-11-23 09:04:17 UTC
Well, bug #31494 is already fixed, in the sense that there is a workaround in place that causes it not to happen. (The same workaround was already present in 3.2.1.) That bug is kept open because we would of course like to know, and fix, the root cause to the problem. (Also, the workaround has been added to the libreoffice-3-3 branch only.) So bug #31494 is not really a blocker.
Comment 3 manj_k 2010-11-23 15:19:14 UTC
CC
Comment 4 Thorsten Behrens (CIB) 2010-11-23 15:35:23 UTC
Nominate bug 31654 - clearly that's a regression relative to 3.2.1
Comment 5 Yifan Jiang 2010-11-23 22:32:38 UTC
Nominate bug #30929 - c#5

Printing crash using some documents, the issue is still being investigated. It would be severe if impacts more wide than we have observed. 

It is a regression against 3.2.1.
Comment 6 Eliot the Cougar 2010-11-24 01:51:51 UTC
Nominate bug #31134
Unable to make presentations with multiple backgrounds: "Apply background to the current slide only" does not work in Impress... Only one background entry is present in styles.xml

This is regression since OpenOffice.org 3.1
Comment 7 Don't use this account, use tml@iki.fi 2010-11-25 06:33:58 UTC
I think we need to have here only bugs that cause crashes in common sitautions, or make the application practically unusable in some common situation. Missing functionality, even if it is a regression, is not a blocker. So I would like to drop bug #31134 from this list?
Comment 8 Rainer Bielefeld Retired 2010-11-25 23:23:54 UTC
@Tor:
I believe "crashes only" is a too narrow definition for blockers.
Concerning bug 31134 please see my comments on the bug page.
Comment 9 Volker Merschmann 2010-11-26 03:21:33 UTC
Adding me to CC
Comment 10 Petr Mladek 2010-11-26 07:04:59 UTC
Note that I proposed definition of blocker bug at
http://wiki.documentfoundation.org/Release_Criteria
Comment 11 Kohei Yoshida 2010-11-26 08:04:01 UTC
Nominating bug 31308 as a blocker.  Several popup icons not working at all on Windows.
Comment 12 Kohei Yoshida 2010-11-26 08:08:06 UTC
Nominating bug 31741 and bug 31833 as blockers.
Comment 13 Michael Meeks 2010-11-26 08:39:29 UTC
added known broffice branding issue.
Comment 14 Rainer Bielefeld Retired 2010-11-28 06:21:49 UTC
Nominate: Bug 31770 - BrOffice brand and LibreOffice
Nominate: Bug 31585 - Writer crashes on mail merge
Comment 15 Rainer Bielefeld Retired 2010-11-28 09:02:38 UTC
Nominate: Bug 31734 - Loading many small documents causes crash

Currently it seems that this one will be the last one of existing bugs I want to nominate.
Comment 16 Petr Mladek 2010-11-29 06:57:31 UTC
Remove bug 31134 - can't save different background images per slide

Reason: old bug, less common scenario
Comment 17 Kohei Yoshida 2010-11-30 08:02:31 UTC
Nominating Bug 31805 as a blocker.  It's a simple little thing, but it is a regression, and has been a long standing bug since the Go-OO time.  I'd like to fix it once and for all.
Comment 18 Kohei Yoshida 2010-11-30 18:30:21 UTC
I just filed Bug 32007 - EvolutionLocal database has no table to display.  Do you guys think that this should be a blocker?  It's not life-threatening, but a bit weird and embarrassing.  Also, the fix may be potentially very simple.
Comment 19 Yifan Jiang 2010-11-30 19:21:40 UTC
Nominate bug 32010 - LibO crashes when clicking a Table control body with control design mode off.

Though I am not sure how many users will use this function, in my side, this can only be revealed by an exceptional automation testing log.

This risky scenario happens when a user opens a document contains a 'Table control'. By default, LibreOffice opens a document with Design mode Off. So whenever the user click a control table body, Libreoffice will crash always.
Comment 20 Don't use this account, use tml@iki.fi 2010-12-01 01:27:31 UTC
I don't think bug #32007 is a blocker, it appears in quite rarely used functionality, as far as I can guess. And if the user doesn't know what an "EvolutionLocal" is, why would he/she click it (except just to intentionally test what happens)?
Comment 21 Yifan Jiang 2010-12-01 03:22:57 UTC
(In reply to comment #19)
> Nominate bug 32010 - LibO crashes when clicking a Table control body with
> control design mode off.
> 
> Though I am not sure how many users will use this function, in my side, this
> can only be revealed by an exceptional automation testing log.
> 
> This risky scenario happens when a user opens a document contains a 'Table
> control'. By default, LibreOffice opens a document with Design mode Off. So
> whenever the user click a control table body, Libreoffice will crash always.

Take out this from blocker, the issue only happens when Assistive Technologies enabled.
Comment 22 Michael Meeks 2010-12-06 02:01:18 UTC
suggest add 32126 (Oracle mention wrt. ODF icons & formats in alt text).
Comment 23 Rainer Bielefeld Retired 2010-12-06 10:08:50 UTC
Nominate Bug 32142 - Replace "Beta" download buttons for stable release
As reminder
Comment 24 Kohei Yoshida 2010-12-06 20:19:59 UTC
I'd like to nominate Bug 32133 - [RC1] overlapping controls on Tools - Options - General panel.
Comment 25 Don't use this account, use tml@iki.fi 2010-12-07 03:53:58 UTC
Adding bug #31716 back.
Comment 26 Kohei Yoshida 2010-12-07 12:56:34 UTC
Nominating Bug 32196 (Data Form shows corrupted string) as a blocker.  This is just ugly, plus the fix will be relatively safe and easy.
Comment 27 Kohei Yoshida 2010-12-07 19:46:16 UTC
Nominating Bug 32209 as a blocker.  A hard-coded English only string which should really be localized.
Comment 28 Petr Mladek 2010-12-08 09:46:02 UTC
Nominating bug #32185. The libreoffice string translations were not used in the Windows build.
Comment 29 Igor Kovalyov 2010-12-09 00:09:46 UTC
Nominating bug #31820. I can't setup LibO 3.3 rc 1 on 2 computers with Windows 7 x64 due to this bug.
Comment 30 Jean-Baptiste Faure 2010-12-09 01:11:51 UTC
Nominating bug 32250 : installation of RC1 impossible on small HD under XP. Regression to beta3. RC1 asks for 4 times free space than OOo.
Comment 31 Cédric Bosdonnat 2010-12-09 01:43:39 UTC
blockers badly added: fixed
Comment 32 Kohei Yoshida 2010-12-10 19:05:48 UTC
I would like to nominate Bug 32304.  Saving an Impress document to ppt with grouped object(s) corrupts the file.
Comment 33 Gökçen Eraslan 2010-12-12 03:27:03 UTC
There is a serious encoding problem about non-ascii letters in MS Office formats (bug 32219), also a related issue is reported here[1].

[1] http://www.openoffice.org/issues/show_bug.cgi?id=114482
Comment 34 Rainer Bielefeld Retired 2010-12-12 08:28:17 UTC
Nominate Bug 32338 - [WIKIHELP]: Missing context sensitive Help
Comment 35 Michael Meeks 2010-12-14 02:57:49 UTC
Olivier suggest 32377 as a blocker; though there is perhaps a suitable workaround for him there now.
Comment 36 Don't use this account, use tml@iki.fi 2010-12-14 04:22:04 UTC
I suggest bug #31518.
Comment 37 Petr Mladek 2010-12-14 08:14:54 UTC
(In reply to comment #36)
> I suggest bug #31518.

I do not see it in the plain LibreOffice build. I think that it is related to the Novell branding. It would have been better to report it in the Novell bugzilla. In each case, it should not block the LibreOffice release.
Comment 38 Don't use this account, use tml@iki.fi 2010-12-14 08:27:00 UTC
Ah, good point.
Comment 39 Petr Mladek 2010-12-14 09:27:37 UTC
Nominate the bug #32229. It describes some more BrOffice branding problems.
Comment 40 Rainer Bielefeld Retired 2010-12-16 04:13:27 UTC
Nominating Bug 30571 - Dragging some toolbars on the left side makes them unusable. That's not totally compatible with our blocker definition, but imho too visible to leave it as a known bug
Comment 41 Netanel_H 2010-12-25 11:30:16 UTC
Suggest issue 32583 - Hebrew language pack not usable because of wrong folder.
Comment 42 mal 2011-01-04 01:41:32 UTC
I would like to nominate bug 32573
Not being able to print landscape 
is a bit of a problem for a word 
processor
Comment 43 Don't use this account, use tml@iki.fi 2011-01-04 04:19:33 UTC
Note that there seems to be some confusion about what it means to "nominate" a bug here.

In my opinion, nominating a bug as a blocker is just a request for comments and discussion that eventually then will end up with a consensus (or developer decision) to accept or reject the bug being as a blocker.

Others seem to take each nomination as an immediate change in status of the bug to blocker.

Which is correct? Is "nominate" a synonym of "make a candidate", (as in "nominate somebody to be a candidate in an election") or a synonym to "make"?

(Wiktionary lists both meanings, but says that the latter is obsolete.)
Comment 44 Petr Mladek 2011-01-04 05:04:30 UTC
(In reply to comment #42)
> I would like to nominate bug 32573. Not being able to print landscape is a bit 
> of a problem for a word processor.

I am not able to reproduce it. It seems to be system specific, so I do not consider it as a blocker for now.
Comment 45 Petr Mladek 2011-01-04 05:12:38 UTC
(In reply to comment #43)
> Note that there seems to be some confusion about what it means to "nominate" a
> bug here.
> 
> In my opinion, nominating a bug as a blocker is just a request for comments and
> discussion that eventually then will end up with a consensus (or developer
> decision) to accept or reject the bug being as a blocker.
> 
> Others seem to take each nomination as an immediate change in status of the bug
> to blocker.
> 
> Which is correct? Is "nominate" a synonym of "make a candidate", (as in
> "nominate somebody to be a candidate in an election") or a synonym to "make"?

I do not have any strong opinion here. I think that both ways are fine and it depends on the reporter's confidence. If it is evident blocker, it might be added to bug dependency immediately. If the reporter is not sure, it might be enough to mention it in the comment... We must investigate all nominated bugs before the release anyway. We could remove bugs from the list if there is a good reason and vice versa...
Comment 46 Petr Mladek 2011-01-04 05:16:22 UTC
(In reply to comment #41)
> Suggest issue 32583 - Hebrew language pack not usable because of wrong folder.

Looks like a real blocker => accepted
Comment 47 Petr Mladek 2011-01-04 05:39:30 UTC
(In reply to comment #40)
> Nominating Bug 30571 - Dragging some toolbars on the left side makes them
> unusable. That's not totally compatible with our blocker definition, but imho
> too visible to leave it as a known bug

It went out that it was pretty old bug even in OOo => not a blocker.
Comment 48 Petr Mladek 2011-01-04 05:51:54 UTC
(In reply to comment #35)
> Olivier suggest 32377 as a blocker; though there is perhaps a suitable
> workaround for him there now.

The extensions can be disabled in the Windows installer in LO-3.3-rc2 => should be solved.
Comment 49 Petr Mladek 2011-01-04 06:01:21 UTC
(In reply to comment #22)
> suggest add 32126 (Oracle mention wrt. ODF icons & formats in alt text).

Yup, I think that we should fix this => accepted.
Comment 50 Petr Mladek 2011-01-04 06:08:20 UTC
(In reply to comment #19)
> Nominate bug 32010 - LibO crashes when clicking a Table control body with
> control design mode off.

It happened only on Linux with 'Assistive Technologies' enabled. There were more similar problems with 'Assistive Technologies' in the past and were old bugs => not a blocker.
Comment 51 Petr Mladek 2011-01-04 06:11:54 UTC
(In reply to comment #15)
> Nominate: Bug 31734 - Loading many small documents causes crash
> 
> Currently it seems that this one will be the last one of existing bugs I want
> to nominate.

I guess that it is a pretty old bug. Also it is not typical scenario. If you open more than 10 documents, you have mess on the desktop, ...

I think that it might be a candidate for memory footprint and speedup  optimization but not a real blocker.
Comment 52 Petr Mladek 2011-01-06 02:55:50 UTC
Removing the bug #31820. The extensions registration fails only in some strange circumstances. It does not affect the base function...
Comment 53 Petr Mladek 2011-01-06 03:11:16 UTC
Added bug #32635. Another problem with BrOffice branding.
Comment 54 Andras Timar 2011-01-06 03:57:53 UTC
Added License Dialog
Added missing langpacks
Comment 55 Michael Meeks 2011-01-07 03:07:26 UTC
I've created a new task/tracker bug for issues for 3.3.1 as bug#32894#
Comment 56 Cor Nouws 2011-01-07 06:20:04 UTC
nominate Bug 32790 as stopper
Comment 57 ariel cornejo 2011-01-08 23:20:08 UTC
I'm nominating Bug #32929 ("Use system font for user interface" ignored) since this feature works fine in RC1 and is broken in RC2.
Comment 58 tester8 2011-01-09 12:13:11 UTC
Nominate Bug 32052 - hat, vector and tilde doesn't appear.
With this bug LibreOffice is unusable for physicist and some other scientists.
It is regression to OO 3.2.
Comment 59 Igor Kovalyov 2011-01-11 00:58:12 UTC
(In reply to comment #52)
> Removing the bug #31820. The extensions registration fails only in some strange
> circumstances. It does not affect the base function...

I have error on 4 computers with libreoffice rc2. And I don't have any workaround to install libreoffice on them, so I can't use "base function". After installation without "Optional components" I can't run any libreoffice application - see comments to #31820. At the same time openoffice 3.2 succesfully setups on all this 4 computers.

Nominating bug #31820 to release blockers again.
Comment 60 tester8 2011-01-12 16:40:06 UTC
Nominate Bug #32991 - FORMATTING TABLES Alignment lost when exporting to DOC
It is regression. Many people use tables, many people export to doc.
Would be nice to fix it.
Comment 61 alex 2011-01-12 19:05:45 UTC
hello friends,

there seems to be a grave problem: lo crashes after attempt to run python macros: bug #32939.

best regards,
alex
Comment 62 gleppert 2011-01-13 02:06:05 UTC
Hi,

I added this as a blocker bug: 
https://bugs.freedesktop.org/show_bug.cgi?id=32930

Writer crashes after copy&paste of content of certain web pages on Ubuntu.
Comment 63 Petr Mladek 2011-01-13 02:44:51 UTC
(In reply to comment #60)
> Nominate Bug #32991 - FORMATTING TABLES Alignment lost when exporting to DOC
> It is regression. Many people use tables, many people export to doc.
> Would be nice to fix it.

It seems to be pretty old bug. We are sorry but it does not fit the release blocker criteria.
Comment 64 Michael Meeks 2011-01-13 02:46:53 UTC
drop bug #32930, Linux and Java specific, and specific to LanguageTool that we don't bundle now; moving it to 3.3.1 in case we have a fix by then.
Comment 65 Lionel Elie Mamane 2011-01-13 15:31:03 UTC
I'd like to nominate #32964 and #32960: they both break a rather basic functionality, which is having reports with grouping and/or sorting. They both imply regressions in some cases.
Comment 66 mal 2011-01-14 01:54:23 UTC
(In reply to comment #44)
> (In reply to comment #42)
> > I would like to nominate bug 32573. Not being able to print landscape is a bit 
> > of a problem for a word processor.
> 
> I am not able to reproduce it. It seems to be system specific, so I do not
> consider it as a blocker for now.

Using the XPS driver works, using a real printer doesn't - RC3 is the same
Comment 67 mal 2011-01-14 02:42:07 UTC
(In reply to comment #66)
> (In reply to comment #44)
> > (In reply to comment #42)
> > > I would like to nominate bug 32573. Not being able to print landscape is a bit 
> > > of a problem for a word processor.
> > 
> > I am not able to reproduce it. It seems to be system specific, so I do not
> > consider it as a blocker for now.
> 
> Using the XPS driver works, using a real printer doesn't - RC3 is the same

Forget this, I withdraw it as a blocker, however I do still think it's a bug
If you use Postscript printer drivers it works fine, PCL5c and PCL6 don't for 
me at least
Comment 68 Michael Meeks 2011-01-14 02:58:50 UTC
add 33099 - crasher with no help pack when selecting help.
Comment 69 Rainer Bielefeld Retired 2011-01-15 07:09:30 UTC
I nominate Bug 33151 - Onlinehelp: Danish and Hungarian contents
Comment 70 Michael Meeks 2011-01-17 03:48:52 UTC
we need a decision on bug#33135 and bug#33105 is an l10n blocker too.
Comment 71 Peter Lairo 2011-01-17 07:46:30 UTC
I'm unsubscribing from this bug (and all LibereOffice bugs) because bugs.freedesktop.org uses an untrusted security certificate, and I am tired of clicking away the warning dialog(s) for every e-mail bug report I receive in Thunderbird.

Who thought that using the untrusted certificate from CAcert was a good idea?

See: https://bugzilla.mozilla.org/show_bug.cgi?id=215243#c158
Comment 72 clio 2011-01-24 11:36:14 UTC
bug 33355 consider to be a blocker
Comment 73 Thorsten Behrens (CIB) 2011-01-25 02:50:28 UTC
No new blockers after RC4 phase, this makes RC4 into final -> fixed.
Comment 74 Michael Meeks 2011-01-25 09:19:31 UTC
Any new blocker bugs need to go vs. the 3.3.1 release - ie. as dependents of bug#32894. Please add new issues there. We need to retire this bug now :-)