Bug 46901 - SLIDESHOW shows characters too slim with Hardware Acceleration activated - cairo canvas used in error on windows.
Summary: SLIDESHOW shows characters too slim with Hardware Acceleration activated - ca...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.1 RC1
Hardware: Other Windows (All)
: medium major
Assignee: Michael Meeks
URL:
Whiteboard: target:3.6.0 target:3.5.3
Keywords: regression
: 46532 46899 47491 47614 47711 47812 47948 47998 48036 48313 (view as bug list)
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2012-03-02 08:23 UTC by Rainer Bielefeld Retired
Modified: 2018-02-23 08:18 UTC (History)
20 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots (123.07 KB, application/pdf)
2012-03-03 00:17 UTC, Rainer Bielefeld Retired
Details
Sample Presentation to illustrate the bug (313.06 KB, application/vnd.oasis.opendocument.presentation)
2012-03-14 15:06 UTC, bellgardt
Details
Screen shoot for the rendering bug (127.68 KB, image/png)
2012-03-14 15:10 UTC, bellgardt
Details
The bold Chinese characters in the first slide looks fat and ugly during slideshow. (1.43 MB, application/vnd.oasis.opendocument.presentation)
2012-03-21 07:29 UTC, Cheng-Chia Tseng
Details
LibreOffice Hardware Acceleration makes bold Chinese characters look fat and ugly. (421.04 KB, image/png)
2012-03-21 07:41 UTC, Cheng-Chia Tseng
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-03-02 08:23:06 UTC
With sample document in test kit for "Bug 46532 - SLIDESHOW does not show pictures with Hardware Acceleration activated"
<https://bugs.freedesktop.org/attachment.cgi?id=57920>
characters on first slide will be shown too slim during slide show with Hardware Acceleration activated.

Steps how to reproduce with "LibreOffice 3.5.1.1 German UI/Locale [Build-ID: 45a2874-aa8c38d-dff3b9c-def3dbd-62463c8] on German WIN7 Home Premium (64bit) and a.m. sample:

1. open document, activate menu 'Tools -> Options -> Viewing -> 
   Hardware acceleration' if necessary
2. start slide show with first slide and compare text view with text view in 
   edit mode. 
   Expected: no difference
   Actual: During slide show character width is reduced, bigger spaces 
           between characters

The ugly text also is visible with presentations created from the scratch.

This makes existing presentations (for example our marketing material like Cor's "liboconf2011_improving_qa_release_cycle-cornouws.mini" or Andreas' "libreoffice_openrheinruhr2011_11_13") unusable wiht HA, looks too ugly.
Comment 1 Thorsten Behrens (CIB) 2012-03-02 08:58:51 UTC
(In reply to comment #0)
> The ugly text also is visible with presentations created from the scratch.
> 
Is that a regression relative to 3.5.0 / 3.4? Currently don't see it on Linux for a recent master, but will try different fonts.
Comment 2 sasha.libreoffice 2012-03-02 23:48:00 UTC
can not reproduce problem in 3.5.0 beta 3 on Windows XP 32 bit
and on 3.5.0 rc 3 on Fedora 64 bit
Please, attach screenshot (if possible) and verify if it is not because wrong animation or slide transition playing
Comment 3 Rainer Bielefeld Retired 2012-03-03 00:17:35 UTC
Created attachment 57955 [details]
Screenshots

For me the problem depends on nothing than Hardware Acceleration, for me it appears always parallel when I see problem of "Bug 46532" SLIDESHOW does not show pictures with Hardware Acceleration activated"
Comment 4 Rainer Bielefeld Retired 2012-03-03 02:25:56 UTC
I can reproduce the problem with LibO I can reproduce the problem with LibO 3.5.1.1 German on German WIN XP 32bit on VirtualBox German on German WIN XP 32bit on VirtualBox
Comment 5 Cor Nouws 2012-03-03 13:54:33 UTC
I can confirm the bug in 3.5.1.1 on Win 7

(And in a build from master Build ID: 9518535-d09cf17-8a74106-c695ecd-16afab)
Comment 6 khagaroth 2012-03-14 10:02:38 UTC
I can also reproduce it, on Windows 7 32bit with 3.5.1.2. Now, I think the severity should be raised by a notch, it not only causes wrong display of font characters, but enabling hardware acceleration also causes images to not be displayed at all on my system.
Comment 7 bellgardt 2012-03-14 15:03:38 UTC
I observed same problems with LO3.5.1.2 on Windows Vista 32bit. Without hardware acceleration the slide show runs fine. With active acceleration graphics objects and images disappear. In addition, in my system there is no slide change. the information of all slides is rendered over each other, change to a new slide does not erase the previous content. A sample file and screen shoot after stepping through slides 1 to 4 is added as attachment

When graphics objects are animated they are shown during animation, but afterwards disappear. Any following animation triggers a flash of graphics objects drawn before (can be seen in slide 5 of the sample file).
Comment 8 bellgardt 2012-03-14 15:06:59 UTC
Created attachment 58454 [details]
Sample Presentation to illustrate the bug
Comment 9 bellgardt 2012-03-14 15:10:48 UTC
Created attachment 58455 [details]
Screen shoot for the rendering bug
Comment 10 Rainer Bielefeld Retired 2012-03-19 07:25:42 UTC
*** Bug 47509 has been marked as a duplicate of this bug. ***
Comment 11 Cheng-Chia Tseng 2012-03-21 07:27:54 UTC
On my fedora x64 LibO 3.4, Chinese characters of bold type will become fat and ugly.

The presentation file and screenshot will be uploaded.
Comment 12 Cheng-Chia Tseng 2012-03-21 07:29:24 UTC
Created attachment 58810 [details]
The bold Chinese characters in the first slide looks fat and ugly during slideshow.
Comment 13 Cheng-Chia Tseng 2012-03-21 07:41:06 UTC
Created attachment 58811 [details]
LibreOffice Hardware Acceleration makes bold Chinese characters look fat and ugly.
Comment 14 michael.fronk 2012-03-21 07:59:36 UTC
I can confirm the bug. The systematic of displayed or undisplayed images is somewhat unclear. But the fonts are corrupted as described in other posts and it cannot be switched between the slides.
My system is Windows 7 64bit, LibreOffice 3.5.1.2. Since the bug is only present with hardware acceleration switched on it is maybe worth to mention the graphics card configuration: NVidia GeForce GT 330M with the latest driver version 296.10 in my case.
Maybe an AMD or Intel card user can make a statement whether the font/image bug is also present on his/her system?
Comment 15 manj_k 2012-03-21 08:02:49 UTC
*** Bug 47614 has been marked as a duplicate of this bug. ***
Comment 16 vitriol 2012-03-21 11:44:25 UTC
*** Bug 47673 has been marked as a duplicate of this bug. ***
Comment 17 Don't use this account, use tml@iki.fi 2012-03-22 05:59:22 UTC
Cheng-Chia Tseng: Please file a separate bug for the issue you see on Linux. This bug report is about a Windows-specific problem.
Comment 18 Cheng-Chia Tseng 2012-03-22 06:34:48 UTC
Sorry, I did not notice "Windows (All)" platform. My bad. :P
Comment 19 Rainer Bielefeld Retired 2012-03-22 07:28:03 UTC
@Cheng-Chia Tseng 
Of course it's not impossible that a WIN Bug becomes "All", but with your sample under WIN I only see the "too slim" problem, not your Linux "look fat and ugly" problem.
Comment 20 info.kalsan 2012-03-22 09:43:54 UTC
https://bugs.freedesktop.org/show_bug.cgi?id=47673 happened under Linux. You can use that as Linux bug report if you want.
Comment 21 Milos Sramek 2012-03-22 23:50:34 UTC
(In reply to comment #14)
> I can confirm the bug. The systematic of displayed or undisplayed images is
> somewhat unclear. But the fonts are corrupted as described in other posts and
> it cannot be switched between the slides.
> My system is Windows 7 64bit, LibreOffice 3.5.1.2. Since the bug is only
> present with hardware acceleration switched on it is maybe worth to mention the
> graphics card configuration: NVidia GeForce GT 330M with the latest driver
> version 296.10 in my case.
> Maybe an AMD or Intel card user can make a statement whether the font/image bug
> is also present on his/her system?

I think that this bug has nothing to do with the graphics card. I run win7 in Virtualbox, with HA switched off both on my host (Ubuntu 11.10) and on the Virtualbox machine. The bug is still present, if I switch HA on in LO. So, I guess, this is solely a problem of LO.
m
Comment 22 manj_k 2012-03-23 15:56:32 UTC
*** Bug 47711 has been marked as a duplicate of this bug. ***
Comment 23 Pedro 2012-03-24 08:52:36 UTC
This is a major bug and needs to be fixed ASAP.

It is a regression against 3.5.0 and since Hardware Acceleration is enabled by default it affects ALL Windows users.

It makes Impress 3.5.1 unusable for presentations.
Comment 24 Jacek Piskozub 2012-03-27 12:02:12 UTC
Confirming with an Intel card on Asus Eee (Win XP).
Comment 25 info.kalsan 2012-03-28 02:23:36 UTC
> It is a regression against 3.5.0 and since Hardware Acceleration is enabled by
> default it affects ALL Windows users.
Not only Windows. Linux is affected as well.
Comment 26 Michael Meeks 2012-03-29 03:05:47 UTC
So - this is in fact for Windows what bug#45584 was for mac - accidentally enabling the cairo canvas code, as part of an unrelated configuration cleanup. It should be trivial to fix: just adding one more configure parameter to the Windows build.

Of course, it'd be great if the underlying issue bug#46901

Thanks for the report ! Fridrich is on it ...
Comment 27 Not Assigned 2012-03-29 03:14:02 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6219ff898a8c3ae6b7abe4272b4b68cc986093e4

Disable cairo canvas on Windows fdo#46901 fdo#46532
Comment 28 Michael Meeks 2012-03-29 03:18:22 UTC
So - split the Linux piece of this (ie. cairo canvas there) off to 43009 - will mark that as a MAB in a second.

This one is basically 'use cairo canvas in error on windows' so re-titling and closing - should be fixed in 3.5.2rc2+1 ;-)
Comment 29 Michael Meeks 2012-03-29 03:19:51 UTC
*** Bug 46532 has been marked as a duplicate of this bug. ***
Comment 30 Not Assigned 2012-03-29 03:20:04 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=92330ae0ae1c584903f8024b24d89e9723cbf6a6&g=libreoffice-3-5

Disable cairo canvas on Windows fdo#46901 fdo#46532


It will be available in LibreOffice 3.5.3.
Comment 31 Only A Test Account, do not aadd to CC! 2012-03-29 03:24:43 UTC
@Michael Meeks: 
Thx for fix. I reintroduced old subject because that will ease queries for DUPs
Comment 32 Only A Test Account, do not aadd to CC! 2012-03-29 03:27:20 UTC
*** Bug 48036 has been marked as a duplicate of this bug. ***
Comment 33 jkonecny 2012-03-29 06:29:53 UTC
*** Bug 47998 has been marked as a duplicate of this bug. ***
Comment 34 manj_k 2012-03-29 07:14:55 UTC
*** Bug 47812 has been marked as a duplicate of this bug. ***
Comment 35 Arturo Espinosa 2012-03-29 17:45:11 UTC
Thank-you, Michael Meeks, you rule. I have a Win7 Toshiba Quosmio laptop and I have hardware acceleration disabled now to make the slideshow work. Honestly, I don't notice any performance difference, compdared to HW accel activated (on the screen; maybe my CPU goes crazy during transitions and effects).

Thanks again. Will be waiting for the upgrade.
Comment 36 jkonecny 2012-03-30 07:10:45 UTC
Everything looks good under 3.5.2.2!  Thanks!
Comment 37 Rainer Bielefeld Retired 2012-04-01 02:11:43 UTC
*** Bug 47673 has been marked as a duplicate of this bug. ***
Comment 38 Rainer Bielefeld Retired 2012-04-04 09:28:53 UTC
Assignation due to facts

@Michael
in "Bug 47673 - SLIDESHOW: Century Schoolbook L too "narrow" in slideshow" we have very similar symptoms, but probably a different root (appeared already in more early versions). I will add you to CC there.
Comment 39 Rainer Bielefeld Retired 2012-04-04 11:11:53 UTC
*** Bug 47948 has been marked as a duplicate of this bug. ***
Comment 40 Rainer Bielefeld Retired 2012-04-05 02:17:04 UTC
*** Bug 48313 has been marked as a duplicate of this bug. ***
Comment 41 Rainer Bielefeld Retired 2012-04-28 04:41:02 UTC
*** Bug 47491 has been marked as a duplicate of this bug. ***
Comment 42 ign_christian 2013-05-18 17:21:27 UTC
*** Bug 46899 has been marked as a duplicate of this bug. ***
Comment 43 Green Wood 2018-02-23 06:21:06 UTC
On Windows, using LibreOffice 3.5.1.2, when I create a presentation using Impress, the Slide Show (F5) cuts off the bottom and top (similar to wide-screen movies) and thus changes the aspect ratio, messing up the fonts. What gets messed up, in particular, is the spacing between letters, which gets stretched a lot. For other error in the Apple visit us https://notresponding.net/itunes-error-56/