Download it now!
Bug 128524 - tip of the day window missing line breaks
Summary: tip of the day window missing line breaks
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All All
: medium trivial
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.4.0 target:6.3.4
Keywords:
: 127926 128578 128841 128865 128928 128945 128962 129108 129116 129212 129249 129453 129748 129981 130017 130464 (view as bug list)
Depends on: 127994
Blocks: Tip-Of-The-Day
  Show dependency treegraph
 
Reported: 2019-11-01 07:51 UTC by sergio.callegari
Modified: 2020-02-05 17:58 UTC (History)
21 users (show)

See Also:
Crash report or crash signature:


Attachments
bad limited image proportions (51.68 KB, image/png)
2019-11-09 18:09 UTC, Ever Fretes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2019-11-01 07:51:55 UTC
Description:
At the start of the newer versions of LibO, one gets a "Tip of the day" window, with a short message and a button to get more information.
Unfortunately the tip of the day message is not auto wrapped on multiple lines adapting to the window size. As a consequence, the message is almost invariably truncated and not understandable at all.

Steps to Reproduce:
Start LibO

Actual Results:
Get a tip of the day window with a single line tip of the day message truncated to a few words depending on the window width

Expected Results:
The short tip of the day message should always be shown entirely, word-wrapping it into multiple lines as needed.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Heiko Tietze 2019-11-02 10:28:23 UTC
Can you please try with a daily build? https://dev-builds.libreoffice.org/daily/master/ (and I guess you are running Windows).
Comment 2 sdc.blanco 2019-11-03 00:09:06 UTC
With 6.3.3.1 (Windows) I also get "one-line" tips.  (The text is not truncated.  It is possible to resize the Tip window so that the entire text becomes visible.

No problems with display (and not possible to resize Tip window) in:
Version: 6.4.0.0.alpha1 (x64)
Build ID: cc57df8f942f239d29cb575ea5a7cb01405db787
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win;
Comment 3 raal 2019-11-06 22:23:56 UTC
*** Bug 128578 has been marked as a duplicate of this bug. ***
Comment 4 Heiko Tietze 2019-11-07 07:20:09 UTC
(In reply to sdc.blanco from comment #2)
> No problems with display (and not possible to resize Tip window) in:
> Version: 6.4.0.0.alpha1 (x64)

Xisco, should we backport the patch to 6.3.3.2 or 6.3.4?
Comment 5 Xisco Faulí 2019-11-07 09:39:29 UTC
(In reply to Heiko Tietze from comment #4)
> (In reply to sdc.blanco from comment #2)
> > No problems with display (and not possible to resize Tip window) in:
> > Version: 6.4.0.0.alpha1 (x64)
> 
> Xisco, should we backport the patch to 6.3.3.2 or 6.3.4?

Hi Heiko,
I bisected it to find which commit fixed it, unfortunately I can reproduce it in the latest commit of bibisect-linux64-6.3 and I can't reproduce it in the oldest of bibisect-linux64-6.4.
Do you know, by any chance, which commit fixed this issue ?
Comment 6 Heiko Tietze 2019-11-07 10:37:13 UTC
(In reply to Xisco Faulí from comment #5)
> Do you know, by any chance, which commit fixed this issue ?

Could be Ib974417282c76b4cede1b4773159b1fa748ddbfb and I26bdb7bc3fc7ad2037438f4fceba51388e4121eb but also If0e0b04be8f7086d18fe3481c3bd8f65b48a0676 which was reverted in I7b63e0e29a22f3feddac99ac42735a1880a9b1c2
Comment 7 Xisco Faulí 2019-11-08 13:15:40 UTC
*** Bug 127926 has been marked as a duplicate of this bug. ***
Comment 8 Ever Fretes 2019-11-09 18:09:32 UTC
Created attachment 155667 [details]
bad limited image proportions

And resizing vertically, the image lose it's shape
Comment 9 Heiko Tietze 2019-11-11 08:30:37 UTC
(In reply to Ever Fretes from comment #8)
> bad limited image proportions

The issue is solved in 6.4 and we are looking for a solution to backport to the 6.3 line.
Comment 10 Ray-V 2019-11-14 22:17:39 UTC
I'm getting this issue with 6.3.3.2 on Linux - 6.3.2.2 is OK.

cui/uiconfig/ui/tipofthedaydialog.ui#141
                    <property name="selectable">True</property>
was added for 6.3.3.2, and with that set to True, and using the gen or gtk vcl plugin, the text in the dialog window doesn't wrap.

Set it to False and the text *does* wrap.

For LO installed, this file is at:
share/config/soffice.cfg/cui/ui/tipofthedaydialog.ui
and I can toggle wrap/non-wrap by setting "selectable" in that file.

Using the gtk3 vcl plugin displays wrapped text whether it's "selectable" or not.

One other observation is that for the gen or gtk vcl plugins, the wrapped text is centred, but with the gtk3 vcl plugin, the text is aligned left.
Comment 11 Heiko Tietze 2019-11-15 07:58:44 UTC
This patch https://gerrit.libreoffice.org/#/c/82672/ and that one https://gerrit.libreoffice.org/#/c/82750/ should solve the problem for 6.3 (Xisco, do I have to cherry-pick for 6.4 as well?)
Comment 12 Heiko Tietze 2019-11-15 08:05:17 UTC
(In reply to Ray-V from comment #10)
> Using the gtk3 vcl plugin displays wrapped text whether it's "selectable" or
> not.

Thanks for testing. The issue is reported in bug 127537 (as blocker for bug 127317).
Comment 13 Xisco Faulí 2019-11-15 09:17:13 UTC
(In reply to Heiko Tietze from comment #11)
> This patch https://gerrit.libreoffice.org/#/c/82672/ and that one
> https://gerrit.libreoffice.org/#/c/82750/ should solve the problem for 6.3
> (Xisco, do I have to cherry-pick for 6.4 as well?)

Nein
Comment 14 Heiko Tietze 2019-11-15 10:24:59 UTC
(In reply to Xisco Faulí from comment #13)
> Nein

Gracias
Comment 15 Heiko Tietze 2019-11-16 18:39:17 UTC
*** Bug 128841 has been marked as a duplicate of this bug. ***
Comment 16 V Stuart Foote 2019-11-18 01:53:08 UTC
*** Bug 128865 has been marked as a duplicate of this bug. ***
Comment 17 V Stuart Foote 2019-11-21 04:36:58 UTC
*** Bug 128928 has been marked as a duplicate of this bug. ***
Comment 18 Roman Kuznetsov 2019-11-22 14:26:44 UTC
*** Bug 128945 has been marked as a duplicate of this bug. ***
Comment 19 Roman Kuznetsov 2019-11-22 14:27:35 UTC
*** Bug 128962 has been marked as a duplicate of this bug. ***
Comment 20 Ming Hua 2019-11-30 18:32:41 UTC
*** Bug 129108 has been marked as a duplicate of this bug. ***
Comment 21 V Stuart Foote 2019-12-06 04:42:04 UTC
*** Bug 129212 has been marked as a duplicate of this bug. ***
Comment 22 Xisco Faulí 2019-12-06 21:34:39 UTC
*** Bug 129249 has been marked as a duplicate of this bug. ***
Comment 23 Xisco Faulí 2019-12-11 14:09:33 UTC
*** Bug 129116 has been marked as a duplicate of this bug. ***
Comment 24 Heiko Tietze 2019-12-18 07:04:29 UTC
*** Bug 129453 has been marked as a duplicate of this bug. ***
Comment 25 V Stuart Foote 2020-01-02 20:58:24 UTC
*** Bug 129748 has been marked as a duplicate of this bug. ***
Comment 26 Blaz3Witch 2020-01-05 13:52:22 UTC
I am using the same version in Ubuntu Studio (updated), and the "tip of the day" text is not wrapped. I have to elongate the window in order to see the entire text.
Comment 27 V Stuart Foote 2020-01-05 14:11:48 UTC
(In reply to Blaz3Witch from comment #26)
> I am using the same version in Ubuntu Studio (updated), and the "tip of the
> day" text is not wrapped. I have to elongate the window in order to see the
> entire text.

Look in the Help -> About dialog. A build of LibreOffice before 6.3.4 or 6.4.0 will show the new tip-of-the-day feature without line breaks. Fixed for later builds.
Comment 28 John Thomas Lenaghan 2020-01-05 19:23:57 UTC
Upgraded to Version: 6.3.4.2 (x64). Tip does not appear. In 'safe mode' tip appears and works well - will try again after a restart.
Comment 29 Heiko Tietze 2020-01-06 08:33:11 UTC
(In reply to John Thomas Lenaghan from comment #28)
> Upgraded to Version: 6.3.4.2 (x64). Tip does not appear. In 'safe mode' tip
> appears and works well - will try again after a restart.

Please file a new ticket (cannot reproduce though). This was about line breaks.
Comment 30 John Thomas Lenaghan 2020-01-07 02:26:47 UTC
Upgrading [eventually] fixed the bug
Comment 31 John Thomas Lenaghan 2020-01-07 19:45:35 UTC
Fix worked for a while. Then the tip window failed to appear on startup altogether. Replace one bug with another - effective!
Comment 32 Xisco Faulí 2020-01-13 12:43:21 UTC
*** Bug 129981 has been marked as a duplicate of this bug. ***
Comment 33 V Stuart Foote 2020-01-15 16:27:00 UTC
*** Bug 130017 has been marked as a duplicate of this bug. ***
Comment 34 V Stuart Foote 2020-02-05 17:58:29 UTC
*** Bug 130464 has been marked as a duplicate of this bug. ***