Bug 86544 (Firefox-Themes) - [META] Personalization: New browser for Firefox themes improvements
Summary: [META] Personalization: New browser for Firefox themes improvements
Status: RESOLVED WORKSFORME
Alias: Firefox-Themes
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 59611 60543 61311 86610 88502 90572 93195 93599 99776 99837 99897 101629 101733 107266 107417 113385 117866 118881 119127 119868 120475 120506 120742 120743 120745 120746 120747 121004 121289 121517 121937 122242 122288 122341 123050 123228 123831 123911 124308 124311
Blocks: UI-Theming
  Show dependency treegraph
 
Reported: 2014-11-21 23:03 UTC by A (Andy)
Modified: 2019-06-10 13:29 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description A (Andy) 2014-11-21 23:03:00 UTC
Tested with LO 4.4.0.0.beta1.

i)
The new browser for Firefox themes looks already very good.  But one thing I am missing is a scrollbar, because I suppose there are more than the shown nine themes.  But one drawback could be that it takes quite long to load them (at least at my pc it takes several seconds - with a search term around 40 seconds).  Therefore, I am not sure whether a scrollbar is really good as long as the previews are not loaded faster.
It would also be good if the load rate could be improved further if possible.

ii)
Furthermore, after you have inserted the Firefox theme it would be good if the selected theme would also be shown in the Personalisation dialogue.

iii)
Maybe, it would also be nice to have an option to show and select the for instance last three selected themes.

iv)
Probably, it would also be good to get preview pictures from the top right section of the themes, because there you will mostly find something?
-> To test: Enter the search term "Tree" -> Result: The bottom left and the two lower right previews show nothing, although the themes have pictures in the top right.

v)
If you enter any search term the Search button should be selected not the OK button.
-> To test: Enter any search term and Press the Enter key to start the search -> Result: The dialogue box is closed.
Comment 1 Robinson Tryon (qubit) 2014-11-23 12:29:10 UTC
(In reply to A (Andy) from comment #0)
> Tested with LO 4.4.0.0.beta1.

Me, too (on Ubuntu 14.04)

REPRO STEPS:
1) Open LibreOffice
2) Open browser via Tools -> Options -> Personalization
3) Click 'Select Theme' button

> i)
> The new browser for Firefox themes looks already very good.  But one thing I
> am missing is a scrollbar, because I suppose there are more than the shown
> nine themes.  But one drawback could be that it takes quite long to load
> them (at least at my pc it takes several seconds - with a search term around
> 40 seconds).  Therefore, I am not sure whether a scrollbar is really good as
> long as the previews are not loaded faster.
> It would also be good if the load rate could be improved further if possible.
> 
> ii)
> Furthermore, after you have inserted the Firefox theme it would be good if
> the selected theme would also be shown in the Personalisation dialogue.
> 
> iii)
> Maybe, it would also be nice to have an option to show and select the for
> instance last three selected themes.
> 
> iv)
> Probably, it would also be good to get preview pictures from the top right
> section of the themes, because there you will mostly find something?
> -> To test: Enter the search term "Tree" -> Result: The bottom left and the
> two lower right previews show nothing, although the themes have pictures in
> the top right.
> 

These all sound great. The speed issue is rather an embarrassment.

> v)
> If you enter any search term the Search button should be selected not the OK
> button.
> -> To test: Enter any search term and Press the Enter key to start the
> search -> Result: The dialogue box is closed.

Most search boxes work with the Enter key, so yes, I've run into this problem many times myself.

Marking this as an enhancement, and Status -> NEW. A bunch of good ideas! (which we might want to split up into separate bugs at some point...)
Comment 2 Peter Maunder 2014-11-25 11:23:52 UTC
I am a great fan of the Personas themes and use them on Firefox, Thunderbird and LibO to give a consistent look across the products.
As I mostly use my own Personas, the improvement I would most like to have is the ability to directly add my own or downloaded themes sitting on my computer. So I would like the first theme box to be an in-house Personas Folder which does not need to be downloaded. Firefox and Thunderbird has this facility called CUSTOM PERSONAS. For me this would also bypass any performance issues waiting for the Personas panels to be set up.

59611 Use of Personas refers to this addition amongst others.
Comment 3 Cor Nouws 2014-12-23 21:16:32 UTC
(In reply to Peter Maunder from comment #2)
> As I mostly use my own Personas, the improvement I would most like to have
> is the ability to directly add my own or downloaded themes sitting on my

In addition to that: add a line where one can paste an url as we had in the previous version. That allows to add a specific theme from the Firefox website.
Comment 4 Cor Nouws 2014-12-23 21:21:19 UTC
set to UX-advise and add Kendy as he knows the people that worked on this (I expect)

See here feature in the release notes
  https://wiki.documentfoundation.org/ReleaseNotes/4.4#Firefox_Themes
Comment 5 Cor Nouws 2015-01-17 12:21:13 UTC
*** Bug 88502 has been marked as a duplicate of this bug. ***
Comment 6 Pedro 2015-01-17 13:37:18 UTC
+1 on all the suggested improvements plus an old suggestion

vi) The Theme dialog shows the name and the link (even if it's local, as suggested on Comment #2) of the currently loaded theme.

One comment on the EXTREMELY slow speed: the miniatures in the theme dialog are NOT the same as those in the Firefox theme page, so maybe the code is creating new thumbnails instead of simply downloading those on the Firefox site?
Comment 7 Cor Nouws 2015-02-11 02:35:32 UTC
*** Bug 89302 has been marked as a duplicate of this bug. ***
Comment 8 Adolfo Jayme 2015-02-22 06:55:27 UTC
Turning this into a meta issue, the new black for people who can’t create focused bug reports. :-P
Comment 9 Dave Barton 2019-05-18 09:09:59 UTC
See also my comment on Bug 125217
Comment 10 Heiko Tietze 2019-05-24 07:20:36 UTC
Muhammet, please also kill the meta ticket or convert into "LoibreOffice Themes".
Comment 11 Muhammet Kara 2019-05-24 09:24:31 UTC
(In reply to Heiko Tietze from comment #10)
> Muhammet, please also kill the meta ticket or convert into "LoibreOffice
> Themes".

Already in my TODO list. ;)
Comment 12 Muhammet Kara 2019-06-10 12:01:02 UTC
There is no longer support for the Firefox Themes (Personas), and no FF Personas browser either in LibreOffice now.

Personalization bugs will be tracked from here: https://bugs.documentfoundation.org/show_bug.cgi?id=125823